Closed Bug 946233 Opened 7 years ago Closed 7 years ago

Revert FF28 to single quickshare behaviour

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 28
Tracking Status
firefox27 --- unaffected
firefox28 --- verified
firefox29 --- wontfix

People

(Reporter: lucasr, Assigned: lucasr)

References

Details

Attachments

(1 file)

We'll land this in FF28 after the merge.
Comment on attachment 8342396 [details] [diff] [review]
Revert to single quickshare behaviour (r=wesj)

This patch:
1. Moves the 'Share' menuitem back to its original position.
2. Forces UI to show only one quickshare item.
Attachment #8342396 - Flags: review?(wjohnston)
Comment on attachment 8342396 [details] [diff] [review]
Revert to single quickshare behaviour (r=wesj)

Review of attachment 8342396 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/base/widget/GeckoActionProvider.java
@@ -55,5 @@
>  
>          final PackageManager packageManager = mContext.getPackageManager();
>          int historySize = dataModel.getDistinctActivityCountInHistory();
> -        if (historySize > 2) {
> -            historySize = 2;

We should make this a const.
Attachment #8342396 - Flags: review?(wjohnston) → review+
Comment on attachment 8342396 [details] [diff] [review]
Revert to single quickshare behaviour (r=wesj)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 937829 (multiple quick share)
User impact if declined: The multi-quickshare feature was not completed in time for FF28. We decided to disable it in FF28 while we work on it in FF29. 
Testing completed (on m-c, etc.): Local tests, works fine. This patch is only for FF28, not Nightly.
Risk to taking this patch (and alternatives if risky): Low, simply forces a maximum of one quick share button and moves the 'Share' menu item back to its original position.   
String or IDL/UUID changes made by this patch: n/a
Attachment #8342396 - Flags: approval-mozilla-aurora?
Attachment #8342396 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Blocks: 957097
(In reply to Wesley Johnston (:wesj) from comment #3)
> Comment on attachment 8342396 [details] [diff] [review]
> Revert to single quickshare behaviour (r=wesj)
> 
> Review of attachment 8342396 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: mobile/android/base/widget/GeckoActionProvider.java
> @@ -55,5 @@
> >  
> >          final PackageManager packageManager = mContext.getPackageManager();
> >          int historySize = dataModel.getDistinctActivityCountInHistory();
> > -        if (historySize > 2) {
> > -            historySize = 2;
> 
> We should make this a const.

Done. I filed bug 957097 to do the same in m-c.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
Status: RESOLVED → VERIFIED
Blocks: 937828
You need to log in before you can comment on or make changes to this bug.