Closed Bug 941058 Opened 6 years ago Closed 6 years ago

Buttons in titlebar swapped in RTL UI

Categories

(Firefox :: Toolbars and Customization, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 28

People

(Reporter: smontagu, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Keywords: rtl, Whiteboard: [Australis:P1])

Attachments

(2 files, 2 obsolete files)

In Australis RTL UI in OSX the close/minimize/zoom buttons are at the right of the titlebar and the go-full-screen control on the left, swapped from the way they appear in all other windows.
Gijs asked me to needinfo mstange on this
Flags: needinfo?(mstange)
I discussed this with Markus on IRC. The problem is actually pretty simple: because of bug 851652, we now draw the titlebar buttons based on the frames of the elements in the #titlebar. Those get reordered in RTL, and we need to ensure that that only happens on non-mac. We should probably remove the #ifdefs for this in browser.xul and instead use browser/base/content/browser.css that takes RTL into account.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Depends on: 851652
Flags: needinfo?(mstange)
Whiteboard: [Australis:P1]
Moving the code to browser/base because themes shouldn't have to worry about getting this right.
Attachment #8335416 - Flags: review?(mdeboer)
Good thing you made me check, there was another issue with this patch...
Attachment #8335443 - Flags: review?(mdeboer)
Attachment #8335416 - Attachment is obsolete: true
Attachment #8335416 - Flags: review?(mdeboer)
Comment on attachment 8335443 [details] [diff] [review]
titlebar buttons are swapped in RTL mode,

Review of attachment 8335443 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/base/content/browser.xul
@@ +430,1 @@
>  #endif

I think you can remove this entire #ifndef block and move it browser/base/content/browser.css
Attachment #8335443 - Flags: review?(mdeboer) → review-
Plonk.
Attachment #8335967 - Flags: review?(mdeboer)
Attachment #8335443 - Attachment is obsolete: true
Comment on attachment 8335967 [details] [diff] [review]
[Australis] titlebar buttons are swapped in RTL mode,

Review of attachment 8335967 [details] [diff] [review]:
-----------------------------------------------------------------

Awesome, we're there!
Attachment #8335967 - Flags: review?(mdeboer) → review+
remote:   https://hg.mozilla.org/integration/fx-team/rev/d7a2934c4548
Whiteboard: [Australis:P1] → [Australis:P1][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/d7a2934c4548
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P1][fixed-in-fx-team] → [Australis:P1]
Target Milestone: --- → Firefox 28
Depends on: 1275650
You need to log in before you can comment on or make changes to this bug.