[B2G][Homescreen] Able to open apps from adjacent homescreen panes

RESOLVED FIXED

Status

Firefox OS
Gaia::Homescreen
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: gbennett, Assigned: crdlc)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(firefox28 affected, b2g18 affected, b2g-v1.2 affected)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Description:
User is able to open apps from adjacent homescreen panes without actually viewing the app itself (see youtube video for clarification).

Repro Steps:
1) Updated Buri 1.3 mozRIL to BuildID: 20131120004000
2) Go to a homescreen
3) Gently and quickly partially move from one homescreen panel to another that has an app on the adjacent screen near where you are touching. (see youtube video for repro)

Actual:
User is able to select an app they cannot see.

Expected:
Apps cannot be launched until transition animation completes.

Environmental Variables:
Device: Buri 1.3 mozRIL
BuildID: 20131120004000
Gaia: 5ec2963fff60492c840707df8d8090f9908a5251
Gecko: 2d454e0de2ed
Version: 26.0
Firmware Version: 20131115

Notes: This does not occur on android devices.

Repro frequency: 100%
See attached: http://www.youtube.com/watch?v=O2pKKdqX-YM
Does this reproduce on 1.1?
Keywords: qawanted

Updated

4 years ago
QA Contact: sarsenyev

Comment 2

4 years ago
The issue doesn't reproduce on 1.1 or 1.3, the bug is written for 1.2 MozRIL
User is unable to select an app they cannot see.

Device: Leo 1.1
BuildID: 20131120041201
Gaia: b585b32441fafa67f2b4582db23be5f3a2afab21
Gecko: a9fa9a04390d
Version: 18.0
Firmware: V10c

Updated

4 years ago
Keywords: qawanted
That doesn't make a whole lot of sense. The affected flag here states this reproduces on 1.3. Please double check this with gbennett.
Flags: needinfo?(sarsenyev)

Comment 4

4 years ago
The YouTube video shows how easy and fast it reproduces on 1.2, you can retrieve any app even when gently touching near to an app.
But on 1.3 it's took about 10-20 seconds of fast touching close to the edge of the first screen to retrieve the closest app from the second screen
Flags: needinfo?(sarsenyev)
(Reporter)

Comment 5

4 years ago
Repro'd this issue on the following builds

Environmental Variables:
Device: Buri 1.3 mozRIL
BuildID: 20131121040202
Gaia: 71063dd91bc8cbb15ba335236ed67a1c5058bd58
Gecko: cf378dddfac8
Version: 28.0a1
Firmware Version: 20131115

Environmental Variables:
Device: Buri 1.2 comRIL
BuildID: 20131121004002
Gaia: ce276842c9ac1746073271fb736dfdb626a89240
Gecko: 36c4c667b9f2
Version: 26.0
Firmware Version: 20131115

Environmental Variables:
Device: Leo 1.1 mozRIL
BuildID: 20131120041201
Gaia: b585b32441fafa67f2b4582db23be5f3a2afab21
Gecko: a9fa9a04390d
Version: 18.0
Firmware Version: V10d

Sorry about the confusion in comment zero. I checked 1.3, 1.2, and 1.1 and all 3 repro but 1.3 and 1.1 are pretty difficult. 1.1 required quite the finesse at an acute angle for about 15 seconds. Updated tracking flags.
status-b2g18: --- → affected

Comment 6

4 years ago
Created attachment 8336464 [details]
IMG_0388.MOV

The video attachment shows a different way how to repro this issue on 1.2 but I cannot reproduce the same on 1.1 and 1.3
(Assignee)

Updated

4 years ago
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Comment 7

4 years ago
Created attachment 8336628 [details]
Patch v1
Attachment #8336628 - Flags: review?(21)
Attachment #8336628 - Flags: review?(21) → review+
(Assignee)

Comment 8

4 years ago
Merged in master

https://github.com/mozilla-b2g/gaia/commit/78052abbb6dea6f35f19f4533777d1791d661845
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Duplicate of this bug: 937744
You need to log in before you can comment on or make changes to this bug.