Closed Bug 941487 Opened 8 years ago Closed 8 years ago

about:support TypeError: "Cu" is read-only @ chrome://global/content/resetProfile.js:7

Categories

(Toolkit :: General, defect)

25 Branch
defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla33

People

(Reporter: cobexer, Assigned: Gijs)

References

Details

(Whiteboard: p=1 s=33.1 [qa-])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131118212339

Steps to reproduce:

open about:support, the Reset Firefox button is missing

tested in Firefox 25.0.1 - 28.0a1 (2013-11-20)


Actual results:

the browser console shows the error message:
TypeError: "Cu" is read-only @ chrome://global/content/resetProfile.js:7
Have you seen this before?
Component: Untriaged → Migration
Flags: needinfo?(MattN+bmo)
Yes, it's been there for a long time and has to do with resetProfile.js being used in two different dialogs, one of which has "Cu" already defined with const. AFAIK, it's harmless, the lack of the Reset Firefox button is probably due to a non-default profile e.g. bug 749700. I have the error and the button in my default profile.
Component: Migration → General
Flags: needinfo?(MattN+bmo)
Product: Firefox → Toolkit
Yes I used a non default profile (created it to make sure it reproduces in a clean profile)
Duplicate of this bug: 980273
I want to use about:support in a test, and it breaks mochitest because of the uncaught exception. :-(


Marco, can you add this to this iteration?
Assignee: nobody → gijskruitbosch+bugs
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: firefox-backlog+
OS: Windows 7 → All
Hardware: x86_64 → All
Whiteboard: p=1 s=33.1 [qa-]
Blocks: 908534
Attachment #8438359 - Flags: review?(MattN+bmo)
(In reply to :Gijs Kruitbosch from comment #5)
> I want to use about:support in a test, and it breaks mochitest because of
> the uncaught exception. :-(
> 
> 
> Marco, can you add this to this iteration?

Seems like this needinfo got lost...
Flags: needinfo?(mmucci)
Added to Iteration 33.1
Flags: needinfo?(mmucci)
Comment on attachment 8438359 [details] [diff] [review]
fix-resetProfile.js

Review of attachment 8438359 [details] [diff] [review]:
-----------------------------------------------------------------

r=me. Perhaps a comment may be useful as people may not realize it gets used in two contexts.
Attachment #8438359 - Flags: review?(MattN+bmo) → review+
w/ comment:
 https://hg.mozilla.org/integration/fx-team/rev/4fe3277c7384
Whiteboard: p=1 s=33.1 [qa-] → [fixed-in-fx-team] p=1 s=33.1 [qa-]
https://hg.mozilla.org/mozilla-central/rev/4fe3277c7384
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team] p=1 s=33.1 [qa-] → p=1 s=33.1 [qa-]
Target Milestone: --- → mozilla33
Status: RESOLVED → VERIFIED
Duplicate of this bug: 933137
You need to log in before you can comment on or make changes to this bug.