dropdown list selection causes trap in widget library

VERIFIED FIXED

Status

()

VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: achimha, Assigned: mkaply)

Tracking

Trunk
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Go to http://www.flugboerse.de/Stuttgart, click on "Linienflug", then try to
select a specific entry from the first listbox. See the browser trap.

Comment 1

17 years ago
Trap is because of the value returned by nsScrollBar::WindowClass().  
We aren't returning a real string that we can do string manipulation on 
(which is causing the trap).  We need to return "#8" instead of 
(PSZ)WC_SCROLLBAR.  "#8" is the window class that comes back via 
WinQueryClassName for a window created with WC_SCROLLBAR.
(Assignee)

Comment 2

17 years ago
Created attachment 45186 [details] [diff] [review]
Fix from aaronr for bug
(Assignee)

Comment 3

17 years ago
Fix checked in
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

17 years ago
*** Bug 94489 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

17 years ago
*** Bug 94646 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
May God have mercy on us all. The 212 bug spam-o-rama is Now!
QA Contact: aegis → jrgm
(Assignee)

Comment 7

17 years ago
This is definitely fixed. Many people have said so.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.