Closed Bug 941567 Opened 6 years ago Closed 6 years ago

[Keyboard][V1.2] The keyboard name of notification bar is incorrect

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:koi+, b2g-v1.2 fixed)

VERIFIED FIXED
blocking-b2g koi+
Tracking Status
b2g-v1.2 --- fixed

People

(Reporter: whsu, Assigned: GaryChen)

References

Details

(Whiteboard: [FT:System-Platform], [3rd-party-keyboard])

Attachments

(3 files, 1 obsolete file)

* Description:
  This problem happens on v1.2 branch.
  After switching the keyboard from third party keyboard to built-in keyboard, drop down the notification page to check the keyboard's name.
  The keyboard's name still displays the third party keyboard's name.
  Attaching the screenshot.

* Precondition:
  - Install a third party keyboard or flash a engineering build to device.

* Reproduction steps:
  1. Launch the message app
  2. Tap pencil icon to edit a message.
  3. Tap the message field
  4. Long press the Globe key
  5. Select a third party keyboard layout
  6. Long press the Globe key again
  7. Select a built-in keyboard layout
  8. Check the keyboard's name of notification page

* Expected result:
  The notification page displays current keyboard which in use.

* Actual result:
    The notification page displays previous keyboard's name.

* Reproduction build:(V1.2 Buri)
  - Gaia:     5ec2963fff60492c840707df8d8090f9908a5251
  - Gecko:    http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/2d454e0de2ed
  - BuildID   20131120004000
  - Version   26.0


Thanks!
Can not reproduce.

Gaia:     d3a0e45b26a0698b62ce0edcb926e3053a2fba73
Gecko:    7d43603d58f118c8792fe73f0b01c166de30ba6f
BuildID   20131122061537
Version   28.0a1
Keywords: qawanted
QA Contact: sarsenyev
Hi, Gary,

OOPS~ My bad. The steps don't seem be able to 100% reproduce this bug.
Please follow the steps below and try it again.

Step:
1. Enable a third party keyboard. (Gaia Test Keyboard)
2. Launch the message app
3. Tap pencil icon to edit a message.
4. Tap the message field
5. After keyboard is launched, please check the notification bar
6. Tap the Globe key
7. Check the notification bar again.
Keywords: qawanted
Assignee: nobody → gchen
Whiteboard: [FT:System-Platform], [3rd-party-keyboard]
Hi Tim,
 Please help to review this patch.
 Since keyboard show timing is depends on 'mozbrowserresize' event,
so call 'showIMESwitcher' in the end of 'resizeKeyboard' to make sure refresh latest information at each time while keyboard layout is chnaged.
Attachment #8339728 - Flags: review?(timdream)
Attachment #8339728 - Flags: review?(timdream) → review+
I found some regression on this patch, back out it first.
https://github.com/mozilla-b2g/gaia/commit/9783801bdf8ea3efc943bcd5eead0ce9bf404e92

I'll fix it on the other patch.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Gary, your revert patch seems to the cause of TBPL bustage:

https://tbpl.mozilla.org/?tree=B2g-Inbound&rev=007a28b19570
Flags: needinfo?(gchen)
False alarm, the offending patch was bug 935094.
Flags: needinfo?(gchen)
Hi Tim,
   please help to review this patch, thanks.
Attachment #8339728 - Attachment is obsolete: true
Attachment #8340503 - Flags: review?(timdream)
Attachment #8340503 - Flags: review?(timdream) → review+
Travis passed
https://travis-ci.org/mozilla-b2g/gaia/builds/14787032

landed in gaia master
https://github.com/mpizza/gaia/commit/fc3ef53f0bbaf297e9177ece1d4390fd8788233b
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
need to uplift to v1.2
blocking-b2g: --- → koi?
> need to uplift to v1.2
Reproduction build:(V1.2 Buri)
Gaia:     075e60c878b0eca68fba9e00bc85cb6eac03578a
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/87c5634a3404
BuildID   20131128004001
Version   26.0(In reply to GaryChen [:GaryChen][:PYChen] from comment #11)
At this point (a week from the finish line), this alone would likely not be a blocker. bug 941745 is the real reason we're taking this bug as koi+, since https://bugzilla.mozilla.org/show_bug.cgi?id=941745#c32 suggests this resolves the issue, and appears to be low risk.
blocking-b2g: koi? → koi+
Blocks: 941745
Hi Steven, 
   Since this patch can resolve Bug 944578 and Bug 941745,so need to uplift to v1.2f.
   This bug is koi+ I can not set fugu?.
Flags: needinfo?(styang)
Ben, supposedly, the solutions for koi+ will be uplifted to 1.2f automatically, is my understanding correct?
Flags: needinfo?(styang) → needinfo?(bhearsum)
(In reply to Steven Yang [:styang] from comment #16)
> Ben, supposedly, the solutions for koi+ will be uplifted to 1.2f
> automatically, is my understanding correct?

Sorry Steven, I'm not sure - I was just involved with branch creation mechanics. Alex should have an answer for you though.
Flags: needinfo?(bhearsum) → needinfo?(akeybl)
Thanks for your help!
Verified this patch. Attaching the verified result (WP_20131218_016.mp4). FYI.


* The test build:
 - Gaia:     4f53ba8b3628ac311253fc28dfdf66e7ba6832de
 - Gecko:    http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/129ad3c335a5
 - BuildID   20131217004001
 - Version   26.0
Status: RESOLVED → VERIFIED
Attached video WP_20131218_016.mp4
Switching needinfo flag to group instead of individual.
Flags: needinfo?(akeybl) → needinfo?(release-mgmt)
yes, 1.2 -> 1.2f merges are being done(checked with Ryan as well), so clearing the NI.
Flags: needinfo?(release-mgmt)
You need to log in before you can comment on or make changes to this bug.