NNTP Error when searching newsgroup messages

VERIFIED DUPLICATE of bug 92746

Status

VERIFIED DUPLICATE of bug 92746
17 years ago
10 years ago

People

(Reporter: wd, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
BuildID:    2001080703

When I try to search newsgroup messages on newsgroups.wisesolutions.com , I get
an error.

Reproducible: Always
Steps to Reproduce:
1.Set up Mailnews for NNTP:   newsgroups.wisesolutions.com
2.login/pass:   moztest/moztest
3.subscribe to a newsgroup
4.hit Search -> Search Messages and type in a search string

Actual Results:  A News (NNTP) error occurred: command not recognized.

Expected Results:  Newsgroup messages searched.

Perhaps the news server isn't 100% compliant or something?   Even if that's
true, if Mozilla already has the headers downloaded for the messages, why would
it need to issue any NNTP requests to the server to do a search in the first
place?  Shouldn't it be searching the headers it already has downloaded?

Updated

17 years ago
QA Contact: stephend → laurel

Comment 1

17 years ago
We search the server. We haven't implement the (4.x type) option to search
locally. We do however search local copy when in offline state, but you have to
download messages for offline use before being able to read the body of the
message when offline.

Comment 2

17 years ago
There's already a (recent) bug 92746 about local news searching, this should
probably be marked a duplicate of that.  If we need to confirm why the news
server doesn't recognize the command, naving or someone can reopen this.

*** This bug has been marked as a duplicate of 92746 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
I don't think this is a dup.

I'm able to search news.mozilla.org for sender is foo, but not the server 
specified in the bug report.

re-opening.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
note, 4.x does the same thing.  (same alert message.)
that server doesn't support XPAT:

202 Extensions supported:
XOVER
XGTITLE
.

so we can't search the searver.

I'm not sure what to do with this bug.  

once the nntp protocol code asks servers for the extensions, we'll figure out 
that the server doesn't support XPAT.  then, we wouldn't show it in search 
unless we are in offline mode.

hiding servers seems in search seems bad.  in this case, the best we could do 
(as laurel points out) is search the offline content or the summary files.  but 
there is no guarantee either will exist.

Comment 6

17 years ago
I still think this is a duplicate. Since the server can't be searched, the
resolution would be to search locally.  Searching 4.x works if you throw the
search local option on -- in search dialog use Options and switch the search
scope to "search your local system".  So, I think this ultimately is a duplicate
(requesting the local search option when online).

Comment 7

17 years ago
After talking with Seth, we're going to mark this a duplicate again and add some
comments to the other bug about possible solutions for the case where server
which doesn't support search.

*** This bug has been marked as a duplicate of 92746 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
v.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.