Closed Bug 92746 Opened 21 years ago Closed 18 years ago

Search of ng will not search local cache headers

Categories

(SeaMonkey :: MailNews: Message Display, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 83968

People

(Reporter: phoenixreads, Assigned: sspitzer)

References

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.2) Gecko/20010628
BuildID:    2001062815

When trying to do a search on a public news server the search fails since that
server does not allow searching.  Did a search on a server which does allow
searching and it works.  Therefore local searching is not supported.

Reproducible: Always
Steps to Reproduce:
1.Set up an account with server which does not support searching (I was using
newscache1.freenet.de)
2.Download headers for a ng.
3.Right click and select search messages for that the above ng
4.Set search parameters from something simple like the letter 'a' or a known
word in the subject headers, or a known sender
5.Select Search

Actual Results:  All searches failed

Expected Results:  To filter local cache headers to the given search parameters.
 For example, finding all the subject headers with the word 'Java' and
displaying them accordingly.

Give the option of local and/or server searches.

Expand this idea to save filter parameters and call it up from the view dropdown
would be a time saver which would filter the main newsgroup (or mail) listing
accordingly.  Included a 'filter' icon button for easier access and as an
indicator filters are active.  Include the filter listing in a dropdown for the
above mentioned filter icon.
We search the news server. We haven't implemented a 4.x style "search locally"
option to search messages. However, in offline state, search will use local
message copies -- you have to download messages for offline use before being
able to read the message bodies when offline.

I might have an older bug about the "local" option to search, will look for it...
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hmmm, I didn't see an older bug. I know it's never been included in the search
spec for 6.x to date. 
*** Bug 94161 has been marked as a duplicate of this bug. ***
*** Bug 94161 has been marked as a duplicate of this bug. ***
This won't in all likelihood be addressed for some time.  When we do address
this problem, Seth wants to also think of a solution for the case where the
server was searched online and is found not to support search (the initial
condition as presented in duplicate bug 94161).  One thought was to display some
user-friendly error text in the results pane telling the user that the server
doesn't support search and to refer them to whatever option we have at the time
for doing local search (even if it's to refer them to use offline).
This is a bit of a problem.  It would be nice to give an error rather than
return zero results.
news.microsoft.com and also newsgroups.wisesolutions.com do not support
searching, too.
*** Bug 104853 has been marked as a duplicate of this bug. ***
*** Bug 167556 has been marked as a duplicate of this bug. ***
*** Bug 188822 has been marked as a duplicate of this bug. ***
*** Bug 203581 has been marked as a duplicate of this bug. ***
mass re-assign.
Assignee: naving → sspitzer
*** Bug 197555 has been marked as a duplicate of this bug. ***
Is this a dup of Bug 210784

*** This bug has been marked as a duplicate of 83968 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search
You need to log in before you can comment on or make changes to this bug.