SocialAPI status buttons shouldn't be visible in toolbarless browser windows

VERIFIED FIXED in Firefox 27

Status

()

Firefox
SocialAPI
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: florian, Assigned: florian)

Tracking

Trunk
Firefox 28
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox26 wontfix, firefox27+ verified, firefox28 verified)

Details

Attachments

(2 attachments)

(Assignee)

Description

4 years ago
Created attachment 8336101 [details]
Screenshot of the Persona dialog with an additional social status button

(See attached screenshot)

Clicking the button results in a JS error:
JavaScript error: resource:///modules/SharedFrame.jsm, line 137: NS_ERROR_NOT_IMPLEMENTED: 

Steps to reproduce:
- Install a social API provider that defines a statusURL, so that it gets a status button. (For the screenshot, I used talkilla where I replaced "sidebarURL" with "statusURL" in the file static/js/browserDetection.js)
- Open a Persona dialog.
(Assignee)

Comment 1

4 years ago
Created attachment 8336103 [details] [diff] [review]
bug-status-button-toolbarless-window.patch
Assignee: nobody → florian
Attachment #8336103 - Flags: review?(mhammond)
Attachment #8336103 - Flags: feedback?(mixedpuppy)
(Assignee)

Comment 2

4 years ago
Setting status/tracking flags. This code was already in Firefox 26, but it wasn't possible to trigger it until we pref'ed it on in bug 906839; which happened for Firefox 27, so I think we should fix this on trunk and 27.
status-firefox26: --- → wontfix
status-firefox27: --- → affected
status-firefox28: --- → affected
tracking-firefox27: --- → ?
Comment on attachment 8336103 [details] [diff] [review]
bug-status-button-toolbarless-window.patch

This looks good, and I was already considering this change in a different patch.
Attachment #8336103 - Flags: review?(mhammond)
Attachment #8336103 - Flags: review+
Attachment #8336103 - Flags: feedback?(mixedpuppy)
(Assignee)

Comment 5

4 years ago
Comment on attachment 8336103 [details] [diff] [review]
bug-status-button-toolbarless-window.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): The feature (SocialAPI status buttons) was implemented in bug 891225 and enabled in bug 906839.
User impact if declined: Broken toolbar buttons in toolbarless browser windows if the user has installed a SocialAPI provider providing a statusURL.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): Low (only css class changes).
String or IDL/UUID changes made by this patch: None.
Attachment #8336103 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/04488590113d
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28

Updated

4 years ago
Attachment #8336103 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

4 years ago
status-firefox28: affected → fixed
tracking-firefox27: ? → +
Keywords: verifyme
(Assignee)

Comment 7

4 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/64b99c299be9
status-firefox27: affected → fixed
Verified as fixed using the latest Firefox 27 beta 1 (20131209204824) on Win 7 64-bit, Ubuntu 32-bit and Mac OS X 10.8.5.

I reproduced the initial issue following the next steps (from Florian):
1. Go to https://talkilla-dev.mozillalabs.com/ 
2. Add a security exception for the certificate. 
3. Click the "Activate Talkilla" button and accept. 
4. Find the new toolbar button that appeared, and click it. 
5. Wait for the content of the panel to load then click the "sign in with Persona" button in there.
status-firefox27: fixed → verified
QA Contact: petruta.rasa

Comment 9

4 years ago
I tried to reproduce/verify this fix but it works the same for Firefox 26b10, 27b1 and 28a2. No SocialAPI icon is displayed anywhere in the persona dialog. I used the steps in comment 8 and variations of them (e.g. open the persona dialog from somewhere else, open another toolbarless window etc).

Petruta, since you could reproduce this issue, please verify it on Firefox 28 too.
Verified as fixed on latest Aurora 28.0a2 (20131215004001) on Win 7 64-bit, Ubuntu 64-bit and Mac OS X 10.9.
Status: RESOLVED → VERIFIED
status-firefox28: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.