Closed Bug 941740 Opened 6 years ago Closed 6 years ago

How Am I supose to move the window on my screen ?

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 28.0

People

(Reporter: Usul, Assigned: jsbruner)

References

Details

(Keywords: regression)

Attachments

(2 files, 3 obsolete files)

In the latest Mac nightly I have One pixel above the tabs to move my window or a few pixels below the Three red, yeallow and green button?

This makes moving the main window a PITA.

Is it a bug or a feature ?
This is almost certainly fallout from the Australis landing.
Until this is fixed, you can set mail.tabs.drawInTitlebar to false.
(In reply to Richard Marti [:Paenglab] from comment #2)
> Until this is fixed, you can set mail.tabs.drawInTitlebar to false.

that did it.
I'll have a fix up as soon as I can build again...
Assignee: nobody → josiah
Status: NEW → ASSIGNED
(In reply to Ludovic Hirlimann [:Usul] from comment #3)
> (In reply to Richard Marti [:Paenglab] from comment #2)
> > Until this is fixed, you can set mail.tabs.drawInTitlebar to false.
> 
> that did it.

Not entirely. I have a MBP with an external HD screen attached. From my time to time, moving a perfectly correctly drawn window from the external screen to the Retina LCD screen will make the window badly redraw its titlebar, just like ludovic's screenshot. And even if the pref mentioned above is set to false.
I also have some whitelisted popups that appear badly drawn and are impossible to move.
From time to time too, but I'm unable to give precise steps, a new window is badly drawn despite of the pref to false.
(In reply to Daniel Glazman (:glazou) from comment #5)
> (In reply to Ludovic Hirlimann [:Usul] from comment #3)
> > (In reply to Richard Marti [:Paenglab] from comment #2)
> > > Until this is fixed, you can set mail.tabs.drawInTitlebar to false.
> > 
> > that did it.
> Not entirely. I have a MBP with an external HD screen attached. From my time
> to time, moving a perfectly correctly drawn window from the external screen
> to the Retina LCD screen will make the window badly redraw its titlebar,
> just like ludovic's screenshot. And even if the pref mentioned above is set
> to false.

The pref is only a quick workaround and where are CSS styles and other thing missing to work correctly.

> I also have some whitelisted popups that appear badly drawn and are
> impossible to move.

I saw bug reports for Fx for popup windows without tab bar showing no title bar and the window buttons in the URL bar.

> From time to time too, but I'm unable to give precise steps, a new window is
> badly drawn despite of the pref to false.
So this should be fixed by bug 768516, but I'll keep this open until we know for sure.
Depends on: 768516
Keywords: regression
Duplicate of this bug: 942785
Attached patch Fix. (obsolete) β€” β€” Splinter Review
This should fix things using a small amount of XUL changes, and little CSS. However, we will want to back this out (or undo it) when we go to land the patch for tabs in the titlebar.
Attachment #8337934 - Flags: review?(mconley)
Comment on attachment 8337934 [details] [diff] [review]
Fix.

Review of attachment 8337934 [details] [diff] [review]:
-----------------------------------------------------------------

Actually, I think we can take care of the default case in a simpler way - simply set the default of mail.tabs.drawInTitlebar to false in mail/app/profile for OS X (you'll need to wrap with an #ifdef for XP_MACOSX).

So I think the strategy here will be:

Land that pref off for Daily, and allow it to merge to Earlybird at merge time. At merge time, Holly will merge into mozilla-aurora, which will mean the OS X will be removed from the CAN_DRAW_IN_TITLEBAR list, and all should be well again. We can leave the pref as it is, since it's behind an ifdef, and OS X will just be ignored.

We'll need to take care of the lightweight theme case as well when not drawing tabs in the titlebar, but then again, so will Firefox. We should file a bug on that.
Attachment #8337934 - Flags: review?(mconley) → review-
Attached patch Fix. (obsolete) β€” β€” Splinter Review
Sounds like a good idea to me. Here's the patch. (Also includes the necessary CSS fix for lw-themes)
Attachment #8337934 - Attachment is obsolete: true
Attachment #8338032 - Flags: review?(mconley)
Comment on attachment 8338032 [details] [diff] [review]
Fix.

Review of attachment 8338032 [details] [diff] [review]:
-----------------------------------------------------------------

Make sure to fix / test the no-lwtheme case, and then I think we're good to go.

Thanks Josiah!

::: mail/themes/osx/mail/messenger.css
@@ +20,5 @@
>     */
>    margin-bottom: 0px !important;
>  }
>  
> +#titlebar:-moz-lwtheme {

We'll need to hide a rule for the titlebar to be hidden if we're not using a -moz-lwtheme.
Attachment #8338032 - Flags: review?(mconley) → review+
Attached patch Fix. (obsolete) β€” β€” Splinter Review
Thanks!
Attachment #8338032 - Attachment is obsolete: true
Attachment #8338047 - Flags: review+
Attached patch Fix. β€” β€” Splinter Review
Attachment #8338047 - Attachment is obsolete: true
Attachment #8338058 - Flags: review+
https://hg.mozilla.org/comm-central/rev/aae6a4e00030
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Remember to set the target milestone to when it landed on trunk.
Target Milestone: --- → Thunderbird 28.0
You need to log in before you can comment on or make changes to this bug.