Add current process ID to all the things!

RESOLVED DUPLICATE of bug 881389

Status

()

Core
XPCOM
RESOLVED DUPLICATE of bug 881389
5 years ago
5 years ago

People

(Reporter: jorendorff, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
It would be pretty rad if every line of the log had a pid and thread id on it. I hear concurrency is the future.

(from bug 941739)

Comment 1

5 years ago
Ted, is there a good component for this bug?
Not really, depends on what's doing the logging. "The log" is a nebulous concept, I think you probably mean "stdout/stderr".

Comment 3

5 years ago
(In reply to comment #2)
> Not really, depends on what's doing the logging. "The log" is a nebulous
> concept, I think you probably mean "stdout/stderr".

I *think* Jason is talking about our test runners.
(Reporter)

Comment 4

5 years ago
I don't think the test runners can fix this.

I think this bug amounts to
- making a logging function that you can use from anywhere that adds the process and thread ids to every line it spits out
- crawling through the whole codebase replacing printf calls with this new thing

Seems possible?

Comment 6

5 years ago
Yeah if that's what you want then this is a dupe.  Sorry I misunderstood you.
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 881389
You need to log in before you can comment on or make changes to this bug.