Moving or deleting mail does not send EXPUNGE command

RESOLVED DUPLICATE of bug 265472

Status

RESOLVED DUPLICATE of bug 265472
17 years ago
10 years ago

People

(Reporter: jmsalvo, Assigned: Bienvenu)

Tracking

({qawanted})

Trunk
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Using mozilla mail against M$ Exchange Server, whenever I delete a message or
move a message from one folder to another, I noticed that the mail was never
really deleted from the IMAP server. I confirmed this two ways:

1) From either M$ Outlook and the Outlook Web interface, the message that I
deleted from mozilla mail is still there.

2) Tracing with ethereal shows that no EXPUNGE command was ever sent to the IMAP
server. ( Section 6.4.3 of RFC 2060 )

Comment 1

17 years ago
Reporter what build id are you using?
(Reporter)

Comment 2

17 years ago
2001080104 ( mozilla 0.9.3 )However, this has been happening since the early builds as well ( as far back as 0.9.0 ), but did not report it since I was not sure what the exact problem was ... until I read the IMAP RFC.

Comment 3

17 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

17 years ago
confirm this on win2k 202022503.
Mail only marked as deleted, not expunged when checking in M$ outlook express

Comment 5

17 years ago
isnt this a dupe of bug 36314 ?
can Q&A mark as such if so.

Comment 6

17 years ago
I don't think this should be duped.

Using mozilla 1.1a, with a large imap mail box, made up of multiple folders, I
can select a message, press delete on the keyboard, have the message marked as
deleted with the red X.  But that message will never be expunged until I right
click the folder of interest, and choose "compact this folder"  Exiting mozilla
completely, not just messenger doesn't help.  If I start messenger again, the
messages are still there, marked as deleted.  If i access my imap folder via
pine, all the messages are correctly marked as deleted, and exiting pine will
properly expunge them.  The imap server is a mirapoint.

Cheers,
Karl P

Comment 7

17 years ago
This is not just true for deleting messages, it also holds true for any message
movement between folders on an IMAP server.  I noticed this when I had been
reorganising my mailbox only to go back to Outlook and find that nothing had
actually happened.

Exiting Mozilla Mail and Newsgroups does however send the relevant updates to
the server.

This is true on Mozilla 1.0
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020510

Updated

16 years ago
QA Contact: huang → gchan

Comment 8

16 years ago
the bug is still here. using mozilla1.3
i have several filters set up to "Move message to folder xxx". so i end up with
two copies of the same message. 
i think moving a message should permanently delete the message from its original
location. 

Comment 9

16 years ago
I confirm too with Gecko/20030428. Moving from one folder to another just marks
messages as "to be deleted" but never get deleted. So you end-up with duplicate
mails. There should be a button "expunge" that should work on every mailbox not
only for the spool or inbox.

Comment 10

16 years ago
You can set moz to expunge the INBOX only on exit via the MailNews Account
settings dialog ("server settings" section) ... but there's no "expunge all"
option anywhere. 

Personally I don't mind, I just expunge messages using the "compact folder"
option, but this will be needed for practical use of moz by non-techie types. A
lot of my users are of the "I put it in the trash, but I didn't want to /delete/
it yet - where did it go?" persuasion... really says enough.

Craig
*** Bug 144427 has been marked as a duplicate of this bug. ***

Comment 12

15 years ago
Using Thunderbird .3, and this happens as well.  Not sure if this is the right 
place for this..
If I should post this to a different bug, please let me know. (tia).

Happens on windows, linux, FreeBSD, and MAC versions of Thunderbird, not just 
linux (as stated above).

John

Comment 13

15 years ago
still there in Thunderbird 0.4RC2 (20031203)

Comment 14

15 years ago
I am using Thunderbird .3, and this happens as well. Mozilla Thunderbird 0.3
(20031013). Will try to reconfirm it with later versions, too.
Good Birding MOZILLA,
martin

Comment 15

15 years ago
i am using TB 0.5 and still got the same problem when deleting imap-mails. doing
the *compact this folder* deletes the emails, so they are really deleted (expunged).

Comment 16

15 years ago
This has got even worse recently.

For ages I've been using File->Compact Folders to expunge deleted messages from
an IMAP folder, and generally that's worked OK. A keyboard shortcut of "Alt-f f"
is certainly better than no keyboard shortcut (or toolbar button) at all...

However, I recently installed Mozilla 1.7 (Mozilla/5.0 (Windows; U; Windows NT
5.1; en-US; rv:1.7) Gecko/20040616).

Now when I do "Compact Folders" there's generally a long delay until the
selected folder is expunged. During this time you don't tend to get a lot of
feedback. Sometimes I see "Compacting <foldername>" in the statusbar, where
"foldername" is generally another folder, which seems to be a bit random. Quite
often I get a statusbar message about a folder being compacted, followed by a
"Downloading message" progress bar.

So, what's going on here? I'm guessing "Compact Folders" has been changed to
actually compact all folders, and it's just the feedback that isn't brilliant.

If so, you've removed the only way (I know about) of expunging an IMAP folder
with a keyboard shortcut.

I've noticed the context menu for a folder has an item "Compact This Folder",
and that this does indeed expunge the folder relatively quickly. However,
there's no keyboard shortcut for this.

Comment 17

15 years ago
#16

when using the latest versions of moz and tbird, clicking Compact Folders will
expunge ALL folders, not just the selected folder.

that's why you're getting the delay.

if you only want to expunge a single folder, then right-click the folder and
select Compact Folder.

Updated

14 years ago
Blocks: 179556

Comment 18

14 years ago
*** Bug 209364 has been marked as a duplicate of this bug. ***
Product: MailNews → Core

Comment 19

13 years ago
http://compactfolder.mozdev.org/ gives Thunderbird an expunge toolbar button (but still no keyboard shortcut...)

Comment 20

11 years ago
It's amazing that this bug has been around for six years and is still around.  I think perhaps it's better than it was, but still not fixed.

I have my account preferences set up to move deleted messages to trash.  This works.  When I delete a message, it does get moved to my trash folder, and it does seem to actually get permanently deleted from the source folder.

However, when I *move* a message from one folder to another, it doesn't get expunged from the source folder immediately.

This is especially annoying when I then forget to compact folders before leaving for work.  When I arrive at work, and switch from Thunderbird using IMAP to Outlook talking directly to Exchange, all the messages I moved are still sitting there in my inbox, because Thunderbird never got around to expunging them.

If the user's account settings say to move deleted messages to trash, then expunge should be called after a message is moved, just as it is currently called after a message is deleted.  This really shouldn't be difficult to fix.

Updated

11 years ago
Assignee: mscott → bienvenu
Keywords: qawanted
OS: Linux → All
QA Contact: grylchan → networking.imap
Hardware: PC → All
(Assignee)

Comment 21

10 years ago
we've added a hidden pref, mail.imap.expunge_after_delete, which you can set to true if you want this behavior. It's not on by default.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 265472
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.