Closed Bug 942166 Opened 7 years ago Closed 7 years ago

On OSX Australis hamburger panel lacks right padding when maximized/full screen

Categories

(Firefox :: Theme, defect)

All
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 874792

People

(Reporter: nmaier, Unassigned)

References

Details

(Whiteboard: [Australis])

Attachments

(1 file)

Attached image Screen shot
See the attached screen shot.
- On the left is the panel of a non-maximized window, like it should look, having the padding on both sides.
- On the right is the panel as displayed in a maximized window, lacking the right padding.

STR:
- Open a browser window
- Maximize the window or go to native full screen
- Click the hamburger

I'm not entirely sure that it is just the padding that is missing. Kinda looks like even the content is slightly cropped on the right?

I tested on Win7 Basic and Ubuntu Saucy as well, and there the panel always looks OK, which makes me think that this is a OSX only problem.

OSX Lion + Latest Nightly
Built from http://hg.mozilla.org/mozilla-central/rev/dbf94e314cde

PS: Disregard the add-ons. It is the same in a new, vanilla profile.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 874792
Not the same, IMO. I'm talking about the padding of the panel content, not the panel "arrow" being misaligned.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
The summary of that bug isn't great, but the alignment thing is also why the panel is being cropped. Read the entire bug for more info, but as a quick summary, we position the panel in such a way that the arrow aligns. OS X then moves the panel onscreen (because that's what it likes doing...), and crops it, which means the right padding and alignment goes AWOL as you noticed, and the panel arrow doesn't match up with the button (which is also visible in your screenshot).
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 874792
You need to log in before you can comment on or make changes to this bug.