[Settings] Can't scroll down

RESOLVED DUPLICATE of bug 941310

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 941310
5 years ago
5 years ago

People

(Reporter: ypwalter, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Devices: Nexus4, Buri
(Doesn't reproduce in Unagi as far as I know)

Reproduce steps:
1. Launch Settings app
2. Scroll down

Expected Rsult:
It scrolls down

Actual Result:
It doesn't scroll down



PS. Bug 938785 might be related.

Comment 1

5 years ago
Fugu has the problem as well, it should be bug from master build.

Gaia:     671a7c1fae1c32a77b2675636c7efdf089fd6443
Gecko:    b79ea773754854e17566f302e80e2654d9c155c9
BuildID   20131126092608
Version   28.0a1
This seems to happen on the Email app as well for me. (Nexus 4)

Comment 3

5 years ago
Today's build are working on Buri and Fugu, but this is often up and down from Monday to today. Will keep monitoring.

Gaia:     087d109c83235fc157b2efac7ace6cc54a4c5aaa
Gecko:    8fdb69114734785065ce6c76ac36f4438b90c2e6
BuildID   20131127093419
Version   28.0a1

Comment 4

5 years ago
(In reply to Enpei from comment #3)
> Today's build are working on Buri and Fugu, but this is often up and down
> from Monday to today. Will keep monitoring.
> 
> Gaia:     087d109c83235fc157b2efac7ace6cc54a4c5aaa
> Gecko:    8fdb69114734785065ce6c76ac36f4438b90c2e6
> BuildID   20131127093419
> Version   28.0a1

Please ignore my last comment, after reboot device, bug found again. Nominate as v1.3 blocker.
blocking-b2g: --- → 1.3?
(Reporter)

Comment 5

5 years ago
It's not always happening when first time launched. My buri has the issue after I used it for awhile.
Can you check if the fix is bug 942259 is in your builds?

Comment 7

5 years ago
looks like not a settings specific issue.
Component: Gaia::Settings → General
Still not working for me, I have verified my build contains patch in bug 942259.
So it seems like the preallocated process is lying. The check at http://mxr.mozilla.org/mozilla-central/source/dom/browser-element/BrowserElementPanning.js#51 fails because the app says that docShell.asyncPanZoomEnabled == true while we are in the preallocated process.

When the prealocatted process is consume by a real app, this value is correct but it is too late.

I seems like something has changed in the way we initialize the asyncPanZoomEnabled value by default.

Updated

5 years ago
Whiteboard: [dsds_US_test]

Updated

5 years ago
Status: NEW → RESOLVED
blocking-b2g: 1.3? → ---
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 941310

Updated

5 years ago
Whiteboard: [dsds_US_test]
You need to log in before you can comment on or make changes to this bug.