Offline mode with CalDav not working (Owncloud)

RESOLVED WORKSFORME

Status

Calendar
Lightning Only
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Jean-Philippe L., Unassigned)

Tracking

Lightning 2.6.3

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; InfoPath.3; rv:11.0) like Gecko

Steps to reproduce:

For this scenario, I used :
- Thunderbird 24.1.1 (Windows)
- Lightning 2.6.3
- OwnCloud 5.0.13 (on Windows, IIS 7.0 , Windows Server 2008 32bits)

1) Install Thunderbird + LightNing 2.6.3
3) Add a new CalDav (OwnCloud) calendar and enable "Offline support"
3) Complete configuration


Actual results:

Although I had to type my username and password for OwnCloud, the content of the calendar do not show up.

If I disable the "Offline support", everything works.

Rolling back to 2.6.2 works with OffLine mode.


Expected results:

The calendar should show it's content.

Comment 1

4 years ago
Do you get any error messages in Tools > Error Console during the steps you have listed above? If yes: please copy and paste them here.
Flags: needinfo?(aragorn1982)

Comment 2

4 years ago
If I enable the "Offline support" I got 356x 
[JavaScript Error: "TypeError: aListener.onOperationComplete is not a function"]

If I disable the "Offline support", I got the warning
Zeitstempel: 26.11.2013 23:14:15
Warnung: getAttributeNodeNS() sollte nicht mehr verwendet werden. Verwenden Sie stattdessen getAttributeNS().
Quelldatei: resource://calendar/modules/calXMLUtils.jsm
Zeile: 32
(Reporter)

Comment 3

4 years ago
With Off-Line mode ON (not working)
[JavaScript Error: "TypeError: aListener.onOperationComplete is not a function"]

With Off-Line mode OFF (Working)
Horodatage : 2013-11-26 18:09:32
Avertissement : L'utilisation de « getAttributeNodeNS() » est obsolète. Utiliser « getAttributeNS() » à la place.
Fichier Source : resource://calendar/modules/calXMLUtils.jsm
Ligne : 32

I also have the latest error in 2.6.2 by the way.

Thanks in advance!
Flags: needinfo?(aragorn1982)

Comment 4

4 years ago
exactly same here:
SERVER:
Debian 7;
Owncloud 5.0.13

CLIENT:
Ubuntu 12.04 64
Thunderbird 24.1.1
Lightning 2.6.3 via CalDAV

creation of appoiontments online and locally possible, upsyncing working but downsyncing fails as long as "Offline Support" ist enabled for the CalDAV-Calendar

Disabling "Offline Support" is a good workaround

regards,
- nemo5  -

Comment 5

4 years ago
Same problem but using CalDAV 

CLIENT: 
- Thunderbird 24.1.1 (Ubuntu)
- Lightning 2.6.3 via CalDAV via Davmail 4.3.4-2174

Calendar display only if offline mode is disabled.

Comment 6

4 years ago
Same problem but using Davmail's CalDAV emulation for Exchange. 

CLIENT: 
- Thunderbird 24.1.1 (Ubuntu)
- Lightning 2.6.3 via CalDAV via Davmail 4.3.4-2174

Calendar display only if offline mode is disabled.Was working well in the past.

In error console :
[JavaScript Error: "TypeError: aListener.onOperationComplete is not a function"] (many times)

Comment 7

4 years ago
The error "aListener.onOperationComplete is not a function" is most probably caused by the incomplete patch in Bug 930132, see Bug 930132 Comment 54 and following. A new patch was added, maybe you can try to locally patch your Lightning installation.
(Reporter)

Comment 8

4 years ago
(In reply to Stefan Sitter from comment #7)
> The error "aListener.onOperationComplete is not a function" is most probably
> caused by the incomplete patch in Bug 930132, see Bug 930132 Comment 54 and
> following. A new patch was added, maybe you can try to locally patch your
> Lightning installation.

How do I apply this kind of patch under Windows? 

Thanks btw!

Comment 9

4 years ago
I can confirm that enabling Offline Support causes the error: 

[JavaScript Error: "TypeError: aListener.onOperationComplete is not a function"].

Disabling Offline Support gives the warning: 

Warning: Use of getAttributeNodeNS() is deprecated. Use getAttributeNS() instead.
Source File: resource://calendar/modules/calXMLUtils.jsm
Line: 32

Thanks.

Comment 10

4 years ago
(In reply to Stefan Sitter from comment #7)
> The error "aListener.onOperationComplete is not a function" is most probably
> caused by the incomplete patch in Bug 930132, see Bug 930132 Comment 54 and
> following. A new patch was added, maybe you can try to locally patch your
> Lightning installation.

I confirm Bug 930132 Comment 56 patch (Attachment #8339151 [details] [diff]) fix the problem and make offline mode work again. Thanks!

Comment 11

4 years ago
Thank for testing.
Jean-Philippe reported the same, so I'm setting dependency to bug 930132.
Depends on: 930132

Comment 12

4 years ago
This issue is fixed by latest patch of bug 930132.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.