Chunked webdav-sync is not handled [status: HTTP/1.1 507 Insufficient Storage] [Error: Assert failed: unexepcted endBatch!]

RESOLVED FIXED in 2.6.4

Status

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: f.niedernolte, Assigned: Fallen)

Tracking

Lightning 2.6.1
2.6.4
Dependency tree / graph

Details

()

Attachments

(2 attachments)

User Agent: Mozilla/5.0 (Android; Mobile; rv:25.0) Gecko/25.0 Firefox/25.0 (Nightly/Aurora)
Build ID: 20131021190846

Steps to reproduce:

Added a new calendar with Google CalDAV api v2 with Lightning 2.6.1


Actual results:

I have installed Lightning 0.2.6.1 from the "other versions" with Thunderbird 24.0.1 but I still get the following errors: [JavaScript Warning: "CalDAV: Unexpected response, status: HTTP/1.1 507 Insufficient Storage, href: /caldav/v2/name@googlemail.com/events/"] [JavaScript Error: "[calCachedCalendar] replay action failed: null, uri=https://apidata.googleusercontent.com/caldav/v2/name@googlemail.com/events, result=2147500037, op=[xpconnect wrapped calIOperation]"] And because of this it doesn't work. How to fix this? Thanks


Expected results:

Sync should work 

See bug 902755
Sorry for the first wrong bug number
Blocks: ltn263
I suspected this to happen, I just couldn't reproduce it. I think it will happen with a large number of events. The error is part of the webav-sync spec.
Assignee: nobody → philipp
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: CalDAV 507 error → Chunked webdav-sync is not handled
Hi Philipp, et al,

    It's me again ;-)  I got the same issue but with Earlybird 26.0a2 and Lightning 2.8a2.  Since the log is not too big, I'm adding it to the comment itself.

This combination of Earlybird and Lightning was working OK for me (albeit with the need to hit "synchronize" multiple times) until today when this error popped up.  Not sure what triggered it.

Let me know if you need more info.

Thanks

Ciao
-- Murali

---------------- Error console log --------------------
Warning: Use of getAttributeNodeNS() is deprecated. Use getAttributeNS() instead.
Source file: resource://calendar/modules/calXMLUtils.jsm
Line: 32
 ----------
Warning: Use of getAttributeNodeNS() is deprecated. Use getAttributeNS() instead.
Source file: resource://calendar/modules/calXMLUtils.jsm
Line: 32
 ----------
Warning: CalDAV: Unexpected response, status: HTTP/1.1 507 Insufficient Storage, href: /caldav/v2/bmurali5128@gmail.com/events/
 ----------
Error: Assert failed: unexepcted endBatch!
2: [resource://calendar/modules/calProviderUtils.jsm:647] cPB_endBatch
3: [resource://calendar/modules/calUtils.jsm -> file:///Users/bmurali/Library/Thunderbird/Profiles/sys7z0f1.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js:464] wH_endDocument
4: [resource://calendar/modules/calUtils.jsm -> file:///Users/bmurali/Library/Thunderbird/Profiles/sys7z0f1.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js:423] wSL_onStopRequest
5: [null:0] null

Source file: resource://calendar/modules/calUtils.jsm -> file:///Users/bmurali/Library/Thunderbird/Profiles/sys7z0f1.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 1029
 ----------
Warning: There has been an error reading data for calendar: Personal.  However, this error is believed to be minor, so the program will attempt to continue. Error code: DAV_REPORT_ERROR. Description: There has been an error reading data for calendar: https://apidata.googleusercontent.com/caldav/v2/bmurali5128@gmail.com/events. It has been disabled until it is safe to use it.
 ----------
Warning: There has been an error reading data for calendar: Personal.  However, this error is believed to be minor, so the program will attempt to continue. Error code: READ_FAILED. Description: 
 ----------
Warning: CalDAV: Unexpected response, status: HTTP/1.1 507 Insufficient Storage, href: /caldav/v2/6hmfnhctb2a86ekudvnnslt5og@group.calendar.google.com/events/
 ----------
Warning: There has been an error reading data for calendar: Work.  However, this error is believed to be minor, so the program will attempt to continue. Error code: DAV_REPORT_ERROR. Description: There has been an error reading data for calendar: https://apidata.googleusercontent.com/caldav/v2/6hmfnhctb2a86ekudvnnslt5og@group.calendar.google.com/events. It has been disabled until it is safe to use it.
 ----------
Warning: There has been an error reading data for calendar: Work.  However, this error is believed to be minor, so the program will attempt to continue. Error code: READ_FAILED. Description: 
 ----------
Error: [calCachedCalendar] replay action failed: null, uri=https://apidata.googleusercontent.com/caldav/v2/6hmfnhctb2a86ekudvnnslt5og@group.calendar.google.com/events, result=2147500037, op=[xpconnect wrapped calIOperation]
Summary: Chunked webdav-sync is not handled → Chunked webdav-sync is not handled [status: HTTP/1.1 507 Insufficient Storage]
Hi Murali, thanks for the logs! Fixing this might also fix the other problem with the multiple synchronization clicks.
I get the same thing. I've tried 2.6.1 on both Mac and PC. Here are some logs...

Timestamp: 10/24/2013 1:03:50 PM
Warning: Use of getAttributeNodeNS() is deprecated. Use getAttributeNS() instead.
Source File: resource://calendar/modules/calXMLUtils.jsm
Line: 32

[JavaScript Error: "[calCachedCalendar] replay action failed: null, uri=https://apidata.googleusercontent.com/caldav/v2/michael@smithers.name/events, result=2147500037, op=[xpconnect wrapped calIOperation]"]

[JavaScript Warning: "There has been an error reading data for calendar: Michael CalDav2.  However, this error is believed to be minor, so the program will attempt to continue. Error code: READ_FAILED. Description: "]

[JavaScript Warning: "There has been an error reading data for calendar: Michael CalDav2.  However, this error is believed to be minor, so the program will attempt to continue. Error code: DAV_REPORT_ERROR. Description: There has been an error reading data for calendar: https://apidata.googleusercontent.com/caldav/v2/michael@smithers.name/events. It has been disabled until it is safe to use it."]

[JavaScript Warning: "CalDAV: Unexpected response, status: HTTP/1.1 507 Insufficient Storage, href: /caldav/v2/michael@smithers.name/events/"]

Timestamp: 10/24/2013 1:03:48 PM
Warning: Use of getAttributeNodeNS() is deprecated. Use getAttributeNS() instead.
Source File: resource://calendar/modules/calXMLUtils.jsm
Line: 32
Same problem here, but only for one of two calendars.

[JavaScript Warning: "CalDAV: Unexpected response, status: HTTP/1.1 507 Insufficient Storage, href: /caldav/v2/xxxx@googlemail.com/events/"]

Zeitstempel: 24.10.2013 12:00:43
Fehler: Assert failed: unexepcted endBatch!
2: [resource://calendar/modules/calProviderUtils.jsm:647] cPB_endBatch
3: [resource://calendar/modules/calUtils.jsm -> file:///C:/Users/Marc/AppData/Roaming/Thunderbird/Profiles/55s9vpfb.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js:464] wH_endDocument
4: [resource://calendar/modules/calUtils.jsm -> file:///C:/Users/Marc/AppData/Roaming/Thunderbird/Profiles/55s9vpfb.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js:423] wSL_onStopRequest
5: [null:0] null

Quelldatei: resource://calendar/modules/calUtils.jsm -> file:///C:/Users/Marc/AppData/Roaming/Thunderbird/Profiles/55s9vpfb.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Zeile: 1029
Ahh sry forgot the version...

win7 64bit   Thunderbird 24.0.1   Lightning 2.6.1
I forgot the version too. I've tried
- Mac OS (latest before Mavericks update), Thunderbird 24.0.1, Lightning 2.6.1
- Win8  Thunderbird 24.0.1, Lightning 2.6.1

During calendar setup, a Google login is triggered in a browser. I login and completes successfully. When I go back to Lightning, the calendar is not available.
Summary: Chunked webdav-sync is not handled [status: HTTP/1.1 507 Insufficient Storage] → Chunked webdav-sync is not handled [status: HTTP/1.1 507 Insufficient Storage] [Error: Assert failed: unexepcted endBatch!]
Duplicate of this bug: 930834
Hey guys, I might have found something. I'm also suffering from this BUG and here is something that might be interesting to you. I have 4 Google calendars. One using my original eMail-Address as the ID the other three use of course these random created Google-IDs. The three calendars using the random organized IDs are working well if integrated to Lightning. Only the one using my mail-address is not working. This might also be related to the size of the calendar as it has a lot of entries, but I'm pretty sure that at least one of my other calendars hosts more entries. Maybe someone else can confirm or disprove the theory that this BUG is only affecting Google calendars using the original eMail-Address as calendar ID? I know it sounds a bit strange, but maybe there is a link :)
Hey guys, I might have found something. I'm also suffering from this BUG and here is something that might be interesting to you. I have 4 Google calendars. One using my original eMail-Address as the ID the other three use of course these random created Google-IDs. The three calendars using the random organized IDs are working well if integrated to Lightning. Only the one using my mail-address is not working. This might also be related to the size of the calendar as it has a lot of entries, but I'm pretty sure that at least one of my other calendars hosts more entries. Maybe someone else can confirm or disprove the theory that this BUG is only affecting Google calendars using the original eMail-Address as calendar ID? I know it sounds a bit strange, but maybe there is a link :)
I'll throw some more info on this bug too, as it's now affecting me.

Lightning 2.6.1 was working fine, but I had to manually sync to see my google calendar entries.

In trying to come up with ideas on what I did differently, the only thing I can think of is that I connected my android phone to my wifi network, did my looking around, gmail sync, etc., disconnected wifi.

Noticed this issue the next day when restarting Thunderbird 24.0.
CalDAV: send(https://apidata.googleusercontent.com/caldav/v2/userid%40gmail.com/events/): <?xml version="1.0" encoding="UTF-8"?>
<sync-collection xmlns="DAV:"><sync-token/><sync-level>1</sync-level><prop><getcontenttype/><getetag/></prop></sync-collection>
CalDAV: webdav-sync Token: null
[JavaScript Warning: "CalDAV: Unexpected response, status: HTTP/1.1 507 Insufficient Storage, href: /caldav/v2/userid@gmail.com/events/"]
CalDAV: recv:
<D:multistatus>
....
.. a whole bunch of event data ..
...
</D:multistatus>
[JavaScript Warning: "There has been an error reading data for calendar: userid.  However, this error is believed to be minor, so the program will attempt to continue. Error code: DAV_REPORT_ERROR. Description: There has been an error reading data for calendar: https://apidata.googleusercontent.com/caldav/v2/userid@gmail.com/events. It has been disabled until it is safe to use it."]
[JavaScript Warning: "There has been an error reading data for calendar: userid.  However, this error is believed to be minor, so the program will attempt to continue. Error code: READ_FAILED. Description: "]
[JavaScript Error: "[calCachedCalendar] replay action failed: null, uri=https://apidata.googleusercontent.com/caldav/v2/userid@gmail.com/events, result=2147500037, op=[xpconnect wrapped calIOperation]"]
Getting the same here.

CalDAV: send(https://apidata.googleusercontent.com/caldav/v2/wcruppel%40gmail.com/events/): <?xml version="1.0" encoding="UTF-8"?>
<sync-collection xmlns="DAV:"><sync-token/><sync-level>1</sync-level><prop><getcontenttype/><getetag/></prop></sync-collection>

CalDAV: webdav-sync Token: null

[JavaScript Warning: "CalDAV: Unexpected response, status: HTTP/1.1 507 Insufficient Storage, href: /caldav/v2/wcruppel@gmail.com/events/"]

CalDAV: recv:
<D:multistatus>
... SNIP! ...
 <D:response>
  <D:href>/caldav/v2/wcruppel%40gmail.com/events/</D:href>
  <D:status>HTTP/1.1 507 Insufficient Storage</D:status>
 </D:response>
 <D:sync-token>/caldav/v2/wcruppel%40gmail.com/events/sync/-ClMKRV84ZDlsY2dyZmRwcjZhc2prNjlqMzJlMW5jOHNqY3AxaWNoZ2ppZDlrNzFobThvcGc3NWkzYWQ5azZkZ20yZTlvY2NvMBgBIICAwMvHtJmIFBoNCAASABjIqNqMg7K6Ag==</D:sync-token>
</D:multistatus>

Timestamp: 10/25/2013 9:25:28 AM
Error: Assert failed: unexepcted endBatch!
2: [resource://calendar/modules/calProviderUtils.jsm:647] cPB_endBatch
3: [resource://calendar/modules/calUtils.jsm -> file:///C:/Users/WCRuppel/AppData/Roaming/Thunderbird/Profiles/inlzt9t8.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js:464] wH_endDocument
4: [resource://calendar/modules/calUtils.jsm -> file:///C:/Users/WCRuppel/AppData/Roaming/Thunderbird/Profiles/inlzt9t8.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js:423] wSL_onStopRequest
5: [null:0] null

Source File: resource://calendar/modules/calUtils.jsm -> file:///C:/Users/WCRuppel/AppData/Roaming/Thunderbird/Profiles/inlzt9t8.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 1029
Getting exactly the same error.
Thunderbird 24.0.1 Lightning 2.6.1 Windows 7 64bit.

First a bunch of events. Followed by:

 <D:response>
  <D:href>/caldav/v2/XXXXXXXXXXXX%40gmail.com/events/XXXXXXXXX.ics</D:href>
  <D:propstat>
   <D:status>HTTP/1.1 200 OK</D:status>
   <D:prop>
    <D:getcontenttype>text/calendar; component=vevent</D:getcontenttype>
    <D:getetag>"6345XXXXXXX"</D:getetag>
   </D:prop>
  </D:propstat>
 </D:response>
 <D:response>
  <D:href>/caldav/v2/XXXXXXXXXXXX%40gmail.com/events/</D:href>
  <D:status>HTTP/1.1 507 Insufficient Storage</D:status>
 </D:response>
 <D:sync-token>/caldav/v2/XXXXXXXXXXXX%40gmail.com/events/sync/-XXXXXXXXXXXX</D:sync-token>
</D:multistatus>

Followed by:
Error: Assert failed: unexepcted endBatch!
2: [resource://calendar/modules/calProviderUtils.jsm:647] cPB_endBatch
3: [resource://calendar/modules/calUtils.jsm -> file:///C:/Users/XXXXXXXXXXX/AppData/Roaming/Thunderbird/Profiles/yd34h9oa.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js:464] wH_endDocument
4: [resource://calendar/modules/calUtils.jsm -> file:///C:/Users/XXXXXXXXXXX/AppData/Roaming/Thunderbird/Profiles/yd34h9oa.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js:423] wSL_onStopRequest
5: [null:0] null

Source File: resource://calendar/modules/calUtils.jsm -> file:///C:/Users/XXXXXXXXXXX/AppData/Roaming/Thunderbird/Profiles/yd34h9oa.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 1029
Sort of the same errors here.
Win 7 64, Thunderbird 24.0.1, Lightning 2.6.1

Could not read chrome manifest 'file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/chrome.manifest'.

Could not read chrome manifest 'file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/extensions/%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D/chrome.manifest'.

While creating services from category 'profile-after-change', could not create service for entry 'Disk Space Watcher Service', contract ID '@mozilla.org/toolkit/disk-space-watcher;1'

No chrome package registered for chrome://testpilot/locale/main.dtd

Timestamp: 10/27/2013 19:28:34
Warning: Use of getAttributeNodeNS() is deprecated. Use getAttributeNS() instead.
Source File: resource://calendar/modules/calXMLUtils.jsm
Line: 32

Timestamp: 10/27/2013 19:28:34
Warning: Use of getAttributeNodeNS() is deprecated. Use getAttributeNS() instead.
Source File: resource://calendar/modules/calXMLUtils.jsm
Line: 32

[JavaScript Warning: "CalDAV: Unexpected response, status: HTTP/1.1 507 Insufficient Storage, href: /caldav/v2/xxxxxxx@gmail.com/events/"]

Timestamp: 10/27/2013 19:28:35
Error: Assert failed: unexepcted endBatch!
2: [resource://calendar/modules/calProviderUtils.jsm:647] cPB_endBatch
3: [resource://calendar/modules/calUtils.jsm -> file:///C:/Users/xxxxxxx/AppData/Roaming/Thunderbird/Profiles/sw0yqhgi.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js:464] wH_endDocument
4: [resource://calendar/modules/calUtils.jsm -> file:///C:/Users/xxxxxxx/AppData/Roaming/Thunderbird/Profiles/sw0yqhgi.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js:423] wSL_onStopRequest
5: [null:0] null

Source File: resource://calendar/modules/calUtils.jsm -> file:///C:/Users/xxxxxxx/AppData/Roaming/Thunderbird/Profiles/sw0yqhgi.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 1029

[JavaScript Warning: "There has been an error reading data for calendar: xxxxxxx.  However, this error is believed to be minor, so the program will attempt to continue. Error code: DAV_REPORT_ERROR. Description: There has been an error reading data for calendar: https://apidata.googleusercontent.com/caldav/v2/xxxxxxx@gmail.com/events. It has been disabled until it is safe to use it."]

[JavaScript Warning: "There has been an error reading data for calendar: xxxxxxx.  However, this error is believed to be minor, so the program will attempt to continue. Error code: READ_FAILED. Description: "]

[JavaScript Warning: "CalDAV: Unexpected response, status: HTTP/1.1 507 Insufficient Storage, href: /calendar/dav/xxxxxxx@gmail.com/events/"]

Timestamp: 10/27/2013 19:28:35
Error: Assert failed: unexepcted endBatch!
2: [resource://calendar/modules/calProviderUtils.jsm:647] cPB_endBatch
3: [resource://calendar/modules/calUtils.jsm -> file:///C:/Users/xxxxxxx/AppData/Roaming/Thunderbird/Profiles/sw0yqhgi.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js:464] wH_endDocument
4: [resource://calendar/modules/calUtils.jsm -> file:///C:/Users/xxxxxxx/AppData/Roaming/Thunderbird/Profiles/sw0yqhgi.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js:423] wSL_onStopRequest
5: [null:0] null

Source File: resource://calendar/modules/calUtils.jsm -> file:///C:/Users/xxxxxxx/AppData/Roaming/Thunderbird/Profiles/sw0yqhgi.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 1029

[JavaScript Warning: "There has been an error reading data for calendar: xxxxxxx@gmail.  However, this error is believed to be minor, so the program will attempt to continue. Error code: DAV_REPORT_ERROR. Description: There has been an error reading data for calendar: https://www.google.com/calendar/dav/xxxxxxx@gmail.com/events. It has been disabled until it is safe to use it."]

[JavaScript Warning: "There has been an error reading data for calendar: xxxxxxx@gmail.  However, this error is believed to be minor, so the program will attempt to continue. Error code: READ_FAILED. Description: "]
Thanks for the logs, folks. Don't worry, I know exactly what to do to fix this bug, I just have to write the patch. I hope to do so this week, maybe I can release an intermediate version.
Updated to TB 24.1.0 and Lightning 2.6.2 and it doesn't fix the problem.
Win7 64bit

[JavaScript Warning: "CalDAV: Unexpected response, status: HTTP/1.1 507 Insufficient Storage, href: /caldav/v2/xxx@googlemail.com/events/"]

Zeitstempel: 30.10.2013 03:04:25
Fehler: Assert failed: unexepcted endBatch!
2: [resource://calendar/modules/calProviderUtils.jsm:647] cPB_endBatch
3: [resource://calendar/modules/calUtils.jsm -> file:///C:/Users/Marc/AppData/Roaming/Thunderbird/Profiles/55s9vpfb.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js:464] wH_endDocument
4: [resource://calendar/modules/calUtils.jsm -> file:///C:/Users/Marc/AppData/Roaming/Thunderbird/Profiles/55s9vpfb.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js:423] wSL_onStopRequest
5: [null:0] null

Quelldatei: resource://calendar/modules/calUtils.jsm -> file:///C:/Users/Marc/AppData/Roaming/Thunderbird/Profiles/55s9vpfb.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Zeile: 1029
Same here. I can't tell what change between 2.6.1 and 2.6.2 but the google problem is still present.
+1

Lightning 2.6.2
Thunderbird 24.1.0
Win7 32Bit (anyway not related to OS)
Not using Provider but CalDAV
Yellow exclamation mark next to CalDAV APIv2 Cal and errors in console:

I am not! getting any other messages like described in Comment #c18 (507 Insuff... - guess its a additional problem)

--
Zeitstempel: 30.10.2013 09:43:52
Fehler: Assert failed: unexepcted endBatch!
2: [resource://calendar/modules/calProviderUtils.jsm:647] cPB_endBatch
3: [resource://calendar/modules/calUtils.jsm -> file:///C:/Users/####/AppData/Roaming/Thunderbird/Profiles/bi83zwpx.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js:464] wH_endDocument
4: [resource://calendar/modules/calUtils.jsm -> file:///C:/Users/####/AppData/Roaming/Thunderbird/Profiles/bi83zwpx.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js:423] wSL_onStopRequest
5: [null:0] null

Quelldatei: resource://calendar/modules/calUtils.jsm -> file:///C:/Users/####/AppData/Roaming/Thunderbird/Profiles/bi83zwpx.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Zeile: 1029
--

What i absolutely don't understand:
Why are some of the old CalDAV Calendars still working (e.g. holidays from Google) from what i've read google has abandoned these??
My own Google CalDAV Calendars however don't work with the old API nor the new one for at least 1 month now :sad:
I'd like to ask you all to keep in mind that this is not a discussion forum but a bug tracking tool. Please don't post useless "me too" comments. Please don't post comments that add no new information. Please don't post comments like "the problem is not fixed" if you can clearly see from the bug status that is not yet fixed. Please take a look at https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
@DEVEL: if there is any new patch or any other nightly build for testing, please let us know, that we can help on testing. thx cu camel
To add a data point:

It was working with 24.0.0 + 2.6.1 on October 15 for both new and old APIs (for the same calendars,
using USERNAME for the calendar [i.e. the primary calendar]), both for calendars owned by me and by somebody else (read-only access for me).

With 24.0.1 + 2.6.2, and with 24.1.0 + 2.6.3 (updated today, Oct. 30), – the NEW URIs do not work, but the old ones still do. (It is on a Win7-32bit box).

The errors and warning are:

[JavaScript Warning: "CalDAV: Unexpected response, status: HTTP/1.1 507 Insufficient Storage, href: /caldav/v2/USER@gmail.com/events/"]

[JavaScript Warning: "There has been an error reading data for calendar: MYCALENDAR. However, this error is believed to be minor, so the program will attempt to continue. Error code: DAV_REPORT_ERROR. Description: There has been an error reading data for calendar: https://apidata.googleusercontent.com/caldav/v2/USER@gmail.com/events. It has been disabled until it is safe to use it."]

[JavaScript Warning: "There has been an error reading data for calendar: MYCALENDAR. However, this error is believed to be minor, so the program will attempt to continue. Error code: READ_FAILED. Description: "]

[JavaScript Error: "[calCachedCalendar] replay action failed: null, uri=https://apidata.googleusercontent.com/caldav/v2/USER@gmail.com/events, result=2147500037, op=[xpconnect wrapped calIOperation]β€œ]
strange, for me doesn't  work - new or old caldav link any more, and calendar items not shown and "alert" sign on calendar :(pff
maybe to much items. 2.6.3 not found in nightly folder for now to try (windows version)
any idea how to fix it via a temporary patch ?
This bug does not seem to depend on the usage of new vs. old CalDav URLs. I have calendars that work with both new and old type links and I have one calendar that does not work with either old or new links. This faulty calendar has by far the most entries, so I would hypothesize that the bug is related to the amount of data transferred.
I get different results than JΓΆrg, that is, it doesn't seem dependent on amount of data.  I created four new Google calendars, all with no data.  Three of them interfaced with Lightning successfully (using the new caldav address).  However, the 4th calendar returned the "insufficient storage" error.  After many failed attempts, as a test, I created a fifth Google calendar and it also won't interface.
Posted patch Fix - v1 β€” β€” Splinter Review
This patch should take care, I've been able to reproduce the issue (Thanks for the test calendar, Murali!) and this one let me sync most(?) events. I haven't confirmed that ALL events are synchronized, but given the code resyncs and gets all events there it should work.

We should really optimize the caldav provider some time, it should be easy to also get the calendar data during the webdav-sync query, this way we don't have to do an extra multiget request.


If you are following this bug, please don't ask how to apply this patch. There is enough help on how to do that on the internet and in bug 920755.
Attachment #826344 - Flags: review?(matthew.mecca)
Comment on attachment 826344 [details] [diff] [review]
Fix - v1

Review of attachment 826344 [details] [diff] [review]:
-----------------------------------------------------------------

Untested since I can't currently reproduce, but looks good codewise. r=mmecca

::: calendar/providers/caldav/calDavRequestHandlers.js
@@ +773,5 @@
>              }
>  
> +            if (this.additionalSyncNeeded) {
> +              setTimeout(() => {
> +                let wds = new webDavSyncHandler(this.calendar,

nit: 4 space indents for this block
Attachment #826344 - Flags: review?(matthew.mecca)
Attachment #826344 - Flags: review+
Attachment #826344 - Flags: approval-calendar-release+
Attachment #826344 - Flags: approval-calendar-beta+
Attachment #826344 - Flags: approval-calendar-aurora+
Sorry for this n00by question:

Does "approval-calendar-aurora+" mean that the fix will be in the "trunk" (comm-central) builds? Will this fix will be in the "trunk" (comm-central) builds?
Patch v1 (fixed indents follow by Matthew's review) works fine on GCal v2 (main calendar and 10 sub calendars) / Lightning 2.7b1 / Thunderbird 25.0b1 / Win7Pro SP1 (x64).
All events seem to be synchronized (I have not confirmed completely, however, all events in all calendars in last half year are synchronized correctly with this patch. I gave up to check older events.)
Also, there are no error messages (except getAttributeNodeNS()) in error console.

(In reply to Peter Lairo from comment #29)
> Sorry for this n00by question:
> 
> Does "approval-calendar-aurora+" mean that the fix will be in the "trunk"
> (comm-central) builds? 

No.
review+ -> comm-central
approval-calendar-aurora+ -> comm-aurora
approval-calendar-beta+ -> comm-beta
approval-calendar-release+ -> comm-release

> Will this fix will be in the "trunk" (comm-central)
> builds?

Yes. This bug will be fixed in all branches including comm-central.
(In reply to Kosuke Kaizuka from comment #30)

> approval-calendar-release+ -> comm-release
Yes, originally this is true. Out of lazyness of creating a flag for every ESR, I am misusing this for "approval-calendar-esr24". This patch will be in all nightly branches, the beta, and the 2.6.3 release.
great, it works fine for me.
also the invites/appointments with invites are working now again :) !!!!!
Hi,

Aside from saying `me too' (it works), for Linux people, below is roughly how to apply the patch:

o Save the patch attachment to a file:  /var/tmp/patch_it

o Shutdown thunderbird

o Navigate to the location of `calDavRequestHandlers.js':  

  find .thunderbird -name calDavRequestHandlers.js

o Save the original copy

  cp calDavRequestHandlers.js /var/tmp

o Patch the file:

  patch < /var/tmp/patch_it

  patching file calDavRequestHandlers.js
  Hunk #3 succeeded at 490 (offset -9 lines).
  Hunk #4 succeeded at 581 (offset -9 lines).
  Hunk #5 succeeded at 635 (offset -9 lines).
  Hunk #6 succeeded at 655 (offset -9 lines).
  Hunk #7 succeeded at 668 (offset -9 lines).
  Hunk #8 succeeded at 760 (offset -12 lines).

o Enjoy Philipp's fine work!  :)
Thanks very much Philipp. Glad my calendar works again.

I've copy pasted and changed line by line, as taken from the diff link, using wordpad on win7.
Probably not the easiest route. So if i may ask, can someone advice a program i could use next time to automatically apply such changes?
Hello
in case someone is interested, I patched my calDavRequestHandlers.js using http://i-tools.org/diff
I hope it helps.
This patch works, but after I restart thunderbird the calendar is empty again and I have to push the "synchronize" button several times. After a minute or so the events are loaded again.
This happens after every restart and is no solution to me.
Unfortunately I'm seeing similar ... I have to restart thunderbird as after a while, I get the calendar is `unavailable error'

I see in the error console the following ... perhaps a different error than before?

[JavaScript Error: "Invalid alarm for item: 5b3c08fc-4f6a-4b12-9f16-9d6d777b28db (BEGIN:VALARM
X-LIC-ERROR;X-LIC-ERRORTYPE=VALUE-PARSE-ERROR:No value for DESCRIPTION pro
 perty. Removing entire property:
X-KDE-KCALCORE-ENABLED:TRUE
END:VALARM
) exception: [Exception... "'Illegal value' when calling method: [calIAlarm::icalComponent]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///home/pablo/.thunderbird/tnczn0sn.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calItemBase.js :: cIB_setItemBaseFromICS :: line 863"  data: no]"]
I still got the same problem with TB 24.1 and Lightning 2.6.2 on win 7/32
[JavaScript Warning: "CalDAV: Unexpected response, status: HTTP/1.1 507 Insufficient Storage, href: /caldav/v2/xxx@gmail.com/events/"]
Data e ora: 07/11/2013 15:12:37
Errore: Assert failed: unexepcted endBatch!
2: [resource://calendar/modules/calProviderUtils.jsm:647] cPB_endBatch
3: [resource://calendar/modules/calUtils.jsm -> file:///C:/Users/andrea/AppData/Roaming/Thunderbird/Profiles/ss3qx4j6.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js:464] wH_endDocument
4: [resource://calendar/modules/calUtils.jsm -> file:///C:/Users/andrea/AppData/Roaming/Thunderbird/Profiles/ss3qx4j6.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js:423] wSL_onStopRequest
5: [null:0] null

File sorgente: resource://calendar/modules/calUtils.jsm -> file:///C:/Users/andrea/AppData/Roaming/Thunderbird/Profiles/ss3qx4j6.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Riga: 1029
(In reply to andrea from comment #39)
This bug is not fixed in 2.6.2. It will be fixed with 2.6.3.
(In reply to Pablo from comment #38)
> Unfortunately I'm seeing similar ... I have to restart thunderbird as after
> a while, I get the calendar is `unavailable error'
> 

Hi,

Just to follow up on my post.  It appears this issue has been resolved with the latest drop of Thunderbird (24.1) and the compatible Lightning plug-in.
Releasing Lightning requires a few more manual steps than Thunderbird, it will take a short while. Here is the preliminary build: https://addons.mozilla.org/en-US/thunderbird/addon/lightning/versions/2.6.3
Fixed for me with 2.6.3, which I got through the official channel today.
+1
What a relief!
Experiencing the defunct sync with Google Calendar for more several months has shaken my trust in the whole Thunderbird project.

Please don't see that as a criticism, Philipp. I very much appreciate your hard work on this project. THANK YOU!!!!!

What I want to say is that I really think Lightning needs more attention and professional support through Mozilla Foundation.
Lightning is much more than just another add-on. This is one major building block to make Thunderbird a replacement for Outlook.
I'm glad this is working for you and thanks for the kudos! I think we can succeed with more community support, although of course it would be nice to get some extra paid developers. This doesn't need to be Mozilla though, if you know an IT department manager that uses Lightning extensively, maybe its worth asking for support. I have a few projects worth doing :)
Status: RESOLVED → VERIFIED
OUTSCH!
Didn't post for a long time and have "only" been using Lightning - but the 2.6.3 update broke my calDAV calendars! Found a simple answer in JS error console... "r.status is undefined".

I resolved it by just adding a check for the definition of r.status in the lines added by the above patch:
-                 } else if (r.status.indexOf(" 507") > -1) {
+                 } else if (r.status &&
+                             r.status.indexOf(" 507") > -1) {

Sorry for not being able to create an appropriate patch file atm, but you will find it!
Did not do any further code review, since this brought back all my calendar items...
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Sven, could you file a new bug for this? If the status is not defined this must have a deeper meaning. I'd appreciate if you could add some logs with calendar.debug.log and calendar.debug.log.verbose enabled in the new bug.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
I was looking at patches that might explain some of the regressions reported with 2.6.3.

This patch added a new parameter to multigetSyncHandler() and updated one usage. But there are two more places where multigetSyncHandler() is called that were not updated:
http://mxr.mozilla.org/comm-esr24/search?string=multigetSyncHandler

I think the missing parameter causes a shift for all other parameters, i.e. aAdditionalSyncNeeded contains the value of aListener, aListener contains the value of aChangeLogListener and aChangeLogListener is undefined in those cases.
Flags: needinfo?(philipp)
Oh, that sucks, my bad. Looks like we need yet another release. Reopening this one again until all issues are solved.
Status: VERIFIED → REOPENED
Flags: needinfo?(philipp)
Resolution: FIXED → ---
Without taking the bug I just wanted to speedup fixing this. The attached patch simply completes the two remaining calls to multigetSyncHandler() observed by Stefan.
Attachment #8339151 - Flags: review?(philipp)
I found the same problem under Bug 942644 regarding the multiSyncHandler.  Can we get a quick release of 2.6.4 to correct the davical users?
Blocks: 942644
Blocks: 943340
Can this problem be the source of the Bug 942896 I reported?

Thanks!
Blocks: 942896
Attachment #8339151 - Flags: review?(philipp) → review?(matthew.mecca)
Blocks: ltn264
Comment on attachment 8339151 [details] [diff] [review]
bug930132_followup.diff

r=philipp and approval for all branches (c-c/c-a/c-b/comm-esr24)
Attachment #8339151 - Flags: review?(matthew.mecca)
Attachment #8339151 - Flags: review+
Attachment #8339151 - Flags: approval-calendar-release+
Attachment #8339151 - Flags: approval-calendar-beta+
Attachment #8339151 - Flags: approval-calendar-aurora+
Pushed to comm-central changeset 54aa8f1134fe
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: 2.6.3 → 3.0
Backported to releases/comm-aurora changeset 50b62809c6de
Target Milestone: 3.0 → 2.9
Backported to releases/comm-beta changeset 4d36e733d36f
Target Milestone: 2.9 → 2.8
Backported to releases/comm-esr24 changeset a2f5b206e52b
Target Milestone: 2.8 → 2.6.4
Hi, to my latest tests with manual apply patches to 2.6.3 with TB 24.2 linux 64, caldav offline sync now works fine ,same with 2.6.4 ( latest  releases/comm-esr24 ) but i still cannot send invite mail with caldav server ( horde ) where no caldav scheduling is implemented yet.
Duplicate of this bug: 945691
You need to log in before you can comment on or make changes to this bug.