Closed Bug 943261 Opened 9 years ago Closed 9 years ago

[System] Offline page cannot tell 404 from network failure

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 952305

People

(Reporter: alive, Unassigned)

Details

STR:
1. Type http://2345.lkdfs.ss.rgsg in url
2. Go

Expected:
404

Actual:
Always tell you that your network has problem. This is really bad UX!
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 912445
Actually, this is a dupe of bug 952305 for handling other error codes gracefully.
Duplicate of bug: 952305
No longer depends on: 882186
You need to log in before you can comment on or make changes to this bug.