[Dialer][Conference call] Detailed contact info on conference call on group line is missing

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
8 months ago

People

(Reporter: isabelrios, Unassigned)

Tracking

({feature})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [planned-sprint][in-sprint=v2.1-S3])

Attachments

(8 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 8338521 [details]
originalvsscreenshot_2.png

v1.2 11/26 build:
Gecko-6ac8a1e
Gaia-264c604

1. Start a call with a contact
2. Call to another contact
3. Merge both calls

EXPECTED
Below the Group call label, there should appear the contact information. Please see on attached file originavsscreenshot: 'original desing'

ACTUAL
Nothing about the contacts (or number) called is shown, please see 'conference call' screenshot attached
(Reporter)

Comment 1

5 years ago
Created attachment 8338522 [details]
Conference call screenshot.png

Latest screenshot of the conference call screen
David,

Please assign an engineer to the same.
Flags: needinfo?(dscravaglieri)
removing koi? flag per comment https://bugzilla.mozilla.org/show_bug.cgi?id=923646#c16 and ni? to Jaqueline in order she can set up the expected flag here. Thanks!
blocking-b2g: koi? → ---
Flags: needinfo?(jsavory)
Since this one was pushed from koi, hopefully we can complete this for 1.3.
blocking-b2g: --- → 1.3?
Flags: needinfo?(jsavory)
this will be discussed during triage
Flags: needinfo?(dscravaglieri)
triage: minus. let's fix it in 1.4 but not blocking release.
blocking-b2g: 1.3? → -

Updated

4 years ago
Duplicate of this bug: 1025843
blocking-b2g: - → backlog
Assignee: nobody → gtorodelvalle
Hi Carol, would you be so kind to point me to the main ongoing conference call page specs related to this bug? If it still applies including the names of the participants on that main page, of course :) Thanks!
Flags: needinfo?(chuang)
Assignee: gtorodelvalle → jpruden92

Comment 9

4 years ago
Created attachment 8470503 [details]
SPEC.Call_Conferencecallwaiting_Expandableareas.png

Hi Germán,
The screenshot are the visuals before visual refresh, right?

I'll attach the Visual spec for Conference call screen.
Please use the new graphic assets.
Let me know if you still need any other information. Thanks!
Flags: needinfo?(chuang) → needinfo?(gtorodelvalle)
Created attachment 8470817 [details]
SPEC.Call_Incall_Expandableareas.png

Hey Carol! The spec you mention (attachment 8470503 [details]) applies when there is an additional call apart from the conference call itself, right? :)
In case the conference call is the only ongoing call, I guess the spec to apply is the one I am attaching here, right? :)
Thanks!
Flags: needinfo?(gtorodelvalle) → needinfo?(chuang)
Hi Germán,
Yes, if the conference call is the only ongoing call, the spec you attached (attachment 8470817 [details]) is correct.
Thank you!:)
Flags: needinfo?(chuang) → needinfo?(gtorodelvalle)
Thanks! Jorge is currently working on this bug based on the provided specs ;)
Flags: needinfo?(gtorodelvalle)
Hi Carrie,

What name format do I have to show on contact details? Do I have show the full name of the contact?

Thanks!
Flags: needinfo?(cawang)
Hi Jorge, 

We should display what users exactly set for that contact. So if user set the contact with the full name (first name + last name), we will display it on call pages (in every different scenarios). Thanks!
Flags: needinfo?(cawang)
Status: NEW → ASSIGNED
Created attachment 8472869 [details]
[screenshot] Merge two calls.png
Created attachment 8472870 [details]
[screenshot] Conference.png
Created attachment 8472872 [details]
[screenshot] Merge conference with call.png
Attachment #8472872 - Flags: ui-review?(chuang)
Attachment #8472872 - Flags: feedback?(gtorodelvalle)
Attachment #8472872 - Flags: feedback?(gtorodelvalle)
Attachment #8472870 - Flags: ui-review?(chuang)
Attachment #8472869 - Flags: ui-review?(chuang)
Attachment #8472878 - Flags: feedback?(gtorodelvalle)

Updated

4 years ago
Attachment #8472872 - Flags: ui-review?(chuang) → ui-review+

Updated

4 years ago
Attachment #8472870 - Flags: ui-review?(chuang) → ui-review+
Comment on attachment 8472869 [details]
[screenshot] Merge two calls.png

Looks good! thank you, Jorge!
Attachment #8472869 - Flags: ui-review?(chuang) → ui-review+
Attachment #8472878 - Flags: feedback?(gtorodelvalle)
Attachment #8472878 - Flags: feedback?(gtorodelvalle)
Comment on attachment 8472878 [details]
22875.html

There are some test cases not passing due to this patch as you can see at https://tbpl.mozilla.org/?rev=a4e73cee96e180ce4d3e16ae740a3eb0429743ba&tree=Gaia-Try We'll deal with them in person as well as with other issues I would like to comment ;)
Attachment #8472878 - Flags: feedback?(gtorodelvalle) → feedback-
Target Milestone: --- → 2.1 S3 (29aug)

Updated

4 years ago
QA Contact: lolimartinezcr
Created attachment 8478183 [details]
23266.html
Attachment #8472878 - Attachment is obsolete: true
Attachment #8478183 - Flags: feedback?(gtorodelvalle)
Comment on attachment 8478183 [details]
23266.html

I left some comments in Github ;) attachment 8478183 [details]
Attachment #8478183 - Flags: feedback?(gtorodelvalle) → feedback-
Attachment #8478183 - Flags: feedback- → feedback?(gtorodelvalle)
Comment on attachment 8478183 [details]
23266.html

Just a minor comment on Github, please include it ;) Anyhow f+ :) Please, ask a peer for the final revision ;) Thanks!
Attachment #8478183 - Flags: feedback?(gtorodelvalle) → feedback+
Attachment #8478183 - Flags: review?(anthony)
Whiteboard: [planned-sprint][in-sprint=v2.1-S3]
Target Milestone: 2.1 S3 (29aug) → 2.1 S4 (12sep)
Comment on attachment 8478183 [details]
23266.html

We have an L10n issue with this patch.

Also, I haven't tested on a device but I'm surprised we don't need to add some text-overflow CSS.
Attachment #8478183 - Flags: review?(anthony) → review-
Target Milestone: 2.1 S4 (12sep) → ---
Assignee: jpruden92 → nobody
Blocks: 1036516
Hi Doug,

I would like to work on this bug.Is there anyone still working on this bug or is it okay if I take it.

Thank you.
Flags: needinfo?(drs.bugzilla)
Hi Doug,

I see that we can't reproduce it using mulet.I don't have a device.

Sorry that I can't help.

Thanks.
Flags: needinfo?(drs.bugzilla)
(Assignee)

Updated

4 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
tracking-b2g: backlog → ---
Keywords: feature

Comment 27

8 months ago
Firefox OS is not being worked on
Status: ASSIGNED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.