B2G desktop startup crash | libxul.so!MarkInternal<JSObject>

RESOLVED DUPLICATE of bug 942421

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 942421
5 years ago
5 years ago

People

(Reporter: ahal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [b2g-desktop-builds])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 8338642 [details]
crash stack

I'm encountering a crash on startup for b2g desktop. I've attached the crash stack and the mozconfig I used.

STR:
* build with attached mozconfig
* <objdir>/dist/bin/b2g -profile path/to/gaia/profile

Results:
I see the locale picker very briefly and then the attached crash occurs.

Additional info:
* First noticed this yesterday (regression range unclear)
* I'm using mozilla-central with gaia master, both recently pulled.
* I've tried building gaia with many different permutations (DESKTOP_SHIMS, NOFTU, DEBUG) and they don't seem to make any difference.
* I'm on Fedora 19 64 bit
(Reporter)

Comment 1

5 years ago
Created attachment 8338643 [details]
mozconfig
(Reporter)

Updated

5 years ago
Whiteboard: [b2g-desktop-builds]
(Reporter)

Comment 2

5 years ago
I can reproduce this on my laptop which is also running Fedora 19 64bit.

Comment 3

5 years ago
Can you please bisect this?  Thanks!
Component: General → JavaScript Engine
Flags: needinfo?(ahalberstadt)
Product: Firefox OS → Core
(Reporter)

Comment 4

5 years ago
Should have checked this earlier, but I can't reproduce on downloaded builds from ftp.m.o. I'm not sure what I'm doing differently, my mozconfig is the same as the one in https://developer.mozilla.org/en-US/Firefox_OS/Using_the_B2G_desktop_client#Create_a_mozconfig except for the ENABLE_MARIONETTE=1 at the end.

I'll try building from an old m-c checkout.
Flags: needinfo?(ahalberstadt)
(Reporter)

Comment 6

5 years ago
Sorry it's taking so long, needing to build each time has been a bit time consuming. I've narrowed it down to sometime between Nov 21st and Nov 22nd:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=09e33431c543&tochange=b9980eb88a26

I'll continue chipping away at it, I'll start using my laptop as a dedicated build machine so hopefully it'll go a little faster from here on out.
(Reporter)

Comment 7

5 years ago
So the culprit is http://hg.mozilla.org/mozilla-central/rev/3b9e118ded0f

Ehsan, any ideas?
Flags: needinfo?(ehsan)

Comment 8

5 years ago
Well crap!

Two questions:

1. Can you please try the latest inbound which has fixes to a couple of regressions from that bug?
2. If 1 doesn't work, can you please open js/src/moz.build, find the UNIFIED_SOURCES chunk here (http://hg.mozilla.org/mozilla-central/rev/3b9e118ded0f#l9.13), and then start "bisecting" that list by moving parts of it to SOURCES until you find the minimum number of files which need to be moved to SOURCES to make this bug go away?

(Also, out of curiosity, what compiler are you using?)
Blocks: 941424
Flags: needinfo?(ehsan) → needinfo?(ahalberstadt)
(Reporter)

Comment 9

5 years ago
Yay, it worked on inbound! For the record I was using gcc 4.8.2
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(ahalberstadt)
Resolution: --- → WORKSFORME

Comment 10

5 years ago
Thanks for verifying.  I'm thinking that this is probably a dupe of bug 942421.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 942421
You need to log in before you can comment on or make changes to this bug.