Closed Bug 943518 Opened 8 years ago Closed 8 years ago

tpaint regression on win8 introduced Nov 22 on Fx-Team

Categories

(Testing :: Talos, defect)

All
Windows 8
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: jmaher, Unassigned)

Details

(Keywords: perf, regression, Whiteboard: [talos_regression])

Attachments

(1 file)

found a regression which landed on fx-team on Friday.  This is in the tpaint talos test and only seen on windows 8:

graph server:
http://graphs.mozilla.org/graph.html#tests=[[82,132,31]]&sel=none&displayrange=30&datatype=running

datazilla:
https://datazilla.mozilla.org/?start=1383004064&stop=1385490033&product=Firefox&repository=Fx-Team-Non-PGO&test=tpaint&page=tpaint&graph_search=0817a274a7aa&tr_id=3649040&graph=win%206.2.9200&x86=false&x86_64=true&error_bars=false&project=talos

while we appear to have had an improvement, the improvement was wiped out by recent changes.  

From what I can tell this is related to bug 941990.
this could be a dup of bug 936078 as that is a tpaint regression/improvement.

Here is more information about tpaint:
https://wiki.mozilla.org/Buildbot/Talos/Tests#tpaint

:jaws- do you think the tpaint test be affected by your patch?
Blocks: 941990
Flags: needinfo?(jaws)
Keywords: perf, regression
Whiteboard: [talos_regression]
Looking in to it.
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Attached patch Patch attemptSplinter Review
This patch would delay showing the panel until after the event loop has spun once. Although I'm not sure why ensureReady would be called during a tpaint run.

try push:
https://tbpl.mozilla.org/?tree=Try&rev=c863f51c0046

baseline:
https://tbpl.mozilla.org/?tree=Try&rev=27cf006a3ac3
oh, tpaint is a talos test in the other suite, this is mochitest-other on the try pushes:
try: -b o -p win32 -u none -t other
(In reply to Joel Maher (:jmaher) from comment #4)
> oh, tpaint is a talos test in the other suite, this is mochitest-other on
> the try pushes:
> try: -b o -p win32 -u none -t other

Yeah I know.... that's what I get for programming at 3am.

Try push:
https://tbpl.mozilla.org/?tree=Try&rev=e03f20342a4e

Baseline:
https://tbpl.mozilla.org/?tree=Try&rev=8e67f3cdf646
Flags: needinfo?(jaws)
tpaint with patch:
- min: 166.74
- mean: 167.61
- max: 168.86

tpaint baseline:
- min: 165.85
- mean: 167.315
- max: 168.96

so it looks like this patch didn't do anything meaningful. None of this code change in the blamed patch should affect runtime unless customization mode is entered or the menu panel is opened, and tpaint does none of that. The panel was previously unhidden a little bit later, but it still was only unhidden if the panel was opened (wasn't unhidden if customization mode was entered without showing the panel). We do a little bit more work now when the panel is initialized, but that requires the panel to be opened as well.

I'm not sure what could have caused a regression on this patch. Perhaps it was a different patch?
I pushed another patch to the tryserver that will Cu.reportError when ensureReady is called so we can make sure that it isn't called during the tpaint run.

https://tbpl.mozilla.org/?tree=Try&rev=20c7dbe3d369

Joel, what do you think is the next step here?
Flags: needinfo?(jmaher)
:jaws- I will look at a few other changesets before after yours, it could have been with the noise levels that you ended up looking like the most likely candidate.  I did some retriggers on the original pushes- should know more between that and your try push if we found the winner.
Flags: needinfo?(jmaher)
this seems to be from a merge:
https://tbpl.mozilla.org/?tree=Fx-Team&startdate=2013-11-22&enddate=2013-11-23&rev=1f3c4189ecc1

I did a bunch of retriggers to get to that conclusion.  

I will hunt around on m-i/m-c to see if I can narrow this down.

:jaws, sorry to have you spend time on this.
Assignee: jaws → nobody
No longer blocks: 941990
Component: Menus → Talos
Product: Firefox → Testing
(In reply to Joel Maher (:jmaher) from comment #9)
> :jaws, sorry to have you spend time on this.

No problem, too bad I wasn't able to fix the regression.
(In reply to Joel Maher (:jmaher) from comment #9)
> this seems to be from a merge:
> https://tbpl.mozilla.org/?tree=Fx-Team&startdate=2013-11-22&enddate=2013-11-
> 23&rev=1f3c4189ecc1
> 
> I did a bunch of retriggers to get to that conclusion.  
> 
> I will hunt around on m-i/m-c to see if I can narrow this down.
> 
> :jaws, sorry to have you spend time on this.

Did something happen here and/or should we now close this bug?
Flags: needinfo?(jmaher)
nothing happened here, I vote for closing this as wontfix.
Flags: needinfo?(jmaher)
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.