Closed Bug 943547 Opened 7 years ago Closed 6 years ago

[B2G][Task Manager][Keyboard]Apps that have the keyboard open when home button is pressed display inappropriately in Task Manager.

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1022540

People

(Reporter: rkuhlman, Unassigned)

References

Details

(Keywords: regression, Whiteboard: ux-most-wanted, user-research [systems-fe])

Attachments

(3 files)

Attached file logcat.txt
The user is using an app and the keyboard is displayed. The user presses the home button to navigate to a different app, while the keyboard is still displayed. The app card will display inappropriately in the task manager. The card appears to be zoomed in on the upper left corner of the app.

Repro Steps:
1) Updated Buri to Build ID: 20131126004001
2) Launch an app that allows the user to display the keyboard. (ex: Messaging App)
3) Tap in a text field to display the keyboard.
4) Long press the home button to display the task manager.
5) Observe the card for the App that was previously open.

Actual:
The card appears to be zoomed into the top left corner of the app page.

Expected:
The entire app page is visible.

Environmental Variables
Device Buri v 1.2 COM RIL
Build ID: 20131126004001
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/21e2ad082d85
Gaia: 264c6044b941437ac3c4b28fe4ca392d2bc78445
Platform Version: 26.0
RIL Version: 01.02.00.019.102 
Firmware Version: V1.2_20131115


Notes:
Repro frequency: 100%
See attached screenshot and logcat.
Optional extra notes:
This issue happens anytime the user uses the home key to navigate away from an app with the keyboard displayed. They do not have to longpress the home key while the app is open.
Issue does not occur in 1.1
Probably not going to block at this point, although this is an odd bug.
Component: Gaia::Keyboard → Gaia::System::Window Mgmt
Keywords: regression
Blocks: 994991
Whiteboard: ux-most-wanted, user-research
Long-tap on home to bring up cards view while editing a calendar entry title.
Depends on: 1033971
Whiteboard: ux-most-wanted, user-research → ux-most-wanted, user-research [systems-fe]
Duping against bug 1022540 which is assigned.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1022540
You need to log in before you can comment on or make changes to this bug.