Closed Bug 943632 Opened 7 years ago Closed 7 years ago

TEST-UNEXPECTED-FAIL | /builds/slave/test/build/mozmill/content-policy/test-view-source.js | test-view-source.js::test_view_source_reload

Categories

(Thunderbird :: Message Reader UI, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 28.0

People

(Reporter: aceman, Assigned: mkmelin)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

The test-view-source.js fails like this in recent trunk:
SUMMARY-PASS | test-view-source.js::setupModule
SUMMARY-UNEXPECTED-FAIL | C:\slave\test\build\mozmill\content-policy\test-view-source.js | test-view-source.js::test_view_source_reload
  EXCEPTION: Did not find matching menu item for action index 0: {"id":"charsetMenu"}
    at: test-window-helpers.js line 1009
       _click_menus test-window-helpers.js 1009
       test_view_source_reload test-view-source.js 88
       Runner.prototype.wrapper frame.js 585
       Runner.prototype._runTestModule frame.js 655
       Runner.prototype.runTestModule frame.js 701
       Runner.prototype.runTestDirectory frame.js 525
       runTestDirectory frame.js 707
       Bridge.prototype._execFunction server.js 179
       Bridge.prototype.execFunction server.js 183

Assuming this was caused by bug 805374, where it removes the id=charsetMenu item from the menu of the view source window. It should be reintroduced in bug 940907.

It seems the whole point of the test is to operate on that menu so removing it kills the test. Do we disable it for now? How is that done?
Yeah we should just disable it for now.
Could just do if true here http://mxr.mozilla.org/comm-central/source/mail/test/mozmill/content-policy/test-view-source.js#31
Attached patch proposed fixSplinter Review
Disable the test to fix oranges, until the test can actually work again.
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #8339872 - Flags: review?(mbanner)
Attachment #8339872 - Flags: review?(mbanner) → review+
https://hg.mozilla.org/comm-central/rev/7fa6a00eb645 -> FIXED
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 28.0
You need to log in before you can comment on or make changes to this bug.