Closed Bug 944079 Opened 6 years ago Closed 6 years ago

[Australis] Remove one of the two hover states of items in the bookmarks panel

Categories

(Firefox :: Theme, defect)

28 Branch
x86
All
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: phlsa, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P-])

Attachments

(2 files)

Attached image different hover states
Items in the bookmark list panel (next to the star icon) have two different hover states. We should reduce that to only one state that gets triggered immediately. My vote goes for the second state (see attached image) because it is visually less busy.
Comment on attachment 8339490 [details]
different hover states

We are doing a weird thing where we have a hover state and an active state. We really just need a hover state. Also no inverted arrows.

I put the intended behavior in the latest interactive mockup: https://people.mozilla.org/~shorlander/mockups-interactive/australis-interactive-mockups/windows8.html
I see the two different styles on Windows also.
Summary: [Australis][Mac] Remove one of the two hover states of items in the bookmarks panel → [Australis] Remove one of the two hover states of items in the bookmarks panel
Whiteboard: [Australis:P4]
Blocks: 963098
Whiteboard: [Australis:P4] → [Australis:P-]
With shorlanders mockup as a reference, here's what needs to be done:
1) Remove the fading of the hover state, so that the menu feels more responsive
2) Get rid of the secondary hover state (when long-hovering over a folder)
3) Get rid of the white arrows that flash through at the moment
1 and 3 appear to be Mac only by the way.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
(In reply to Philipp Sackl [:phlsa] from comment #3)
> With shorlanders mockup as a reference, here's what needs to be done:
> 1) Remove the fading of the hover state, so that the menu feels more
> responsive

The fading is the same across all of the subviews and the panel menu. Do you really want it removed *just* for the bookmarks menu? Everywhere? Neither?
Flags: needinfo?(shorlander)
Flags: needinfo?(philipp)
This does everything except adjusting the fade, awaiting ux decision on that one.
Attachment #8382584 - Flags: review?(MattN+bmo)
Attachment #8382584 - Flags: review?(MattN+bmo) → review+
You realize this is currently a P-, right? ;)
(In reply to Matthew N. [:MattN] from comment #7)
> You realize this is currently a P-, right? ;)

It blocks the P2 "bookmarks panel polish" bug, and is on the UX blocker list, though...
(In reply to :Gijs Kruitbosch from comment #6)
> Created attachment 8382584 [details] [diff] [review]
> remove double hover state in bookmarks menu,
> 
> This does everything except adjusting the fade, awaiting ux decision on that
> one.

Tested it and it's looking good!
I think we can keep it that way!
Flags: needinfo?(philipp)
Alright!

remote:   https://hg.mozilla.org/integration/fx-team/rev/67913237769c
Flags: needinfo?(shorlander)
Whiteboard: [Australis:P-] → [Australis:P-][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/67913237769c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P-][fixed-in-fx-team] → [Australis:P-]
Target Milestone: --- → Firefox 30
(In reply to Philipp Sackl [:phlsa] from comment #4)
> 1 and 3 appear to be Mac only by the way.

Windows XP also has the white arrow on hover. Note sure if it's important to support XP though, as XP is gonna get unsupported soon.
Flags: needinfo?(gijskruitbosch+bugs)
(In reply to Tim Nguyen [:ntim] from comment #12)
> (In reply to Philipp Sackl [:phlsa] from comment #4)
> > 1 and 3 appear to be Mac only by the way.
> 
> Windows XP also has the white arrow on hover. Note sure if it's important to
> support XP though, as XP is gonna get unsupported soon.

Please file a new bug for this.
Flags: needinfo?(gijskruitbosch+bugs)
(In reply to Tim Nguyen [:ntim] from comment #12)
> (In reply to Philipp Sackl [:phlsa] from comment #4)
> > 1 and 3 appear to be Mac only by the way.
> 
> Windows XP also has the white arrow on hover. Note sure if it's important to
> support XP though, as XP is gonna get unsupported soon.

AFAIK a large number of Firefox Users still use XP. Unless we see that number go down significantly after the discontinuation by Microsoft, it makes sense to keep supporting it well.
Depends on: 978309
(In reply to :Gijs Kruitbosch from comment #13)
> (In reply to Tim Nguyen [:ntim] from comment #12)
> > (In reply to Philipp Sackl [:phlsa] from comment #4)
> > > 1 and 3 appear to be Mac only by the way.
> > 
> > Windows XP also has the white arrow on hover. Note sure if it's important to
> > support XP though, as XP is gonna get unsupported soon.
> 
> Please file a new bug for this.

Filed bug 978309.
Comment on attachment 8382584 [details] [diff] [review]
remove double hover state in bookmarks menu,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: bookmark panel has strange hover/active states
Testing completed (on m-c, etc.): on m-c for a long time now
Risk to taking this patch (and alternatives if risky): low. Known issue (bug 978309) but that was likely an issue before, and we should be able to fix it in time for 29's release. Additionally, a bunch of the remaining panel polish depends on this landing, so I think we should uplift now to avoid keeping back a bunch of bugs until the last moment.
String or IDL/UUID changes made by this patch: none
Attachment #8382584 - Flags: approval-mozilla-aurora?
Attachment #8382584 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.