Closed Bug 944635 Opened 6 years ago Closed 5 years ago

B2G RIL: Exception in updateDisplayCondition() ... "TypeError: RIL.operator is null"

Categories

(Firefox OS Graveyard :: RIL, defect)

ARM
Linux
defect
Not set

Tracking

(blocking-b2g:1.4+, firefox31 wontfix, firefox32 fixed, firefox33 fixed, b2g-v1.3T affected, b2g-v1.4 fixed, b2g-v2.0 fixed, b2g-v2.1 fixed)

RESOLVED FIXED
2.0 S5 (4july)
blocking-b2g 1.4+
Tracking Status
firefox31 --- wontfix
firefox32 --- fixed
firefox33 --- fixed
b2g-v1.3T --- affected
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: edgar, Assigned: sku)

References

Details

(Whiteboard: [good first bug])

Attachments

(1 file, 1 obsolete file)

11-28 11:29:05.900 I/Gecko   (  106): RIL Worker[0]: Parcel handling threw TypeError: RIL.operator is null
11-28 11:29:05.900 I/Gecko   (  106): updateDisplayCondition@resource://gre/modules/ril_worker.js:12526
11-28 11:29:05.900 I/Gecko   (  106): callback@resource://gre/modules/ril_worker.js:11477
11-28 11:29:05.900 I/Gecko   (  106): processICCIOReadBinary@resource://gre/modules/ril_worker.js:11301
11-28 11:29:05.900 I/Gecko   (  106): ICC_COMMAND_READ_BINARY@resource://gre/modules/ril_worker.js:11335
11-28 11:29:05.900 I/Gecko   (  106): processICCIO@resource://gre/modules/ril_worker.js:11071
11-28 11:29:05.900 I/Gecko   (  106): REQUEST_SIM_IO@resource://gre/modules/ril_worker.js:5263
11-28 11:29:05.900 I/Gecko   (  106): handleParcel@resource://gre/modules/ril_worker.js:4885
11-28 11:29:05.900 I/Gecko   (  106): processParcel@resource://gre/modules/ril_worker.js:149
11-28 11:29:05.900 I/Gecko   (  106): processIncoming@blob:20620634-c668-4585-ac92-4d20b92f204e:536
11-28 11:29:05.900 I/Gecko   (  106): onRILMessage@resource://gre/modules/ril_worker.js:13555

Please see bug 944230 comment #2.
This bug was reported originally in bug 944230 comment #2.
And the log is located in attachment #8339707 [details].
Whiteboard: [good first bug]
See this issue on France Orange sim card, too.
happened on USIM card from CUCC.
blocking-b2g: --- → backlog
Attachment #8443222 - Flags: review?(htsai)
Assignee: nobody → sku
Comment on attachment 8443222 [details] [diff] [review]
Bug 944635 - B2G RIL: Exception in updateDisplayCondition() ... "TypeError: RIL.operator is null"

Review of attachment 8443222 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good.
Attachment #8443222 - Flags: review?(htsai) → review+
https://hg.mozilla.org/mozilla-central/rev/3a05fcd14cab
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S5 (4july)
Duplicate of this bug: 1035058
nominate 1.4? per Sam's comment in bug 1035058
blocking-b2g: backlog → 1.4?
What's the user impact of not taking fix in 1.4? Sounds like confusing UX, is this right?
Flags: needinfo?(htsai)
(In reply to Preeti Raghunath(:Preeti) from comment #12)
> What's the user impact of not taking fix in 1.4? Sounds like confusing UX,
> is this right?

The impact will be wrong operator name displayed on UI.
Ex:
SPN: ABC
PLMN: 1234

Per 3GPP spec., We might need to display "ABC" as operator name for some circumstance, but show "1234" instead.
Thanks Shawn for the reply.
Flags: needinfo?(htsai)
blocking-b2g: 1.4? → 1.4+
Could you provide the detailed reproduce steps and video for me to verify this bug. Thanks!
Flags: needinfo?(echen)
Hi Sue, this bug is reproduced in booting up stage with the sim contains EF_SPN inserted.
The easier way to verify this is to check the log, after this fix you should not see any error like comment #0. Hope this help. Thank you.
Flags: needinfo?(echen)
You need to log in before you can comment on or make changes to this bug.