"There is not enough disk space to download new messages" - message incorrect

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
5 years ago
13 days ago

People

(Reporter: ian, Unassigned)

Tracking

(Depends on: 1 bug)

24 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131112160018

Steps to reproduce:

1) Start Thunderbird 24.1.1 on OSX 10.8.5 Retina Makbook Pro with SSD 
2) Get Mail.




Actual results:

Alert "There is not enough disk space to download new messages. Try deleting old mail, emptying the Trash folder, and compacting your mail folders, and then try again."

No email downloaded.




Expected results:

Email should download. I have tried compacting folders and emptying trash. There is almost 200Gb of free space. Other bug reports concerning this error ( 750207  and 236218 ) are marked fixed or expired. Error started 30/11/13.
(Reporter)

Comment 1

5 years ago
OK - it turns out the 'Bug' is with the text which is misleading and I therefore misunderstood. I would suggest that it should be re-phrased as follows:

"Your Inbox has reached maximum capacity. Try deleting old mail, emptying the trash folder, moving messages to archive folders, and compacting your mail folders; then try again. There is a 4Gb limit on any one Thunderbird folder."
(In reply to ian from comment #0)
> Actual results:
> Alert "There is not enough disk space to download new messages. Try deleting old mail,
> emptying the Trash folder, and compacting your mail folders, and then try again."
According to bug 789679 comment #14, when "move mails", warning about "over 4GB" is one like following(English translatin of actual Spanish message by Spanish version of Tb).
> "The folder 2012 is full, and can't hold anymore messages.
> To make room for more messages, delete any old or unwanted mail and compact folder."
It looks that "warning upon pop3 mail download" is different from one upon Copy/Move.
What message do you see when you try to copy or move mails to Inbox after you saw the warning message upon mail download?

(In reply to ian from comment #1)
> I would suggest that it should be re-phrased as follows:
> "Your Inbox has reached maximum capacity. (snip)
> There is a 4Gb limit on any one Thunderbird folder."
Does it mean that file size of Inbox(not Ibox.msf) exceeded 4GB in your environment?
Is relevant account POP3?

If both answers is YES, it's perhaps combination of following known issues, because Tb has logic of "never add mail data to file if file size exceeds 4GB-α where 0<α<several MB and issues warning of Folder Full(==pretty near to 4GB limit)".
(1) When Tb tries to download POP3 mails, file size < 4GB-α, so above "Folder Full" warnng
    is not issued, and Tb starts download of POP3 mails.
(2) Tb simply appends downloaded mail data at end of file named Inbox.
    Because "file size limit in file system is far greater than 4GB", the "append at end
    of file" is normally executed with no problem.
(3) During (2), Tb doesn't check "file size after download a new mail" before download the
    new mail. So, if many mails or big mails are downloaded by single new mail check
    interval, file size can exceed 4GB limit. This is a part of bug 634544.
(4) After it, because 4GB-α < file size, "warning about folder full" is always issued,
    until file size is reduced by user's action.
    This is phenomenon of bug 789679.

FYI.
(1) In Bug 789679, developers are tryng to remove 4GB limit in BerkleyStore for local mail
    folder. See dependency tree for that bug.
(2) "MaildirStore" is already implemented and is available for testing, although it has
    manay many many ... many problems especially when IMAP is involved or BarkleyStore is
    mixed, as seen in dependency tree for meta bug 859011.
    (usable only when "POP3 with MaildirStore" + "Local Folders with MaildirStore" only)
    See also meta bug 845952 and its dependency tree.
    This is also challenge of "remove 4GB limit".
(Reporter)

Comment 3

5 years ago
The message was displayed when trying to download mails. I was able to move email out of the Inbox which cleared the problem.

The inbox was I believe at 4Gb and I am using POP3

I trust your further comments will help to decide if the message should be changed as I suggest. I confess they went above my head!
(In reply to ian from comment #3)
> I was able to move email out of the Inbox which cleared the problem.
Thanks for your answer, but I asked about message when you try to move(or copy) mail(s) from other than Inbox to Inbox for which message of "There is not enough disk space to download new messages. ..." was issued by Tb, and file size of which exceeded 4GB.

> The inbox was I believe at 4Gb (snip)
"Actual file size of an actually existent file on actually existent HDD" is usually absolutely irrelevant to your "belief" on the Earth.
What is actual file size?
(Reporter)

Comment 5

5 years ago
I only had a message when trying to download new messages to my inbox? Click 'Get Mail' = message! Nothing else caused it.

I cannot tell you the actual file size when there was the error as I did not check before resolving it by moving messages out of the Inbox. It is possible it was approaching 4Gb as there was a lot of stuff and some of the archive folders I made are large!
Oh, you already did "Compact after delete some mails" correctly, and, unfortunately for me, bug 794303 didn't occur because you deleted sufficient mails correctly :-)

> some of the archive folders I made are large!
As known by Bug 789679 and its dependency tree, "over 4GB problem" can happen upon "pop3 mail download" only(may happen upon writing to Sent/Drafts/Templates if mail send code doesn't use Copy/Move module, but, IIRC, "over 4GB of Sent" problem is already resolved.)
And, Archive == "Move mails from a folder to Archives folder or subfolder of Archives".
And, warning message upon "Copy/Move" is "The folder xxx is full, and can't hold anymore messages ..." like one.
Therefore, you don't need to worry about Archive case :-)

> I trust your further comments will help to decide
> if the message should be changed as I suggest. I confess they went above my head!

I don't know where/by which module/by what reeason the Alert of "There is not enough disk space to download new messages...", so I can say nothing about your proposal on "message string change".
If string is blindly changed to "Folder is full. ...", the warning after change is obviously wrong if "free disk space just before start new mail check interval" is less than a threshold.
Code around "free disk space check", "file size check", "total mail data size", "each downloaded mail data size" which is relevant to POP3 download, are pointed in bug 634544 and some other bugs.
See code, check used message for alert(s) in POP3 download, and check modules who use the message in his alert, please.
(Reporter)

Comment 7

5 years ago
OK I can understand that there are different possible scenarios under which the currently confusing alert message might appear. Apologies that I have no further information to give you which might help to determine exactly the conditions surrounding my own issue where I was apparently unable to download new mail.

If it would be wrong to state "Your Inbox has reached maximum capacity" given the message might be displayed under conditions where this is NOT the case that's fine. The point I am making is that for humble users such as myself wanting to get their email it is confusing to have the current message displayed which starts with "There is not enough disk space...", when in fact there is lots available on the computer. The current message was unhelpful to me; I was unable to resolve my issue as I had not understood that I just had too many emails in my Inbox! It was only after spending quite some time researching (and after having got far enough to convince myself that this must be an unresolved bug which had been previously reported but seemed to be no longer active - hence this report), that I eventually found a post on a forum suggesting that messages needed to be moved out of the Inbox. As soon as I took this remedial action matters were resolved. 

So - perhaps some more general wording could be used which at least suggests that one of the things to look at is 'archiving' messages to move then away from the Inbox. "Try deleting old mail" is not very helpful if the user wants to keep it!
(In reply to ian from comment #7)
> "Try deleting old mail" is not very helpful if the user wants to keep it!

I absolutely agree with you on that "Try deleting old mail" is not so appropriate message when file size is near 4GB limit(as designed) or when file size unfortunately exceeded "4GB limit" due to unwanted/never-intentional Tb's bug.
Even if file size is too larger than Tb's file size limit of 4GB, we can not say/shouldn't say "some of your old mails in this mail folder are useless, so delete them, please".
An accurate and useful/helpful expression in this case is;
  File size of file for mail folder used by our lovely Tb will exceed our unfortunate file
  size limit of 4GB, if your xxx KB mail which arrived at your POP3 server's Mbox(server
  name=pop3.x.y.z, username=uuu@pop3.x.y.z).
  Sorry but we can currently not hold "total mail data size larger than 4GB" in an our
  file for mail folder.
  Please tell us what is your want, or tell us what we should do for you.
  - Ignore the new mail(s) in your POP3 server's Mbox, and delete the new mail(s)
    from your POP3 server's Mbox.
  - Wait for "you move old mails to other(or newly created) mail folder and you kindly
    do "Compact folder" in order to reduce file size.
But, I believe it's too lengthy for "Alert message issued by Tb".
What message is best for you?
What message is best for majority of general Tb users on the Earth excluding you?

By the way, even though your request of "improvement of an alert message issued by Tb" is absolutely proper and valid, I believe "waiting for resolving Bug 789679 by kind developers who are volunteers" is far fruitful for us.
What do you think?
(Reporter)

Comment 9

5 years ago
A message which is more helpful to users... As my original suggestion might on occasion be wrong perhaps something like:

"Sorry! There is a problem downloading new messages. Try making more space by moving or deleting old mail. Also empty the trash folder and compact your mail folders. Once you have done this try again."

If appropriate add "If the problem persists..... [whatever]" at the end. Not sure how this would go on but it might be something like "check you internet connection and login details / have a cup of tea / bow three times to the new moon" etc.

Are you suggesting a proposal of this kind be added to bug 789679 or is it OK here?
(In reply to ian from comment #9)
> Are you suggesting a proposal of this kind be added to bug 789679 or is it OK here?
Absolutely No.

That bug is trying to remove "4GB limit" by expanding "number of bits for file size" to around 51bits(64bits integer is used, but due to restriction in ECMAScript, usable number of bits for file size is less than 64bits).
It'll make message proposed by you useless, because "file size of full 51bits" is nearly impossible on actually available PC or PC in near future, unless Desktop size ”hyper cluster of many Blue Gene with hyper disk array" will be sold soon in $1,000 with maximum power consumption = several hundreds Watts :-)

Comment 11

4 years ago
bug 454359 can cause the error message to display
Summary: There is not enough disk space to download new messages - message incorrect → "There is not enough disk space to download new messages" - message incorrect

Updated

11 months ago
Depends on: 454359

Updated

9 months ago
Duplicate of this bug: 1150346

Comment 13

2 months ago
Ian, do you see this issue when using version 60?
Flags: needinfo?(ian)
Whiteboard: [closeme 2018-10-15]
(Reporter)

Comment 14

2 months ago
I have not had a recent problem with lack of disk space so I cannot be certain what would happen.

As I said at the top of the tread - the text is misleading and I therefore misunderstood. I would suggest that it should be re-phrased as follows:

"Your Inbox has reached maximum capacity. Try deleting old mail, emptying the trash folder, moving messages to archive folders, and compacting your mail folders; then try again. There is a 4Gb limit on any one Thunderbird folder."
Flags: needinfo?(ian)
(Reporter)

Comment 15

2 months ago
Although of course there may not be a 4Gb limit any more and other issues may come into play. I imagine the error message is no longer the name in any case.
(Reporter)

Comment 16

2 months ago
'same' not name!

Comment 17

13 days ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 days ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2018-10-15]
You need to log in before you can comment on or make changes to this bug.