[Contacts] When export contacts which exceed the SIM card memory size, the process will continue till the end if SIM card is already full.

RESOLVED DUPLICATE of bug 944648

Status

Firefox OS
Gaia::Contacts
RESOLVED DUPLICATE of bug 944648
4 years ago
4 years ago

People

(Reporter: Enpei, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8340863 [details]
start exporting 770 contacts to the SIM from 13:32.

If user exports over 250 contacts to the SIM which can only save 250 contacts, exporting process should be stopped when it exports the 251st contact to SIM card. In FxOS, it will keep showing exporting progress over 250 contacts until all contacts are exported from UI, which confuses user due to all contacts from 251st to the end are actually not exported to SIM.

* Build Number                
Gaia:     f64d282b6b44eaaf8cddc8be8f3250cb6fbacd95
Gecko:    0e3362fb5625eb6d98c7617b1b3019a2cc553d47
BuildID   20131202094818
Version   28.0a1

* Reproduce Steps
1. Export over 250 contacts to a SIM card which can only contain 250.

* Expected Result
Process stop at exporting 251st contact and show message to user that SIM card is full.

* Actual Result
It will keep showing exporting progress until the last one which confuses users and wastes of time.

* Occurrence rate
100%
I guess this could be a duplicated of bug 944648.

Also, Noemi, could you confirm that the expected result is what Enpei shows? It looks good to me if we are able to know from the backend that the sim is full.

Cheers,
F.
Flags: needinfo?(noef)
(In reply to Francisco Jordano [:arcturus] from comment #1)
> I guess this could be a duplicated of bug 944648.
> 
> Also, Noemi, could you confirm that the expected result is what Enpei shows?
> It looks good to me if we are able to know from the backend that the sim is
> full.
> 
> Cheers,
> F.

Hi,

I also see this bug as potential duplicate of bug 944648. 
From my point of view it would be fine to interrupt the export process and show a specific message once the SIM card is full in case the backend can provide that information. ni to Ayman to know UX input here. Thanks!
Flags: needinfo?(noef) → needinfo?(aymanmaat)

Comment 3

4 years ago
I would also say this is a duplicate of 944648

how about if we end the export process and output a message saying:

"SIM card full. 'n1' out of 'n2' contacts exported" 
where:
n1 = the number of contacts exported 
n2 = the number of contacts that were attempted to be exported.

...is that technically feasible? let me know and i will knock up some wireframes.
Flags: needinfo?(aymanmaat)
Adding the last UX comment (https://bugzilla.mozilla.org/show_bug.cgi?id=945093#c3) to bug 944648 in order to centrilize there the discussion and marking this bug as duplicate of bug 944648 per comments 1,2 and 3.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 944648
You need to log in before you can comment on or make changes to this bug.