[Contacts] When SIM card is fulled, exporting contact to the SIM will only get no contact exported message, user won't know it's due to SIM storage full.

RESOLVED DUPLICATE of bug 949594

Status

RESOLVED DUPLICATE of bug 949594
5 years ago
5 years ago

People

(Reporter: echu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 8340287 [details]
time stamp:15:16, 11/29.

When SIM card is full, try to export contact to the SIM again, it will only show no contact exported message. User won't know the real reason that SIM is full.

* Build Number                
Gaia:     53bd0adc20e83ccf718c6d2c2a3905efb14d1bef
Gecko:    f239e6a56a72096ac4aff3d4cd8fcc01ac9471b5
BuildID   20131129093923
Version   28.0a1

* Reproduce Steps
1. Export 250 contacts to a SIM.
2. Export more contact to it.

* Expected Result
Suggest to have a warning message clearly indicating the SIM is full.

* Actual Result
no contact is exported message only.

* Occurrence rate
100%
Unfortunately we are not showing any error log when we do the DOM request to save the contact, will need to investigate if in the error message we get something that could tell us that the sim is full.

Thanks!
Issue reported during pre-IOT 1.2 (although not as a blocker).
Blocks: 943796

Updated

5 years ago
Duplicate of this bug: 945093
Adding here the last comment coming from UX (https://bugzilla.mozilla.org/show_bug.cgi?id=945093#c3):

how about if we end the export process and output a message saying:

"SIM card full. 'n1' out of 'n2' contacts exported" 
where:
n1 = the number of contacts exported 
n2 = the number of contacts that were attempted to be exported.

...is that technically feasible? let me know and i will knock up some wireframes.
That's perfect feasible, will need to prioritize among the rest of bugs, but perfectly doable :)
Duplicate of this bug: 952595
Thanks for the feedback. We need this feature included in order to avoid certification issues in the close future. Nominating to 1.4 accordingly.
blocking-b2g: --- → 1.4?

Updated

5 years ago
Blocks: 891754
its in backlog but I do not believe this will make it into v1.4  - we will keep it in the list and review when we come closer to bug fixing in v1.4
Created attachment 8370058 [details]
2014-02-04-15-48-52.png

Hi,

Please find attached a screenshot of the message currently shown in v1.3. It was implemented as part of Bug 949594 because of this we mark this bug as dupe of that one. Thanks!

Updated

5 years ago
Status: NEW → RESOLVED
blocking-b2g: 1.4? → ---
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 949594
You need to log in before you can comment on or make changes to this bug.