[DSDS] Sometimes WiFi will be disabled after turning off airplane mode.

VERIFIED FIXED

Status

defect
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: echu, Assigned: eragonj)

Tracking

unspecified
x86_64
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:1.3+, firefox29 fixed, b2g-v1.3 verified)

Details

(Whiteboard: [dsds_US_test])

Attachments

(3 attachments)

Wifi is connected to an AP. But sometimes after turning on and off airplane mode, Wifi will be disabled. But next time it will be enabled and connected to AP. It's not stable.

* Build Number                
Gaia:     f64d282b6b44eaaf8cddc8be8f3250cb6fbacd95
Gecko:    0e3362fb5625eb6d98c7617b1b3019a2cc553d47
BuildID   20131202094818
Version   28.0a1

* Reproduce Steps
1. Enable wifi and connect to AP.
2. Enable airplane mode, after airplane mode icon shows, diable airplane mode.

* Expected Result
Wifi can be turned on and connected to AP.

* Actual Result
Sometimes Wifi will be disabled.

* Occurrence rate
tried 10 times, 4/10 wifi will be disabled.
Whiteboard: [dsds_US_test]
blocking-b2g: --- → 1.3?
Vincent, I wonder if the root cause of this bug is same as the one of previous bugs.
Flags: needinfo?(vchang)
When there is only SIM2 in device, I cannot reproduce the bug. (SIM 1 has bug 945159 preventing me from verification)
Logs of wpa_supplicant are identical between fail and success case, except for one line:

D/WifiHW  (  106): 'DRIVER SCAN-ACTIVE' command timed out.

This line only shows in fail log, after wpa_supplicant sends 

I/wpa_supplicant( 2373): wlan0: CTRL-EVENT-TERMINATING 

,and follows a longer start time for wpa_supplicant(fail case: >30 seconds, success case: <20 seconds, maybe the wifi is enabled manually in fail case?)


But I can't make any judgment based on the logs.
Blocks: 926342
Change component to Gaia that I might not select correct component in the begining. Wifi is not enabled in this bug, not failed to connect to AP.
Component: Wifi → Gaia::Settings
Flags: needinfo?(vchang)
Based on log, we suspect that Gaia might receive wifi-disabled event later than normal, or no event at all, due to the timeout issue in comment 7.
In such case, the wifi state in settings will still be enable, and the next "airplane mode disable" won't enable the wifi again.

Please help to verify Gaia do receive the wifi disable event after airplane mode is enabled.
Triage: user confusion.

(In reply to Chuck Lee [:chucklee] from comment #6)
> Please help to verify Gaia do receive the wifi disable event after airplane
> mode is enabled.

EJ, could you work with Chunk to diagnose the root cause? Thanks.
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(ejchen)
ok for sure !
Flags: needinfo?(ejchen)
Assignee: nobody → ejchen
Hi Enpei,

I tried several times on latest Gaia and can't reproduce this problem. Are you using quick settings (the panel you pull down from the top of screen) to disable airplane mode or from settings app ?

or if you have time, can you use your fugu show me how you make this problem happen ? thanks :)
Flags: needinfo?(echu)
(In reply to EJ Chen [:eragonj] from comment #9)
> Hi Enpei,
> 
> I tried several times on latest Gaia and can't reproduce this problem. Are
> you using quick settings (the panel you pull down from the top of screen) to
> disable airplane mode or from settings app ?
> 
> or if you have time, can you use your fugu show me how you make this problem
> happen ? thanks :)
Hi EJ, I disable airplane mode from Settings. Log with today's build will be attached.

Gaia      fbb6ce88ce8b7bd4d2efdb7a4a9f5a3c145f3eab
Gecko     a0bb585098cc89c454fac0297b5ef748d5cab82c
BuildID   20131210063021
Version   28.0a1
Flags: needinfo?(echu)
Posted file time stamp: 16:02.
No longer blocks: 926342
See Also: → 926342
I am currently rewriting Airplane mode to make sure it work as what we expected and after some testing on my drafts, it seems that this problem doesn't happen anymore. I think this bug can depend on bug 948847 and will be fixed after it is landed.
Depends on: 948847
Hi Enpei, 

this bug has been fixed after landing bug 948847. Thanks :)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Verified on Fugu

Gaia      fd2154a0f288820933bf727c2b2af3b1b1f47896
Gecko     d8919d498a7bc7c49d7c0eebe5bf340e094c47c0
BuildID   20140117145953
Version   28.0a2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.