Closed Bug 945375 Opened 6 years ago Closed 6 years ago

When choosing share from the three-dot-menu, Firefox crashes.

Categories

(Firefox for Android :: General, defect, critical)

ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 28
Tracking Status
fennec 28+ ---

People

(Reporter: mythmon, Assigned: lucasr)

References

Details

(Keywords: crash, regression, reproducible)

Crash Data

Attachments

(2 files)

I downloaded Nightly today to try out the new share feature. On every webpage I have tried, pressing the sync menu item (from the three dots menu), crashes Nightly, giving the "Unfortunately, Nightly has stopped."

Sharing from the long-press menu works fine.
What device? Any crash ids? about:crashes in the address bar
Galaxy S4 (Tmobile), running Cyanogenmod 10.1.

about:crashes says "No crash reports have been submitted."

Could logcat output be useful? I should be able to get that if it could be useful.
(In reply to Mike Cooper [:mythmon] from comment #2)

> Could logcat output be useful? I should be able to get that if it could be
> useful.

Yes. That would be very useful.
Attached file nightly-share.log
I did this:

$ adb logcat -c
$ adb logcat | tee nightly-share.log

Then I went to my phone, started Firefox, clicked on one of the homepage tiles, clicked the 3dots, then clicked share. It crashed, as usual.

Looking through the logcat, I definitely see some interesting things, but I don't really know enough about the internals to point to anything interesting.
E/GeckoAppShell( 7051): java.lang.NullPointerException
E/GeckoAppShell( 7051): 	at android.view.ViewGroup.addView(ViewGroup.java:3318)
E/GeckoAppShell( 7051): 	at android.view.ViewGroup.addView(ViewGroup.java:3301)
E/GeckoAppShell( 7051): 	at org.mozilla.gecko.GeckoApp.showMenu(GeckoApp.java:379)
E/GeckoAppShell( 7051): 	at org.mozilla.gecko.menu.GeckoMenu.showMenu(GeckoMenu.java:259)
E/GeckoAppShell( 7051): 	at org.mozilla.gecko.menu.GeckoMenu.handleMenuItemClick(GeckoMenu.java:443)
E/GeckoAppShell( 7051): 	at org.mozilla.gecko.menu.GeckoMenu.onItemClick(GeckoMenu.java:423)
tracking-fennec: --- → ?
tracking-fennec: ? → 28+
I'm hitting this on Nightly (11/03, en-US build) on my LG Nexus 4. Crash-stats is piddling around trying to submit my report so I can attach a signature.
Severity: normal → critical
Duplicate of this bug: 945664
Crash Signature: [@ java.lang.NullPointerException: at android.view.ViewGroup.addView(ViewGroup.java)]
Assignee: nobody → lucasr.at.mozilla
This seems like a regression from bug 936756.
Comment on attachment 8342395 [details] [diff] [review]
Unconditionally return mSubmenu in GeckoMenuItem.getSubMenu() (r=rnewman)

Menuitems with an associated ActionProvider depend on mSubMenu too. See:

http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/menu/GeckoMenu.java#434

Although the intent behind the original change to getSubMenu() seems correct. But this approach would only work if the ActionProvider actually held its own reference to its submenu of something. If that was the case, we'd have something like:

public getSubMenu() {
    if (mActionProvider != null && mActionProvider.hasSubMenu()) {
        return mActionProvider.getSubMenu();
    }

    return mSubMenu;
}
Attachment #8342395 - Flags: review?(rnewman)
Comment on attachment 8342395 [details] [diff] [review]
Unconditionally return mSubmenu in GeckoMenuItem.getSubMenu() (r=rnewman)

Review of attachment 8342395 [details] [diff] [review]:
-----------------------------------------------------------------

Yeah, I was seeing problems if I called mActionProvider.getSubMenu -- it was returning a thing that actually wasn't a usable submenu (e.g., for clearing).
Attachment #8342395 - Flags: review?(rnewman) → review+
Duplicate of this bug: 946590
https://hg.mozilla.org/mozilla-central/rev/2bd207736d7b
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
You need to log in before you can comment on or make changes to this bug.