ibm.com - document.layer/document.all dectection

RESOLVED INVALID

Status

Tech Evangelism Graveyard
English US
P1
normal
RESOLVED INVALID
17 years ago
3 years ago

People

(Reporter: Steven H. Levine, Assigned: Doron Rosenberg (IBM))

Tracking

Details

(Whiteboard: [USERAGENT][PROPRIETARY-DOM], URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (OS/2; U; Warp 4; en-US; rv:0.9.3) Gecko/20010803
BuildID:    Mozilla/5.0 (OS/2; U; Warp 4; en-US; rv:0.9.3) Gecko/20010803

0.9.3 displays:

  http://www.ibmlink.ibm.com/usalets&parms=H_301-123

incorrectly compared to 4.61.  The JavaScript console reports errors. 
Probably caused by the floating TOC menu that the site uses.

This display error has been confirmed on both the OS/2 and WinXX builds.

Reproducible: Always
Steps to Reproduce:
1.Display page
2.
3.

Actual Results:  Page displayed incorrectly.  JavaScript console reported error.

Expected Results:  It should have displayed as it appears with Netscape 4.61.
page uses document.layers for mozilla.  over to evangelism.
Assignee: rogerl → bclary
Status: UNCONFIRMED → NEW
Component: Javascript Engine → Evangelism
Ever confirmed: true
QA Contact: pschwartau → zach

Comment 2

17 years ago
someone needs to contact them...
Summary: Left side Table of Contents menu displays incorrectly → http://www.ibmlink.ibm.com--document.layer/document.all dectection

Comment 3

17 years ago
I'll take this one since it's IBM
Assignee: bclary → mkaply
OS: OS/2 → All

Comment 4

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 5

17 years ago
Michael, we have at least one other IBM evang issue. can you take one too?
thanks, bc
Summary: http://www.ibmlink.ibm.com--document.layer/document.all dectection → ibm.com - document.layer/document.all dectection

Updated

16 years ago
Depends on: 114157

Updated

16 years ago
No longer depends on: 114157

Updated

16 years ago
Blocks: 114157

Updated

16 years ago
Priority: -- → P1

Updated

16 years ago
Whiteboard: [USERAGENT][PROPRIETARY-DOM]

Comment 6

16 years ago
contacted 12/8
Status: NEW → ASSIGNED
Target Milestone: --- → Jan
(Assignee)

Updated

16 years ago
Whiteboard: [USERAGENT][PROPRIETARY-DOM] → [USERAGENT][PROPRIETARY-DOM][aok]

Updated

16 years ago
Keywords: evang500
Whiteboard: [USERAGENT][PROPRIETARY-DOM][aok] → [USERAGENT][PROPRIETARY-DOM]

Comment 7

16 years ago
Mike, taking back. I would appreciate any contacts you have.
Assignee: mkaply → bclary
Status: ASSIGNED → NEW

Comment 8

15 years ago
Error: setting a property that has only a getter
Source File: http://www.ibmlink.ibm.com/GIF/ALET/PROF13.JS
Line: 51

Error: setting a property that has only a getter
Source File: http://www.ibmlink.ibm.com/usalets&parms=H_301-123
Line: 91

Error: document.layers has no properties
Source File: http://www.ibmlink.ibm.com/GIF/ALET/PROF13.JS
Line: 618

Updated

15 years ago
Depends on: 181339

Comment 9

15 years ago
tech evang june 2003 reorg
Assignee: bc → english-us
QA Contact: zach → english-us
Target Milestone: Jan → ---
(Assignee)

Comment 10

15 years ago
all ibm.com evang bugs over to me
Assignee: english-us → doronr

Comment 11

14 years ago
Closing:

"IBMLink Document Viewer
The requested document "/ilinet/data/usa/english/static/H_301-123" does not exist."

I assume by now any data inside that page is no longer relevant and has been
hopefully replaced with Mozilla-compatible pages. Please re-open a new bug if
this is not the case.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.