[Music] Artifacts below music scrubber

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Music
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: epang, Assigned: ivanovpavel)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: ux-tracking, visual design, visual-tracking, bokken)

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

5 years ago
Created attachment 8342424 [details]
music player.png

Hey Pavel,

The right side of the scrubber highlight is a bit cut off.  This wasn't occurring before, was it a regression from the fix we did for WVGA? Can you take a look?

Thanks!
Created attachment 8342553 [details] [review]
patch for Gaia/master

Hey Eric, 
there are some glitches because of odd sizes ... but I think that I fix it for now, can you check it ?
Attachment #8342553 - Flags: review?(epang)
(Reporter)

Comment 2

5 years ago
(In reply to Pavel Ivanov [:ivanovpavel] from comment #1)
> Created attachment 8342553 [details] [review]
> patch for Gaia/master
> 
> Hey Eric, 
> there are some glitches because of odd sizes ... but I think that I fix it
> for now, can you check it ?

glitches still seem to be happening, I'll attach a screen that i took from wvga.  You can see the right side of the srubber looks cut off.  The glitches seem to change when you move the slider around.
Flags: needinfo?(pivanov)
(Reporter)

Comment 3

5 years ago
Created attachment 8342876 [details]
music player.png

example image of the glitches in the wvga music player.  Can you take a look?  We need to land this by tomorrow.
this is because the odd sizes :( I think we don't have time to fix this because is deeper than just CSS
Flags: needinfo?(pivanov)
(Reporter)

Comment 5

5 years ago
(In reply to Pavel Ivanov [:ivanovpavel] from comment #4)
> this is because the odd sizes :( I think we don't have time to fix this
> because is deeper than just CSS

is there anything I can do about the odd sizes?  I can always try to update the designs to help. Let me know, thanks!
Flags: needinfo?(pivanov)
Can we try with something like 2.2 instead of 2.1 and 6.2 instead of 6.1?
Flags: needinfo?(pivanov)
(Reporter)

Comment 7

5 years ago
(In reply to Pavel Ivanov [:ivanovpavel] from comment #6)
> Can we try with something like 2.2 instead of 2.1 and 6.2 instead of 6.1?

sure,let's give it a try. thanks!
Flags: needinfo?(pivanov)
Hey Eric can you test the patch now ... I think that I found a way to hack it and I use 2.3rem and 6.1rem like in spec
Flags: needinfo?(pivanov)
(Reporter)

Updated

5 years ago
Flags: needinfo?(epang)
(Reporter)

Comment 9

5 years ago
Created attachment 8347321 [details]
Music Player.png

Hey Pavel, the scrubber looks good now! But not when you move it around lines appear, see the attached image.  Do you know what's happening here?  This only occurs in WVGA 1.5x.
Attachment #8342424 - Attachment is obsolete: true
Attachment #8342876 - Attachment is obsolete: true
Flags: needinfo?(epang) → needinfo?(pivanov)
huh ... no idea ... maybe we need to wait till we have devices to test
Flags: needinfo?(pivanov)
(Reporter)

Updated

5 years ago
Summary: [Music] Right edge of music scrubber highlight is cut off → [Music] Artifacts below music scrubber
(Reporter)

Updated

5 years ago
Blocks: 950756
No longer blocks: 925925
Whiteboard: ux-tracking, visual design, visual-tracking, jian → ux-tracking, visual design, visual-tracking, bokken
(Reporter)

Updated

5 years ago
Attachment #8342553 - Flags: review?(epang)
Hey Eric,
can you test the PR now ... I can't reproduce the problem on a peak (HD device) a have a chance to test it on it
Flags: needinfo?(epang)
(Reporter)

Comment 12

5 years ago
(In reply to Pavel Ivanov [:ivanovpavel] from comment #11)
> Hey Eric,
> can you test the PR now ... I can't reproduce the problem on a peak (HD
> device) a have a chance to test it on it

Hey Pavel, I just tested on the helix and I'm unable to reproduce the problem too.  Did you fix?
Flags: needinfo?(epang)
Comment on attachment 8342553 [details] [review]
patch for Gaia/master

Nope,

I think there is a platform fix for the graphics and that's why now looks fine :)
Attachment #8342553 - Attachment is obsolete: true
(Reporter)

Comment 14

5 years ago
(In reply to Pavel Ivanov [:ivanovpavel] from comment #13)
> Comment on attachment 8342553 [details] [review]
> patch for Gaia/master
> 
> Nope,
> 
> I think there is a platform fix for the graphics and that's why now looks
> fine :)

ok, we should land this :). Thanks!
Work fine now
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Blocks: 965885
Blocks: 965887
You need to log in before you can comment on or make changes to this bug.