Make window._content chromeonly

RESOLVED FIXED in mozilla29

Status

()

Core
DOM
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: bz, Assigned: bz)

Tracking

(Blocks: 2 bugs, {dev-doc-complete, site-compat})

unspecified
mozilla29
dev-doc-complete, site-compat
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa-])

Attachments

(2 attachments)

The web shouldn't use it because no one else supports it, it's been deprecated since 2001 (though without any console messages), and it's already not supported via Xrays, so extensions ought not to break.

Can we just kill it, pretty please?
> so extensions ought not to break.

Except I guess they could be getting _content on the chrome window.  :(  And in fact, that's exactly what they do; it's all over the addons mxr.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
Actually, I'm going to try to make this chromeonly.  Lack of xray support means I don't have to add it to xpidl at all, and I can hack webidl enough to allow this.
Blocks: 864845
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Summary: Can we nix window._content ? → Make window._content chromeonly
Created attachment 8342861 [details] [diff] [review]
part 1.  Allow installing chromeonly webidl quickstubs too.
Attachment #8342861 - Flags: review?(peterv)
Assignee: nobody → bzbarsky
Status: REOPENED → ASSIGNED
Created attachment 8342862 [details] [diff] [review]
part 2.  Make window._content chromeonly and define it in WebIDL.
Attachment #8342862 - Flags: review?(peterv)
Also, I'd be happy to add a warning in this getter if people prefer.  But addons use it a _lot_.
Attachment #8342861 - Flags: review?(peterv) → review+
Comment on attachment 8342862 [details] [diff] [review]
part 2.  Make window._content chromeonly and define it in WebIDL.

Review of attachment 8342862 [details] [diff] [review]:
-----------------------------------------------------------------

I'd really like to add the warning :-/.
Attachment #8342862 - Flags: review?(peterv) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/2154019a866e
https://hg.mozilla.org/integration/mozilla-inbound/rev/537ff932d5f1

I filed bug 948096 on adding a warning.
Flags: in-testsuite-
Target Milestone: --- → mozilla29
https://hg.mozilla.org/mozilla-central/rev/2154019a866e
https://hg.mozilla.org/mozilla-central/rev/537ff932d5f1
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
I guess this is technically site-compat.
Keywords: site-compat
Blocks: 916605

Updated

4 years ago
Keywords: dev-doc-needed
OS: Mac OS X → All
Hardware: x86 → All

Updated

4 years ago
Duplicate of this bug: 864845
https://developer.mozilla.org/en-US/docs/Web/API/Window
https://developer.mozilla.org/en-US/Firefox/Releases/29/Site_Compatibility
Keywords: dev-doc-needed → dev-doc-complete

Updated

4 years ago
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.