[xh, an] Add Xhosa and Aragonese locales to shipped-locales

RESOLVED FIXED in Firefox 27

Status

defect
RESOLVED FIXED
6 years ago
7 months ago

People

(Reporter: gueroJeff, Assigned: gueroJeff)

Tracking

27 Branch
mozilla29
Dependency tree / graph

Firefox Tracking Flags

(firefox27 verified, firefox28 verified, firefox29- affected)

Details

(Whiteboard: [merge-day])

Attachments

(1 attachment)

Both the Xhosa and Aragonese locales are ready to be added to shipped-locales for Aurora and Beta. The attached patch adds both locales for Aurora, but we'd like this to also be ported to Beta for the impending merge day please. As I do not have commit access, this patch will need to be commited for me please.
[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or IDL/UUID changes made by this patch:
Attachment #8343064 - Flags: review?(release-mgmt)
Attachment #8343064 - Flags: checkin?(l10n)
Attachment #8343064 - Flags: approval-mozilla-aurora?
OS: Mac OS X → All
Hardware: x86 → All
Attachment #8343064 - Flags: review?(stas)
Attachment #8343064 - Flags: review?(release-mgmt)
Attachment #8343064 - Flags: checkin?(l10n)
Attachment #8343064 - Flags: checkin?(akeybl)
Comment on attachment 8343064 [details] [diff] [review]
Adds xh and an to shipped-locales.

Review of attachment 8343064 [details] [diff] [review]:
-----------------------------------------------------------------

r=me, thanks.
Attachment #8343064 - Flags: review?(stas) → review+
Comment on attachment 8343064 [details] [diff] [review]
Adds xh and an to shipped-locales.

Alex landed this.
https://hg.mozilla.org/mozilla-central/rev/a79294ed7ebe
Attachment #8343064 - Flags: checkin?(akeybl) → checkin+
Assignee: nobody → jbeatty
Target Milestone: --- → Firefox 29
Comment on attachment 8343064 [details] [diff] [review]
Adds xh and an to shipped-locales.

post-landing a+ just for completeness
Attachment #8343064 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Mihaela, can you please verify these locales pass our test automation?
Flags: needinfo?(mihaela.velimiroviciu)
Keywords: verifyme
I ran the functional testruns on Firefox 27.0beta 2 and Firefox 28.0a2 for these locales and beta runs are green on both locales, while on Aurora there are some failures for the [an] locale on Mac OS X:
* Beta xh: all pass
* Beta an: all pass
* Aurora xh: all pass
* Aurora an:
** Mac 10.6.8 - 14 failures: http://mozmill-crowd.blargon7.com/#/functional/report/ca1869364f98dd0de71202e01ee04b25
** Mac 10.7.5 - 1 failure: http://mozmill-crowd.blargon7.com/#/functional/report/ca1869364f98dd0de71202e01ed4bfdb
** Mac 10.8.5 - 1 failure: http://mozmill-crowd.blargon7.com/#/functional/report/ca1869364f98dd0de71202e01ed4b1d1
** Mac 10.9 - 1 failure: http://mozmill-crowd.blargon7.com/#/functional/report/ca1869364f98dd0de71202e01ed4cc69
Flags: needinfo?(mihaela.velimiroviciu)
The aragonese failures seem to be mostly timeouts. Can we rerun those, or get a manual testrun to verify if there is an actual localization problem?
I ran the testruns locally on a Mac 10.6.8 machine and the failures were reproducible.
Interesting. Right now mozilla-aurora and mozilla-beta have the same changeset as default/tip, so I don't understand why one fails and the other doesn't.
I looked more into the tests and it seems that the additional 13 test failures on Mac 10.6 are due to the failure of /testPrivateBrowsing/testOpenClosePBKeyboardShortcut.js test. That test fails because CMD+SHIFT+P keyboard shortcut enters browser in fullscreen mode instead of opening a new private browsing window. I logged bug #951579 for that.
So, there is only one failure in the mozmill automation functional testrun for the an locale on Mac OS X.
This  failure is also reproducible on the Firefox 27 beta build, but it wads't caught by the automated tests because there are different tests run depending on the branch (default, aurora, beta, release, esr).
There are no failures in the add-ons, update and remote testruns for these 2 locales on the beta branch.
There are some failures in the localization testrun- see bug 952007, bug 952065, bug 952066 and bug 952067
I've also looked through mozmill-release and mozmill-daily for runs on these locales between 12/19 and today and found this:
mozmill-daily
* http://mozmill-daily.blargon7.com/#/l10n/reports?branch=All&platform=All&from=2013-12-19&to=2014-01-24 (all the fails are about access keys test1.js::testPrefWindowAccessKeys)
* functional tests were not run on these locales

mozmill-release
* There were no l10n tests results here and the functional tests were not run on these locales.
Still not seeing these in 29 latest, but we are shipping this for FF27 and the locales are listed in m-c's shipped-locales -- what's the issue here? Should we not be shipping this locale yet?
Flags: needinfo?(l10n)
Blocks: 959591
No longer blocks: 959591
(In reply to Lukas Blakk [:lsblakk] from comment #16)
> Still not seeing these in 29 latest, but we are shipping this for FF27 and
> the locales are listed in m-c's shipped-locales -- what's the issue here?
> Should we not be shipping this locale yet?

Nightly has a reduced list of locales, the list we're intending to ship is most complete on aurora, so 28 right now. Nightly is a subset of Aurora, and Beta is a subset of Aurora, and Release is a subset of Beta.

Whether a locale is on nightly or not is irrelevant to what happens down the line on the release train.
Flags: needinfo?(l10n)
Based on Comment 16 we will not be tracking
I think we can close this bug now...
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Component: Build Config → General
Product: Firefox → Firefox Build System
Target Milestone: Firefox 29 → mozilla29
You need to log in before you can comment on or make changes to this bug.