Closed Bug 946797 Opened 6 years ago Closed 6 years ago

Hang on Metro Firefox startup with remote debugging enabled (Error: inspectorActor already exists)

Categories

(Firefox for Metro Graveyard :: General, defect)

28 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 28

People

(Reporter: mbrubeck, Assigned: mbrubeck)

References

Details

(Keywords: regression)

Attachments

(1 file)

When "devtools.debugger.remote-enabled" is enabled in Metro Firefox, the Metro app hangs at the splash screen and this error appears in the debug console:

JavaScript error: resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/main.js, line 656: Error: inspectorActor already exists

This is because bug 912057 added a global inspectorActor and styleEditorActor in toolkit, while bug 934744 previously added them in Metro front-end code.
Attached patch patchSplinter Review
This patch just reverts part 1 of bug 934744 which is no longer needed (these are now registered in toolkit).
Attachment #8343172 - Flags: review?(ally)
Blocks: 946800
Comment on attachment 8343172 [details] [diff] [review]
patch

Passing review to jimm because of PTO.
Attachment #8343172 - Flags: review?(ally) → review?(jmathies)
Summary: Hang on Metro Firefox startup with remote debugging enabled → Hang on Metro Firefox startup with remote debugging enabled (Error: inspectorActor already exists)
Attachment #8343172 - Flags: review?(jmathies) → review+
https://hg.mozilla.org/mozilla-central/rev/bd5b4ba543ec
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
You need to log in before you can comment on or make changes to this bug.