Closed Bug 946802 Opened 6 years ago Closed 6 years ago

Update bing icon to new triangular icon

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 28
Tracking Status
firefox27 --- verified
firefox28 --- verified

People

(Reporter: Margaret, Assigned: Margaret)

References

Details

Attachments

(1 file)

This is a follow-up to bug 903084 comment 24.

From IRC:
[05 09:54:48] <kar> margaret - my preference is that we go with their latest branding. I think it's been delayed on desktop and if we can get it into mobile, all the better. It won't be an enormous deal if we cn't (and it goes to the next release), but I'd like a case made to see if we can get it in in time.

I can write a patch to do this for en-US.

My one concern is that the icon included in bug 903084 is 70x70, but we usually include 32x32 icons.
Nothing really to do on l10n side: all locales using Bing rely on the en-US version, so as soon as you update mobile and browser (standard and metro) we're good.

Wondering where the idea of having a 70px icon came from...
Attached patch patchSplinter Review
This patch updates the bing icon to use the 70x70 yellow "b" on grey background icon from bug 903084.
Attachment #8343221 - Flags: review?(mark.finkle)
Attachment #8343221 - Flags: review?(mark.finkle) → review+
Comment on attachment 8343221 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bing updated its branding
User impact if declined: we show an older (and smaller) Bing icon
Testing completed (on m-c, etc.): just landed on fx-team
Risk to taking this patch (and alternatives if risky): low-risk icon change (although we should make sure nothing weird happens because this is a 70x70 icon)
String or IDL/UUID changes made by this patch: none

I wonder if we should also try to jam this into beta before release. My instinct tells me it's too late for that, but 26 will be the first time we ship Bing (and customizable search engines), so it could be nice to have the updated branding.
Attachment #8343221 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/1810169dc57f
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
Comment on attachment 8343221 [details] [diff] [review]
patch

The ship for beta(Firefox 26) has sailed :( approving for aurora though.
Attachment #8343221 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
Verified fixed on:
Build: Firefox for Android 27 Beta 1 (2013-12-11)
Device: Samsung Galaxy Nexus
OS: Android 4.2.1
Depends on: 950719
You need to log in before you can comment on or make changes to this bug.