Moving a child element outside of a parent element while moving the parent element, both using transform: translate(), will cause the child element to disappear

VERIFIED FIXED in mozilla29

Status

()

Core
Layout: View Rendering
P3
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Patrik Elfström, Assigned: roc)

Tracking

({dev-doc-needed, regression, site-compat})

25 Branch
mozilla29
dev-doc-needed, regression, site-compat
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131112160018

Steps to reproduce:

Moving a child element for example -10px using transform: translate() and at the same time moving the parent element 10px also using transform: translate().

Here is an example: http://jsbin.com/IsIVoyox/1/edit
(hover the red elements)

Bug appears in Firefox 25.0.1 and Firefox 28.0a1.
Works as it should in Chrome, Safari and Internet Explorer 10.



Actual results:

When the child element goes outside of the parent element it will disappear.
This however does seem to depend on the size of the child element and the distance it's moved.


Expected results:

The child element should still be visible when outside the parent element.
(Reporter)

Updated

4 years ago
Confirmed on Mac too.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(tnikkel)
OS: Windows 7 → All
Hardware: x86_64 → All
Works fine with 2013-02-01 nightly. So I think the next step is to get a regression range here.
Flags: needinfo?(tnikkel)
Keywords: regressionwindow-wanted
(Reporter)

Comment 3

4 years ago
Works in Firefox 21.0b7 but not in 22.0
Tested on win7
Great. If we could get that bisected down to a single day of changesets that would be amazing. mozregression can help do it quicker, instructions here http://mozilla.github.io/mozregression/
(Reporter)

Comment 5

4 years ago
Last good revision: eccf45749400 (2013-03-11)
First bad revision: 7433bc4545c9 (2013-03-12)
Thank you!

That gives these changesets
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=eccf45749400&tochange=7433bc4545c9
Keywords: regressionwindow-wanted → regression
Hmm, the only changeset in there that looks like it could have affected this is

http://hg.mozilla.org/mozilla-central/rev/9a9689e414e4

form bug 849263.
Flags: needinfo?(dbaron)
...which was making a previous change that Matt made actually do what it was supposed to do.
Flags: needinfo?(dbaron) → needinfo?(matt.woodrow)
(Though I'm actually a bit skeptical of that being the cause, since it really should have changed perf rather than behavior.)
There were actually two regression ranges, afaict.

First one is indeed http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=eccf45749400&tochange=7433bc4545c9 where the behavior changed to the the blue square disappearing while the red one is moving but reappearing once the red one stops.

Second one, to the current behavior: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=97cfc16ba5dc&tochange=c232bec6974d
Local bisect says that either bug 849263 or the landing/backout of bug 804944 that happened at the same time triggered the first regression.  My money is on the former.
Blocks: 849263

Updated

4 years ago
Priority: -- → P3
Fixed by bug 944291.
Depends on: 944291
Flags: needinfo?(matt.woodrow)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Assignee: nobody → roc
Target Milestone: --- → mozilla29
Verified as fixed on latest Aurora 28.0a2 as well using Ubuntu 12.04 x32 and Windown 8.1 x32
Status: RESOLVED → VERIFIED

Updated

4 years ago
Keywords: dev-doc-needed, site-compat
You need to log in before you can comment on or make changes to this bug.