Closed Bug 947146 Opened 6 years ago Closed 6 years ago

Taps send a mouse move at the last position of the mouse

Categories

(Firefox for Metro Graveyard :: Input, defect, P2)

x86_64
Windows 8.1
defect

Tracking

(firefox28 verified, firefox29 verified)

RESOLVED FIXED
Firefox 28
Tracking Status
firefox28 --- verified
firefox29 --- verified

People

(Reporter: jimm, Assigned: jimm)

References

Details

(Whiteboard: [beta28] p=2)

Attachments

(1 file)

str:

1) surf to techmeme.com, which has "hot areas" around each article snippet
2) bring up the nav bar edit
3) tap in the navbbar edit to invoke selection

result: you'll notice the underlying content react to the taps
str:

1) surf to techmeme.com, which has "hot areas" around each article link
2) move the mouse over one of the highlight areas
3) tap on content to remove the mouse cursor / highlight
2) bring up the nav bar edit
3) tap in the navbbar edit
Summary: Nav bar clicks bleed through to content → Taps send a mouse move at the last position of the mouse
Whiteboard: [triage] → [beta28]
Whiteboard: [beta28] → [beta28] p=0
Assignee: nobody → jmathies
Whiteboard: [beta28] p=0 → [beta28] p=2
Blocks: metrov1it21
No longer blocks: metrov1backlog
Status: NEW → ASSIGNED
Priority: -- → P2
QA Contact: jbecerra
Blocks: 937229
Depends on: 941774
No longer blocks: 937229
Duplicate of this bug: 937229
Comment on attachment 8345493 [details] [diff] [review]
fix plus tests v.1

Fixing this for good and adding some tests. (Note the tests rely on native events from bug 941774.)
Attachment #8345493 - Flags: review?(mbrubeck)
Attachment #8345493 - Flags: review?(mbrubeck) → review+
https://hg.mozilla.org/mozilla-central/rev/828bbb5114bb
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Comment on attachment 8345493 [details] [diff] [review]
fix plus tests v.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): This bug.
User impact if declined: Wonky working menu highlight color.
Testing completed (on m-c, etc.): Yes.
Risk to taking this patch (and alternatives if risky): Very low.
String or IDL/UUID changes made by this patch: None.
Attachment #8345493 - Flags: approval-mozilla-aurora?
Attachment #8345493 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Target Milestone: Firefox 29 → Firefox 28
Went through the following issue for iteration #21 without any problems. Used the following builds:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-01-14-00-40-02-mozilla-aurora/
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-01-14-03-02-36-mozilla-central/

Before testing to see if the issue has been fixed, reproduced the problem following comment #0 & comment #1 using the following build:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-12-14-03-02-04-mozilla-central/

- Went through the original test cases from both comment #0 and comment #1 without any issues
- Ensured that sliding the Navigation App Bar from the Top/Bottom didn't invoke a mouse move (didn't re-highlight the link)
- Ensured that taping the URL under the Navigation App Bar didn't invoke a mouse move (didn't re-highlight the link)
- Ensured that sliding in the Windows Charm didn't invoke a mouse move (didn't re-highlight the link)
- Swiped in the Desktop environment from the left and then re-swiped Firefox Metro into view and ensured that sliding the Navigation App Bar didn't invoke a mouse move
- Ensured that going back to the website after creating a new tab using both methods (overlay/under Tab Navigation) didn't invoke a mouse move when sliding in the Navigation App Bar
- Went through all of the above test cases using several different links from the website provided in both comment #0 and comment #1
- Went through all of the above test cases using filled view (variations of widths)
You need to log in before you can comment on or make changes to this bug.