Closed Bug 947167 Opened 6 years ago Closed 5 years ago

Intermittent dom/downloads/tests/test_downloads_pause_resume.html | Test timed out.

Categories

(Core :: DOM: Core & HTML, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla39
Tracking Status
firefox37 --- wontfix
firefox38 --- fixed
firefox39 --- fixed
firefox-esr31 --- unaffected
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: cbook, Assigned: asuth)

References

()

Details

(Keywords: intermittent-failure, Whiteboard: [systemsfe][p=5])

Attachments

(1 file)

b2g_emulator_vm fx-team opt test mochitest-3 on 2013-12-05 16:20:00 PST for push 2831368a5e05

slave: tst-linux64-ec2-042

https://tbpl.mozilla.org/php/getParsedLog.php?id=31531398&tree=Fx-Team

43820 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/downloads/tests/test_downloads_pause_resume.html | Test timed out.
I'll try to take a look, but Paolo or Fabrice are probably more able to diagnose this one than myself.

Have you seen any of these prior to today? If not I think there's a good chance of trying to pinpoint an offending cset
Flags: needinfo?(paolo.mozmail)
It's possible it started a day or so ago and was starred a generic B2G failure, but it is definitely a recent regression.
This test is for an API that has landed recently to support B2G. There might be a race condition in the test due to the asynchronous nature of the underlying Toolkit Downloads API.

The patch in bug 941317 makes the failure deterministic, thus I think that applying the patch locally would make fixing this intermittent failure easier.
Blocks: 938023
Depends on: 941317
Flags: needinfo?(paolo.mozmail) → needinfo?(aus)
Great, I'll grab the patch from 941317 and fix the tests locally. Patch will be attached to this bug.
Assignee: nobody → aus
Flags: needinfo?(aus)
Flags: needinfo?(felipc)
Whiteboard: [systemsfe][p=5]
I think the patch in bug 957592 will solve this problem.
Status: NEW → ASSIGNED
Depends on: 957592
No longer depends on: 941317
Target Milestone: --- → B2G C4 (2jan on)
Depends on: 941317
I'm going to wait one day now that bug 957592 to see if this is truly resolved. My gut feeling is telling me yes, though. :)
Sadly the patch needed to get backed out. However, while it was on the tree, the intermittent failures ceased. It's looking good. I'm hoping that it will be re-landing (with fixes) today.
Summary: Intermittent TEST-UNEXPECTED-FAIL | /tests/dom/downloads/tests/test_downloads_pause_resume.html | Test timed out. → Intermittent dom/downloads/tests/test_downloads_pause_resume.html | Test timed out.
The failures that are now being logged against this bug are no longer related to the code the test is exercising or the test code itself. I'm not sure what the protocol is in this scenario. Do I leave this open anyway even though the real failure was fixed?
(In reply to Ghislain Aus Lacroix [:aus] from comment #136)
> The failures that are now being logged against this bug are no longer
> related to the code the test is exercising or the test code itself. I'm not
> sure what the protocol is in this scenario. Do I leave this open anyway even
> though the real failure was fixed?

Well, it still times out as frequently or more frequently than it did before, so I guess if you're done, we're done and we'll just disable the test.
Test skipped on B2G.
https://hg.mozilla.org/integration/fx-team/rev/1121a0d3af2e
Component: Download Manager → DOM
Product: Toolkit → Core
Whiteboard: [systemsfe][p=5] → [systemsfe][p=5][test disabled on B2G][leave open]
Target Milestone: B2G C4 (2jan on) → ---
Depends on: 979446
Going to try and re-enable these, stay tuned for progress updates.
Target Milestone: --- → 2.1 S5 (26sep)
Target Milestone: 2.1 S5 (26sep) → ---
I believe I've corrected the intermittent failures in this test with https://hg.mozilla.org/mozilla-central/rev/4d0ef24554ca from https://bugzilla.mozilla.org/show_bug.cgi?id=825318#c116

Resolving WFM.  Please reopen or refile if this comes back.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
(In reply to Andrew Sutherland [:asuth] from comment #248)
> Resolving WFM.  Please reopen or refile if this comes back.

(In reply to TBPL Robot from comment #249)

:)
Status: RESOLVED → REOPENED
Flags: needinfo?(bugmail)
Resolution: WORKSFORME → ---
The log included some suspicious spam in it, but based on the log and the test, I think the problem is that the serve_file.sjs is serving the file too quickly for the slow emulator and the logic that triggers the pause just ended up seeing the file fully downloaded.  I've adjusted the serve_file.sjs argument so it takes 100 seconds to complete instead of 10 seconds and so that we generate info on all the notifications we get, so in the inconceivable situation I am wrong we know when the glitch in the matrix happened.  I'll do some retriggers on the try and then ask for review assuminig the burnination hasn't increased.
(The chatty robot's new log also agrees with/matches the old log.)
This seems to be permafailing on b2g37.
Here's the patch I used to get 11 clean runs of this mochitest 7 job on mozilla-central at https://treeherder.mozilla.org/#/jobs?repo=try&revision=e16c9bfa1ffc.

I've also gotten 5 clean runs (with 3 more pending) against b2g37 on the https://treeherder.mozilla.org/#/jobs?repo=try&revision=30dfacae0626 try run.
Assignee: aus → bugmail
Status: REOPENED → ASSIGNED
Flags: needinfo?(bugmail)
Attachment #8576921 - Flags: review?(aus)
Comment on attachment 8576921 [details] [diff] [review]
bug9471670-fix-pause-resume-timeout-v1.diff

Review of attachment 8576921 [details] [diff] [review]:
-----------------------------------------------------------------

Oh geez, I see. It was downloading too fast. Looks good to me.
Attachment #8576921 - Flags: review?(aus) → review+
https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/94f65ecbcd1d
Status: ASSIGNED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Whiteboard: [systemsfe][p=5][test disabled on B2G][leave open] → [systemsfe][p=5]
Target Milestone: --- → mozilla39
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.