Last tab's border in the toolbox tabstrip is much brighter than the rest

RESOLVED FIXED in Firefox 28

Status

defect
RESOLVED FIXED
6 years ago
Last year

People

(Reporter: vporof, Assigned: bgrins)

Tracking

(Blocks 1 bug)

unspecified
Firefox 28
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first verify])

Attachments

(3 attachments, 1 obsolete attachment)

See screenshot. Happens after bug 941579, at least on OS X.
Blocks: 941579
Posted patch lasttabborder.patch (obsolete) — Splinter Review
Uses consistent border color for last tab
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Comment on attachment 8344338 [details] [diff] [review]
lasttabborder.patch

Review of attachment 8344338 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/themes/shared/devtools/toolbars.inc.css
@@ +496,5 @@
>    border-left-width: 0;
>  }
>  
>  .devtools-tab:last-child {
> +  border-right: 1px solid #42484f;

Need to use -moz-border-end and -moz-border-start here and throughout the file for proper localization.
Attachment #8344338 - Flags: review?(vporof) → review-
Here's how it looks like on RTL.
Same comment in bug 947709 applies here as well: https://bugzilla.mozilla.org/show_bug.cgi?id=947709#c2

Let's fix localization for the remaining CSS in a different patch, but at least let's use the proper rules in this bug.

https://wiki.mozilla.org/DevTools/CSSTips
(In reply to Victor Porof [:vp] from comment #4)
> Same comment in bug 947709 applies here as well:
> https://bugzilla.mozilla.org/show_bug.cgi?id=947709#c2
> 
> Let's fix localization for the remaining CSS in a different patch, but at
> least let's use the proper rules in this bug.
> 
> https://wiki.mozilla.org/DevTools/CSSTips

Got it, thanks for the info.  I'm going to upload a patch here that also fixes Bug 947709 since they have become related to each other.
This adds rtl support to the tab bar.  It also fixes:

* Brighter border on last tab
* Jiggle on last tab (Bug 947709)
* Opacity on the image when tab is selected isn't 1 (you can see this by selecting a tab then hovering over it - the opacity shouldn't change in this case).
Attachment #8344338 - Attachment is obsolete: true
Attachment #8344344 - Flags: review?(vporof)
Comment on attachment 8344344 [details] [diff] [review]
tabbar-rtl.patch

Review of attachment 8344344 [details] [diff] [review]:
-----------------------------------------------------------------

Bokay! Thank you :)

I guess we can dupe the other bugs to this one now.
Attachment #8344344 - Flags: review?(vporof) → review+
Duplicate of this bug: 947709
https://hg.mozilla.org/mozilla-central/rev/550462c1dae0
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 28
Whiteboard: [good first verify]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.