Closed Bug 947895 Opened 6 years ago Closed 6 years ago

[e10s] context-menu->"open in new tab" broken (TypeError: this.browser.docShell is null nsContextMenu.js:850)

Categories

(Firefox :: General, defect)

28 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30

People

(Reporter: shawnlandden, Assigned: evilpie)

References

(Blocks 1 open bug)

Details

(Whiteboard: [bugday-20131209][e10s])

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20131208030204

Steps to reproduce:

riht click "open in new tab"


Actual results:

nothing


Expected results:

tab opened

----
note: middle-click to open new tab works
Blocks: e10s
Confirmed with
2013-12-08-03-02-04-mozilla-central-firefox-28.0a1.en-US.linux-x86_64
2013-12-09-05-34-02-mozilla-central-firefox-28.0a1.en-US.linux-x86_64

This appears in the Browser Console:
TypeError: this.browser.docShell is null nsContextMenu.js:850
Status: UNCONFIRMED → NEW
Component: Untriaged → IPC
Ever confirmed: true
Product: Firefox → Core
Summary: context-menu->"open in new tab" broken with browser.tabs.remote → context-menu->"open in new tab" broken with browser.tabs.remote (TypeError: this.browser.docShell is null nsContextMenu.js:850)
Whiteboard: [bugday-20131209]
Component: IPC → General
Product: Core → Firefox
Whiteboard: [bugday-20131209] → [bugday-20131209][e10s]
Could be a duplicate of bug 946503 (filed as specific to a site).
I see this with OS X, too.
Blocks: fxe10s
No longer blocks: e10s
OS: Linux → All
Hardware: x86_64 → All
Summary: context-menu->"open in new tab" broken with browser.tabs.remote (TypeError: this.browser.docShell is null nsContextMenu.js:850) → [e10s] context-menu->"open in new tab" broken (TypeError: this.browser.docShell is null nsContextMenu.js:850)
Duplicate of this bug: 946503
Attached patch context-menuSplinter Review
This was caused by bug 906190. We probably need to mixedContentChannel to the browser element.
Assignee: nobody → evilpies
Status: NEW → ASSIGNED
Attachment #8376710 - Flags: review?(gavin.sharp)
Attachment #8376710 - Flags: review?(gavin.sharp) → review?(felipc)
Comment on attachment 8376710 [details] [diff] [review]
context-menu

Do we have a generic "make context menu work in e10s" bug that we could mention this in?

Otherwise we should get a bug on file to make this work with e10s.
Attachment #8376710 - Flags: review?(felipc) → review+
(i.e. please file that "add mixedContentChannel to <browser>" bug)
https://hg.mozilla.org/mozilla-central/rev/a712e7b9892d
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.