Closed Bug 948014 Opened 7 years ago Closed 7 years ago

Unit tests won't run under B2G Desktop

Categories

(Firefox OS Graveyard :: Gaia::TestAgent, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 929172

People

(Reporter: benfrancis, Assigned: julienw)

References

Details

STR:
* Download a nightly build of B2G Desktop from http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-central/
* Follow the instructions on the Gaia README to run unit tests https://github.com/mozilla-b2g/gaia/blob/master/README.md

Expected:
Unit tests run

Actual:
Says "Running all tests" and then there's no further output.

Tested on 32 and 64bit Linux builds.
Flags: needinfo?(jlal)
This is probably the same problem as bug 929172.
Actually, if the tests aren't running at all then your profile is probably not built right.  Make sure you use this:

  DESKTOP=0 DEBUG=1 NOFTU=1 make

See if that helps.  If it starts running tests, however, I would not be surprised if you hit bug 929172.
I confirm this is not working for me either... I don't see a CSP error though not sure what the root cause is yet.
Flags: needinfo?(jlal)
(In reply to Ben Kelly [:bkelly] from comment #2)
> Actually, if the tests aren't running at all then your profile is probably
> not built right.  Make sure you use this:
> 
>   DESKTOP=0 DEBUG=1 NOFTU=1 make

Unfortunately if I set DESKTOP=0 there's a problem with touch events and I can't unlock the lock screen. If I disable the lockscreen I can't launch apps. If I try to search for the app to open it a different way I get a dialog I can't close (probaably the keyboard first time use dialog).
Blocks: 946778
Bug 943460 fixed an issue with CSP in iframes, I wonder if this could be related here.
Julien, any idea what can move this forward? It's an important developer hygiene piece that we shouldn't leave broken.
Flags: needinfo?(felash)
I admit I never run unit tests in B2G Desktop, but this week is my test-agent week so I can give it a try ;)

The first thing that comes to my mind is to do a bisection ;)

So the really first step is to find one build where that works as expected. Ben, do you know a build where this worked?
Flags: needinfo?(felash) → needinfo?(bkelly)
(In reply to Julien Wajsberg [:julienw] from comment #7)
> So the really first step is to find one build where that works as expected.
> Ben, do you know a build where this worked?

Last I knew they were working was prior to this commit:

  https://hg.mozilla.org/mozilla-central/rev/ac2eb4f684ad

You could start there.  Note, however, it sounds like I was running into a different problem than Ben was.  I think there are multiple issues going on.  So there is probably bustage later than that.
Flags: needinfo?(bkelly)
Assignee: nobody → felash
I could make them run while working on bug 929172 so I'm duping.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 929172
You need to log in before you can comment on or make changes to this bug.