Closed Bug 948305 Opened 6 years ago Closed 5 years ago

[User Story] Rocketbar: URL Bookmark Search

Categories

(Firefox OS Graveyard :: Gaia::Search, defect)

x86
macOS
defect
Not set

Tracking

(feature-b2g:2.1, b2g-v2.0 wontfix, b2g-v2.1 affected)

RESOLVED FIXED
2.1 S1 (1aug)
feature-b2g 2.1
Tracking Status
b2g-v2.0 --- wontfix
b2g-v2.1 --- affected

People

(Reporter: pdol, Assigned: daleharvey)

References

Details

(Whiteboard: [ucid:System87, 1.4:P2][systemsfe][tako])

User Story:
As a user, I want Rocketbar to search and display results based on partial URLs or webpage titles that I enter for websites that I have bookmarked to make it much quicker to browse to my favorite sites.

Acceptance Criteria:
1. I can enter a partial string and relevant results from my bookmarks are displayed as is currently done in the Browser..
2. Selecting one of the bookmarks results loads that page.

Assumptions: 
1. UX spec to specify number of entries. 
2. Frecency algorithm is the same that is currently used in the Browser Awesome Bar. 
3. String matching with bookmarked web pages is the same as in Browser Awesome Bar.
(In reply to Peter Dolanjski [:pdol] from comment #0)
> User Story:
> As a user, I want Rocketbar to search and display results based on partial
> URLs or webpage titles that I enter for websites that I have bookmarked to
> make it much quicker to browse to my favorite sites.

This is actually the same as history search. Both bookmarks and history are 'places'. It's places that are searched. Whether or not a place is bookmarked may effect its frecency weighting though.

> Assumptions: 
> 2. Frecency algorithm is the same that is currently used in the Browser
> Awesome Bar. 

We might want to improve on that. The "frecency" in the current browser app is actually just frequency.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 948303
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Component: Gaia::System → Gaia::Search
Flags: in-moztrap?(jsmith)
No longer blocks: 1.4-systems-fe
Flags: in-moztrap?(jsmith)
Francis, should we kill this requirements based on your desire to just use autocomplete?
Flags: needinfo?(fdjabri)
At this point this close to merge, I think it would be best to backlog this to the next release?
Assignee: nobody → dale
feature-b2g: --- → 2.1
Whiteboard: [ucid:System87, 1.4:P2, ft:systems-fe] → [ucid:System87, 1.4:P2][systemsfe][tako]
Target Milestone: --- → 2.1 S1 (1aug)
This is implemented to spec in https://bugzilla.mozilla.org/show_bug.cgi?id=1042116
Status: REOPENED → RESOLVED
Closed: 6 years ago5 years ago
Flags: needinfo?(fdjabri)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.