Closed Bug 948349 Opened 8 years ago Closed 7 years ago

Convert System to new Notification API

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1095109

People

(Reporter: gerard-majax, Assigned: gerard-majax)

References

Details

(Whiteboard: [systemsfe])

apps/system/js/battery_manager.js:
  - sending notification of power saving mode
  
apps/system/js/bluetooth_transfer.js:
  - sending notification of bluetooth transfers
    - started
    - confirmation
    - sent finished successfully
    - receive finished successfully
    - sent finished with error
    - receive finished with error
    - multiple transfers report
  
apps/system/js/icc_worker.js:
  - sending notification from STK CMD_SET_UP_IDLE_MODE_TEXT
There is also a direct use in: apps/system/js/screenshot.js which should be quite easy to convert, it's just for notifying of screenshots.
(In reply to Alexandre LISSY :gerard-majax from comment #1)
> There is also a direct use in: apps/system/js/screenshot.js which should be
> quite easy to convert, it's just for notifying of screenshots.

So it seems someone already fixed this ...
(In reply to Alexandre LISSY :gerard-majax from comment #0)
> apps/system/js/icc_worker.js:
>   - sending notification from STK CMD_SET_UP_IDLE_MODE_TEXT

This one also seems to have been fixed.
(In reply to Alexandre LISSY :gerard-majax from comment #2)
> (In reply to Alexandre LISSY :gerard-majax from comment #1)
> > There is also a direct use in: apps/system/js/screenshot.js which should be
> > quite easy to convert, it's just for notifying of screenshots.
> 
> So it seems someone already fixed this ...

Looks like it was done in bug 971546.
Depends on: 971546
(In reply to Alexandre LISSY :gerard-majax from comment #3)
> (In reply to Alexandre LISSY :gerard-majax from comment #0)
> > apps/system/js/icc_worker.js:
> >   - sending notification from STK CMD_SET_UP_IDLE_MODE_TEXT
> 
> This one also seems to have been fixed.

Fixed by bug 873397.
Depends on: 873397
Depends on: 1025628
Depends on: 1025629
Whiteboard: [systemsfe]
Depends on: 1030063
Hey guys, 

:gerard-majax made me aware that this bug exists. We found a need for a Notification wrapper for L10n purposes and we want to reuse NotificationHelper. See bug 1095109. Because it also moves NotificationHelper to use W3C Notification API, I'm marking this bug as a dupe of that one.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1095109
You need to log in before you can comment on or make changes to this bug.