[meta] Spikes in power usage during idle

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: rvitillo, Unassigned)

Tracking

(Depends on 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

This bug tracks the work related to the energy drain of Firefox when idle.
Assignee: nobody → rvitillo
The energy drain of FF 25.0.1 during idle on Windows, Linux and OSX are very similar in my tests:
- the donate gif in about:home is draining up to 33% more energy wrt. the idle machine
- without the donate gif FF does not seem to drain any additional energy
Depends on: 477850, 892023
Depends on: 951671
Depends on: 951713
No longer depends on: 892023
Duplicate of this bug: 892023
Even though Intel Power Gadget doesn't seem to show any statistically significant drain during idle on my machine, there are some wakeups triggered due to mainly:

- bug 951713
- bug 951671
- Watchdog
- nsIdleService
- gfxFontCache::WordCacheExpirationTimerCallback (disabled in release)

were the last three are required but have a low frequency. I suspect that the power drain is difficult to spot when profiling "short" intervals (1-10min) whereas the effect could be visible over much longer intervals.
Correction: the wakeups triggered during idle by gfxFontCache and Watchdog could be avoided.
No longer depends on: 477850
Depends on: 958552
The wakeups triggered by Watchdog are caused by Bug 958552.
Depends on: 958566
Depends on: 850709
Depends on: 965348
Assignee: rvitillo → nobody
This meta-bug now has only one blocker, and it hasn't seen any significant activity since early 2014. I think it's served its purpose and can be closed.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.