Closed Bug 948824 Opened 8 years ago Closed 8 years ago

[CostControl] [DSDS] Remove IccHelper

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed)

RESOLVED FIXED
1.3 C2/1.4 S2(17jan)
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed

People

(Reporter: mai, Assigned: mai)

References

Details

Attachments

(1 file)

To have dual sim support we have to remove IccHelper from CostControl.
Blocks: 945325
Target Milestone: --- → 1.3 C1/1.4 S1(20dec)
Attached file proposal patch v1
Could you give me your feedback about the proposal?

Regards
Attachment #8345969 - Flags: feedback?(salva)
Comment on attachment 8345969 [details]
proposal patch v1

Ok, it is going well but please take into account the comments on GitHub and my telephonic feedback before asking for review. The main point of improvements are:

- Not address other bugs such as Airplane Mode. If you consider they are bugs, check if they are reproducing on master and open specific bugs for them. Note some can be not bugs but not considered situations.

- Focus on removing IccHelper, we can avoid code duplication if we load once and only once the ICC info for the proper SIM (updating when DSDS configuration change) and keeping that object as the replacement of IccHelper.
Attachment #8345969 - Flags: feedback?(salva) → feedback+
Comment on attachment 8345969 [details]
proposal patch v1

Please, could you review the code?
Regards
Attachment #8345969 - Flags: review?(salva)
Comment on attachment 8345969 [details]
proposal patch v1

Good work but review my comments on GtitHub. Once addressed, ask for the review one more time. 

Thank you!
Attachment #8345969 - Flags: review?(salva)
Comment on attachment 8345969 [details]
proposal patch v1

Please, could you review the patch?
Attachment #8345969 - Flags: review?(salva)
Target Milestone: 1.3 C1/1.4 S1(20dec) → 1.3 C2/1.4 S2(17jan)
Comment on attachment 8345969 [details]
proposal patch v1

Please, before merging, re-launch Travis and wait for green. Ping me if problems.

Thank you :mai, happy new year and welcome back to work! ,)
Attachment #8345969 - Flags: review?(salva) → review+
Master: 33e4a0f4e242b54c91eb8a1f5f91efada5252565
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
We have checked for landing bug 963682 which is 1.3+ we will need this as well.
blocking-b2g: --- → 1.3?
Blocks a blocker.
blocking-b2g: 1.3? → 1.3+
Hi John,

Could you please help us with the uplift of this patch to v1.3 branch?. Many thanks!!
Flags: needinfo?(jhford)
Uplifted to v1.3 with 190b3e90ec8b93bd44155bd7dbac29143d902f58.
Flags: needinfo?(jhford)
Duplicate of this bug: 964502
No longer blocks: 964502
Depends on: 965792
You need to log in before you can comment on or make changes to this bug.