[DSDS] SIM1 data call does not disconnected after switch data call to SIM2

VERIFIED WORKSFORME

Status

Firefox OS
Gaia::Settings
VERIFIED WORKSFORME
5 years ago
4 years ago

People

(Reporter: edchen, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:1.3+)

Details

(Whiteboard: dsdsrun1.3-1, [FT:RIL])

(Reporter)

Description

5 years ago
[Testing information]
Gaia      cbd29217ea37209449774b0c31cbfbdd2da6ee68
Gecko     0711d9529ced971c85244c4be3504d01edf5161d
BuildID   20131211154453
Version   28.0a2
ro.build.version.incremental=13

[Steps to Reproduce]
1. Go to Settings > SIM manager or open it from utility tray.
2. SIM manager can be opened.
3. Set one of the SIM cards as primary outgoing data.
4. Enable SIM 1 data call in its Cellular & Data setting.
5. Go to SIM manager again.
6. Set another SIM cards as primary outgoing data, the data connection does not switch this SIM card. 

[Actual Result]
Data connection cannot switch between SIM1 and SIM2.

[Expected Result]
Date connection has to switch between SIM1 and SIM2.
(In reply to Edward Chen[:Edward] from comment #0)
> [Testing information]
> Gaia      cbd29217ea37209449774b0c31cbfbdd2da6ee68
> Gecko     0711d9529ced971c85244c4be3504d01edf5161d
> BuildID   20131211154453
> Version   28.0a2
> ro.build.version.incremental=13
> 
> [Steps to Reproduce]
> 1. Go to Settings > SIM manager or open it from utility tray.
> 2. SIM manager can be opened.
> 3. Set one of the SIM cards as primary outgoing data.
> 4. Enable SIM 1 data call in its Cellular & Data setting.
> 5. Go to SIM manager again.
> 6. Set another SIM cards as primary outgoing data, the data connection does
> not switch this SIM card. 
> 

Could you elaborate on 'data connection does not switch this sim card?' Does that mean the data connection on the 2nd sim card isn't successfully established? If yes, then I think this is because the test gaia commit doesn't include bug 933203. And without bug 933203, the data connection is unable to set up with the 2nd sim. 


> [Actual Result]
> Data connection cannot switch between SIM1 and SIM2.
> 
> [Expected Result]
> Date connection has to switch between SIM1 and SIM2.
I believe this bug (or a feature?!) depends on (at least) Bug 943191 and bug 933203. It's not completely done yet. We should come back when the blockers are done. I set the dependency for tracking them easily.
Depends on: 943191, 933203
(Reporter)

Comment 3

5 years ago
HI Hsin-Yi,

Your comment is right, the mainly issue is data call cannot switch when I wanna switch data call to SIM2.

Thanks,
Edward
Summary: [DSDS] Data connection cannot switch between SIM1 and SIM2. → [DSDS] SIM1 data call does not disconnected after switch data call to SIM2

Updated

5 years ago
blocking-b2g: --- → 1.3?

Comment 4

5 years ago
Hi Joe,

Could you help to triage this DSDS bug? Thanks!
Flags: needinfo?(jcheng)
definitely a blocker if data connection cannot switch between 2 SIMs
1.3+
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(jcheng)
As the blockers of this issue are fixed, I am wondering should this bug is fixed as well. qawanted for asking for QA's verifying. Thanks!
Keywords: qawanted
(In reply to Hsin-Yi Tsai  [:hsinyi] from comment #6)
> As the blockers of this issue are fixed, I am wondering should this bug is
> fixed as well. qawanted for asking for QA's verifying. Thanks!

Sorry we need one more bug fixed before coming back to verify this issue again. Clearing qawanted for now.
Keywords: qawanted

Updated

5 years ago
Depends on: 952887

Comment 8

4 years ago
(In reply to Hsin-Yi Tsai  [:hsinyi] from comment #7)
> (In reply to Hsin-Yi Tsai  [:hsinyi] from comment #6)
> > As the blockers of this issue are fixed, I am wondering should this bug is
> > fixed as well. qawanted for asking for QA's verifying. Thanks!
> 
> Sorry we need one more bug fixed before coming back to verify this issue
> again. Clearing qawanted for now.

Set qawanted since the dependent bug is fixed.
Keywords: qawanted

Comment 9

4 years ago
Adding QARegressExclude tag as QAnalysts do not have a duo SIM device sadly. Leaving qawanted for another QA group to pick up.
Whiteboard: dsdsrun1.3-1 → dsdsrun1.3-1, QARegressExclude
Whiteboard: dsdsrun1.3-1, QARegressExclude → dsdsrun1.3-1, QARegressExclude [FT:RIL]
(In reply to Ivan Tsay (:ITsay) from comment #8)
> (In reply to Hsin-Yi Tsai  [:hsinyi] from comment #7)
> > (In reply to Hsin-Yi Tsai  [:hsinyi] from comment #6)
> > > As the blockers of this issue are fixed, I am wondering should this bug is
> > > fixed as well. qawanted for asking for QA's verifying. Thanks!
> > 
> > Sorry we need one more bug fixed before coming back to verify this issue
> > again. Clearing qawanted for now.
> 
> Set qawanted since the dependent bug is fixed.

Edward - Can you verify this is fixed now?
Flags: needinfo?(edchen)

Comment 11

4 years ago
Works now on Fugu

Fugu
Gaia      726ae682da9022bdccc057f29e836eff6a738677
Gecko     6ea72307375cfa123d2ec81f29ccc86976134b2a
BuildID   20140120153149
Version   28.0a2
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
Whiteboard: dsdsrun1.3-1, QARegressExclude [FT:RIL] → dsdsrun1.3-1, [FT:RIL]

Updated

4 years ago
Flags: needinfo?(edchen)
(Reporter)

Updated

4 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.