Closed Bug 949044 Opened 6 years ago Closed 6 years ago

App dimensions is not correctly resize after minimizing the call screen

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed)

RESOLVED FIXED
1.3 Sprint 6 - 12/6
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed

People

(Reporter: vingtetun, Assigned: vingtetun)

References

Details

Attachments

(2 files)

When the call screen is minimized apps are normally resized in order to fit the remaining space. This works great but when the call screen is closed, the next time the app is opened it has the wrong dimensions.

I found that the if (app.resized) app.resize() call in window_manager.js does not succeed since resize() wait for the app to be active.

Alive I don't understand the reason of this check, so I removed it. Let me know what are the side effects of that.

Also this patch only fix the issue for 1.3 for now. I need to check if it happens on 1.4 with the new window management code.
The patch may apply for 1.4 but i need to check that it happens here as well.
Component: Gaia::System → Gaia::System::Window Mgmt
Comment on attachment 8346039 [details] [diff] [review]
bug949044.patch for 1.3

Review of attachment 8346039 [details] [diff] [review]:
-----------------------------------------------------------------

The reason is I don't want a background app to be resized but if window manager has the correct active window reference this may be redundant.
I'll check this bug in AppWindow#v1.4 too.
Attachment #8346039 - Flags: review?(alive) → review+
This doesn't occur on v1.4 :)
Triager, are you looking at this bug ?
There was unfortunate some confusing involving who should triage Gaia::System::Window Mgmt but we will start triage this today.
blocking-b2g: 1.3? → 1.3+
Assignee: nobody → 21
Status: NEW → ASSIGNED
I've submitted a pull request to land the patch.
Vivien,

I tried to land this v1.3-only patch for you but it looks like there is a Travis-CI error. If it's not related please go ahead and merge it.
Flags: needinfo?(21)
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #9)
> Vivien,
> 
> I tried to land this v1.3-only patch for you but it looks like there is a
> Travis-CI error. If it's not related please go ahead and merge it.

Should not be. I will investigate and land it myself if needed. Thanks for trying :)
Flags: needinfo?(21)
Duplicate of this bug: 948611
Vivien, are you still working on this?
Flags: needinfo?(21)
PM retriaged this and we agree with the blocking status.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.3 Sprint 6 - 12/6
You need to log in before you can comment on or make changes to this bug.