Webpages tear while scrolling

VERIFIED FIXED in Firefox 26

Status

()

defect
--
major
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: anthonyjross, Assigned: jrmuizel)

Tracking

26 Branch
mozilla29
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox26 fixed, firefox27+ wontfix, firefox28+ verified, firefox29+ verified)

Details

Attachments

(3 attachments)

Posted image Firefox 1.JPG
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET4.0C; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)

Steps to reproduce:

I've ran my registry cleaner, checked flash player and ran anti virus and it continues to crash. Also I've uninstalled it and reinstalled and still get the same result


Actual results:

Firefox updated to the new version on my computer last night and once it went into Version 26 it continues to crash. the new version is not compatible with Windows XP


Expected results:

Firefox after doing its update should have worked like the previous verson that was working just fine.
Thanks for taking the time to report this!
Please follow the steps on http://support.mozilla.com/kb/Firefox%20crashes and report back here. Thanks!
Flags: needinfo?(anthonyjross)
(In reply to Andre Klapper from comment #1)
> Thanks for taking the time to report this!
> Please follow the steps on http://support.mozilla.com/kb/Firefox%20crashes
> and report back here. Thanks!

I've done all updates and scans on my computer and still Firefox is still not working properly there is something in the update to 26 that isn't allowing users with XP to use Firefox. Also Firefox was working perfectly fine before the update to 26 on the previous version of Firefox. I included in my original report an attachment to show you what is occurring.
Flags: needinfo?(anthonyjross)
Please follow the steps on http://support.mozilla.com/kb/Firefox%20crashes and report back here:
"Check to see if the crash happens in safe mode"
Flags: needinfo?(anthonyjross)
(In reply to Andre Klapper from comment #3)
> Please follow the steps on http://support.mozilla.com/kb/Firefox%20crashes
> and report back here:
> "Check to see if the crash happens in safe mode"

I have followed the steps provided and still on Firefox version 26 the same thing occurs when I bring up the browser as I showed you in my attachment. I just uninstalled Firefox Version 26 from my computer and reinstalled Firefox version 25.0.1 back on it and Firefox works without any issues with version 25.0.1. There is something in Version 26 that is causing issues as I showed you in the attachment I sent in my inital reporting. I am able to use Firefox without any issues with version 25.0.1 but with version 26 I have serious issues with it.
Flags: needinfo?(anthonyjross)
We are getting a significant amount of reports of this issue on Input and SUMO. It seems to be Windows only and appeared after the 26 update. We can work on tracking down a list of affected drivers if needed.

https://input.mozilla.org/en-US/?q=scroll&product=Firefox&locale=en-US&date_end=2013-12-13&date_start=2013-12-10&version=26.0.0&happy=0
Severity: normal → major
Component: Untriaged → Layout
Product: Firefox → Core
Summary: Firefox new version not compatible with XP → Webpages tear while scrolling
Whiteboard: [DUPEME]
Well Tyler I reinstalled Firefox Version 25.0.1 back on and have no issue you just have to go into options under Tools and under the advance Tab where Update is located is where you need to select check for updates but let me choose to install it. But as you stated with Firefox Version 26 I have the issues that you listed in your link, that's why I uninstalled Version 26 and reinstaled the previous Version of Firefox so I can use the browser.
(In reply to Tyler Downer [:Tyler] from comment #5)
> We are getting a significant amount of reports of this issue on Input and
> SUMO. It seems to be Windows only and appeared after the 26 update. We can
> work on tracking down a list of affected drivers if needed.
> 
> https://input.mozilla.org/en-US/?q=scroll&product=Firefox&locale=en-
> US&date_end=2013-12-13&date_start=2013-12-10&version=26.0.0&happy=0

Well Tyler I reinstalled Firefox Version 25.0.1 back on and have no issue you just have to go into options under Tools and under the advance Tab where Update is located is where you need to select check for updates but let me choose to install it. But as you stated with Firefox Version 26 I have the issues that you listed in your link, that's why I uninstalled Version 26 and reinstaled the previous Version of Firefox so I can use the browser.
Hey Anthony. We are trying to get more information on this issue so that we can figure out if it's a regression or other root cause. Would you be willing to work with me 1 on 1? We can take the conversation to email if you're willing. Thanks!
(In reply to Matt Grimes [:Matt_G] from comment #8)
> Hey Anthony. We are trying to get more information on this issue so that we
> can figure out if it's a regression or other root cause. Would you be
> willing to work with me 1 on 1? We can take the conversation to email if
> you're willing. Thanks!

Matt I'm willing to work with you via through here but so you know I'm back to using the previous version as the new version 26 kept failing and I was unable to use it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Anthony, could you attach the result of about:support (from 25.* is fine, just want to see what kind of graphics hardware/driver you have)

Jeff, the image grab looks very much like what you traced to driver StretchRect problem in bug 919454.  That was on Intel graphics GMA X4500HD, drivers range 6.14.10.5082 through 6.14.10.5160.
Flags: needinfo?(anthonyjross)
(In reply to Matt Grimes [:Matt_G] from comment #8)
> Hey Anthony. We are trying to get more information on this issue so that we
> can figure out if it's a regression or other root cause. Would you be
> willing to work with me 1 on 1? We can take the conversation to email if
> you're willing. Thanks!

Matt- I sent you the information you reguested a few days ago and I'm still awaiting word back from someone. Can I get an update?
(In reply to Milan Sreckovic [:milan] from comment #10)
> Anthony, could you attach the result of about:support (from 25.* is fine,
> just want to see what kind of graphics hardware/driver you have)
> 
> Jeff, the image grab looks very much like what you traced to driver
> StretchRect problem in bug 919454.  That was on Intel graphics GMA X4500HD,
> drivers range 6.14.10.5082 through 6.14.10.5160.

I've sent that information to Matt Grimes 2 days ago as I previously explained to Matt I went back to the previous version of Firefox since 26 continues to malfunction and the other version works but 26 doesn't. If you want I can sent you the same information as I sent Matt Grimes?
Flags: needinfo?(anthonyjross)
Matt is on vacation the rest of the year, please post the information to this bug :) Thanks!
(In reply to Tyler Downer [:Tyler] from comment #13)
> Matt is on vacation the rest of the year, please post the information to
> this bug :) Thanks!

OK Tyler I wish Matt would have said something when he requested the information from me this past Saturday evening. I will email you and Milan the information
(In reply to Tyler Downer [:Tyler] from comment #13)
> Matt is on vacation the rest of the year, please post the information to
> this bug :) Thanks!

Tyler I just emailed you the information the Matt requested a few days ago of both version of Firefox I am currently back to using version 25.0.1 since that works and 26 doesn't. Also Matt believed it was a driver issue within version 26 and that is where we left it a few days ago.
Graphics

Adapter Description
	

Intel(R) G41 Express Chipset

Adapter Drivers
	

igxprd32

Adapter RAM
	

Unknown

Device ID
	

0x2e32

Direct2D Enabled
	

Blocked for your graphics driver version.

DirectWrite Enabled
	

false (0.0.0.0)

Driver Date
	

1-12-2010

Driver Version
	

6.14.10.5215

GPU #2 Active
	

false

GPU Accelerated Windows
	

1/1 Direct3D 9

Vendor ID
	

0x8086

WebGL Renderer
	

Google Inc. -- ANGLE (Intel(R) G41 Express Chipset Direct3D9 vs_3_0 ps_3_0)

windowLayerManagerRemote
	

false

AzureCanvasBackend
	

skia

AzureContentBackend
	

none

AzureFallbackCanvasBackend
	

cairo

AzureSkiaAccelerated
	

0
Got it, thanks.  Sorry for the duplication.
The driver version is 6.14.10.5215.  We blocklisted 6.14.10.5082 through 6.14.10.5160, perhaps this problem came back in later driver versions?  I also see that Firefox 25 suggests updating the driver to 6.14.10.5284 or newer.
Component: Layout → Graphics: Layers
Assignee: nobody → jmuizelaar
Blocks: 919454
Whiteboard: [DUPEME]
(In reply to Milan Sreckovic [:milan] from comment #17)
> Got it, thanks.  Sorry for the duplication.

Would you like that I update to 26 again to see if it will work?
One workaround is to go to preferences, advanced, and set disable "Use hardware acceleration when available".  Does that fix the problem for you?
See also bug 951422.  If we go the downloadable route, we won't be able to ever relax it.  This bug will track the actual "in code" fix.
I just reinstalled and updated all Intel Drivers on my computer and reinstalled Firefox Version 26 and at this time I'm happy to report I'm having issues with Version 26 at this time. I will continue to run the browser to see if all is working properly and report back within 24 hours.
I'm happy to report that Version 26 of the Firefox hasn't crashed or have I had any additional issues with it since the fixes recomended 48 hours about. I'm to report that all is good and working properly.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
(In reply to Anthony from comment #25)
> I'm happy to report that Version 26 of the Firefox hasn't crashed or have I
> had any additional issues with it since the fixes recomended 48 hours about.
> I'm to report that all is good and working properly.

Great, thanks for all your help.  This went away because of the fix in bug 951422.
See Also: → 951422
Tracking this and marking affected for the in-code fix needed for beta/aurora/nightly
Attachment #8349068 - Flags: review?(jmuizelaar) → review+
Re-opening this so that we land the "in code" solution.
Status: RESOLVED → REOPENED
Keywords: checkin-needed
Resolution: WORKSFORME → ---
https://hg.mozilla.org/mozilla-central/rev/211e9db554c8
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Ni on Jeff to help with aurora/beta uplift.
Flags: needinfo?(jmuizelaar)
I wouldn't bother with the uplift.  This is fixed in the downloadable blocklist (with bug 951422) and will stay there "forever", and certainly beyond when this fix gets released (so that it covers the older versions).
I think it's worth fixing in Aurora/Beta because without it, a user could have a bad first run experience.
Flags: needinfo?(jmuizelaar) → needinfo?(bbajaj)
(In reply to Jeff Muizelaar [:jrmuizel] from comment #33)
> I think it's worth fixing in Aurora/Beta because without it, a user could
> have a bad first run experience.

That was the intention in comment #31, but I am confused now based on comment #32's response. Does the block not help in those situation. Can you help  understand ?

Also note, we only have one beta left this cycle for Fx27 which will go-to-build on Thursday. Would need risk evaluation explaining if this is super safe for our final beta.
Flags: needinfo?(bbajaj) → needinfo?(jmuizelaar)
Comment on attachment 8349068 [details] [diff] [review]
Extend the block list range to (excluding) 6.14.10.5218.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 904266
User impact if declined: Possible bad first run experience on affected systems.  After the first run, the downloadable list will kick in and the bad systems will be blocked.  This fix is before that downloadable update.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): Bad first run.
String or IDL/UUID changes made by this patch:
Attachment #8349068 - Flags: approval-mozilla-beta?
Attachment #8349068 - Flags: approval-mozilla-aurora?
Flags: needinfo?(jmuizelaar)
(In reply to Milan Sreckovic [:milan] from comment #35)
> Comment on attachment 8349068 [details] [diff] [review]
> Extend the block list range to (excluding) 6.14.10.5218.
> 
> [Approval Request Comment]
> Bug caused by (feature/regressing bug #): 904266
> User impact if declined: Possible bad first run experience on affected
> systems.  After the first run, the downloadable list will kick in and the
> bad systems will be blocked.  This fix is before that downloadable update.
> Testing completed (on m-c, etc.): 
> Risk to taking this patch (and alternatives if risky): Bad first run.
> String or IDL/UUID changes made by this patch:

We have already gone to build with our final Release candidate for Fx27 here and its too late for beta's given all the beta's are completed. Unless we think this is something that will cause a very bad user experience and be a driver for a dot release for Fx27.0 let's wontfix this for Fx27 at this point.
Attachment #8349068 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(In reply to bhavana bajaj [:bajaj] from comment #36)
> (In reply to Milan Sreckovic [:milan] from comment #35)
> > Comment on attachment 8349068 [details] [diff] [review]
> > Extend the block list range to (excluding) 6.14.10.5218.
> > 
> > [Approval Request Comment]
> > Bug caused by (feature/regressing bug #): 904266
> > User impact if declined: Possible bad first run experience on affected
> > systems.  After the first run, the downloadable list will kick in and the
> > bad systems will be blocked.  This fix is before that downloadable update.
> > Testing completed (on m-c, etc.): 
> > Risk to taking this patch (and alternatives if risky): Bad first run.
> > String or IDL/UUID changes made by this patch:
> 
> We have already gone to build with our final Release candidate for Fx27 here
> and its too late for beta's given all the beta's are completed. Unless we
> think this is something that will cause a very bad user experience and be a
> driver for a dot release for Fx27.0 let's wontfix this for Fx27 at this
> point.

Approving for aurora though for this to be resolved in Fx28
Attachment #8349068 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
Keywords: verifyme
Verified by spoofing my graphic card to the following values:

MOZ_GFX_SPOOF_DEVICE_ID = 0x2e32
MOZ_GFX_SPOOF_DRIVER_VERSION = 6.14.10.5215
MOZ_GFX_SPOOF_VENDOR_ID = 0x8086

FF 28
User Agent:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0
Build Id: 20140203225656

The graphic card driver version is blocked.
Mozilla/5.0 (Windows NT 5.1; rv:29.0) Gecko/20100101 Firefox/29.0

Verified that 'Driver Version 6.14.10.5215' is blocked after spoofing the GPU to this values:
MOZ_GFX_SPOOF_DEVICE_ID = 0x2e32
MOZ_GFX_SPOOF_DRIVER_VERSION = 6.14.10.5215
MOZ_GFX_SPOOF_VENDOR_ID = 0x8086

The testing was done on Firefox 29 beta 4 (buildID: 20140331125246).
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.