[B2G][Contacts] The user will get stuck on the export screen when exporting contacts to the SIM that has no space available for the exported contacts

VERIFIED FIXED in Firefox OS v1.3

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: KTucker, Assigned: jmcf)

Tracking

unspecified
1.3 C2/1.4 S2(17jan)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g18 unaffected, b2g-v1.2 affected, b2g-v1.3 verified)

Details

(Whiteboard: dogfood1.2)

Attachments

(5 attachments)

Created attachment 8346702 [details]
ExportSIM.txt

Description:
If the user starts exporting their contacts to the SIM and presses the home button on their phone, they will notice that the contacts app will be stuck on the export screen. 

Repro Steps:
1)  Updated Buri to Build ID: 20131212004004
2)  Tap on the "Contacts app" icon.
3)  Tap on the "Gear" icon to open settings.
4)  Tap on "Export Contacts".
5)  Tap on the "SIM card" option.
6)  Tap on "Select all" and then tap on "Export". 
7)  Tap on the "Home Button" on the phone.
8)  Tap on the "Contacts app" icon again and observe.

Actual:
The user will be stuck on the "Export to SIM" screen and will have to force close the app.

Expected:
The user can export their contacts to the SIM without issue.

Environmental Variables
Device: Buri v 1.2.0 COM RIL
Build ID: 20131212004004
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/8bae10bb0aed
Gaia: 6d02039072a2ae5cf9225a6f4c78ed49decfab5c
Platform Version: 26.0
RIL Version: 01.02.00.019.102 

Notes:
Repro frequency: 100%
See attached: Video, Logcat
This issue does not occur on Buri v 1.1.0 COM RIL 

Environmental Variables
Device: Buri v 1.1.0 COM RIL
Build ID: 20131210041202
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/05117f42088f
Gaia: 6ff3a607f873320d00cb036fa76117f6fadd010f
Platform Version: 18.1
RIL Version: 01.01.00.019.281 

There is not an option to export contacts on v 1.1.0.
Created attachment 8346707 [details]
ExportSIM.mp4
This sucks, but it's likely not terribly hard to recover from.
The user can force close the contacts app or restart their phone to recover. Adding the regression keywords since this worked before on v 1.2.0
Keywords: regression, regressionwindow-wanted
I apologize but the export to SIM is not functioning period. The user does not even have to go home on the device to get stuck on the export screen. I should have researched this issue more.
Summary: [B2G][Contacts] Pressing home while exporting contacts to the SIM causes it to be stuck on the export screen → [B2G][Contacts] The user will get stuck on the export screen when exporting contacts to the SIM

Updated

5 years ago
blocking-b2g: --- → koi?

Updated

5 years ago
QA Contact: sparsons

Comment 6

5 years ago
This issue started to occur on the Buri 1.2 Build ID 20130823040202

Gaia   72d9989f759099632c3d3b8b5335b7d12d969d2f
SourceStamp fb2318875cd4
BuildID 20130823040202
Version 26.0a1

Last working Buri 1.2 Build ID: 20130822040202

Gaia   abd81ff5e49bf0c9479cdc5c5eb6975cc776f632
SourceStamp 2ab07dec6404
BuildID 20130822040202
Version 26.0a1
Keywords: regressionwindow-wanted
Weird - so apparently this problem is only present on 1.2. Doesn't reproduce on 1.3 or 1.4.
status-b2g-v1.3: --- → unaffected
status-firefox29: --- → unaffected

Comment 8

5 years ago
Created attachment 8347349 [details]
949594_logcat

Logcat attached from 12/13 Buri 1.2
Does this reproduce on a 1.2 Moz RIL?
Keywords: qawanted

Comment 10

5 years ago
Yes, this issue also reproduces on the 1.2 Moz RIL.
Keywords: qawanted
(Assignee)

Updated

5 years ago
Assignee: nobody → jmcf
(Assignee)

Comment 11

5 years ago
Hi guys,

With the latest v1.2 I've been able to export > 100 contacts to a SIM card using unagi and moz RIL. Please could you retest this with the latest 1.2 build you can get, maybe some related bugs such as bug 943234 could not have landed on your version.

thanks!
Flags: needinfo?(ktucker)
(In reply to Jose M. Cantera from comment #11)
> Hi guys,
> 
> With the latest v1.2 I've been able to export > 100 contacts to a SIM card
> using unagi and moz RIL. Please could you retest this with the latest 1.2
> build you can get, maybe some related bugs such as bug 943234 could not have
> landed on your version.
> 
> thanks!

I don't think a retest will do any value here. The bug in question here landed on 12/12, which means a 12/13 1.2 build would have the patch. comment 10 indicates this still reproducible on 12/13 - I know for the fact the QA Analysts have checked this multiple times to confirm that this is reproducing.

I think this could be SIM-specific. We need to find out why however & which SIMs could be affected. Would RIL logs help?
Flags: needinfo?(ktucker)
Enpei - Do you know or can you find out if exporting contacts to SIM is not allowed by certain SIMs?
Flags: needinfo?(echu)
(Assignee)

Comment 14

5 years ago
(In reply to Jason Smith [:jsmith] from comment #12)
> (In reply to Jose M. Cantera from comment #11)
> > Hi guys,
> > 
> > With the latest v1.2 I've been able to export > 100 contacts to a SIM card
> > using unagi and moz RIL. Please could you retest this with the latest 1.2
> > build you can get, maybe some related bugs such as bug 943234 could not have
> > landed on your version.
> > 
> > thanks!
> 
> I don't think a retest will do any value here. The bug in question here
> landed on 12/12, which means a 12/13 1.2 build would have the patch. comment
> 10 indicates this still reproducible on 12/13 - I know for the fact the QA
> Analysts have checked this multiple times to confirm that this is
> reproducing.
> 
> I think this could be SIM-specific. We need to find out why however & which
> SIMs could be affected. Would RIL logs help?

Sure, please attach them.
QA Wanted - let's get RIL logs here when this reproduces.
Keywords: qawanted

Comment 16

5 years ago
Created attachment 8348845 [details]
SP_RIL_Log

This issue reproduces on the Buri 1.2 Build ID: 20131217004001, See RIL log attached. 

Gaia   4f53ba8b3628ac311253fc28dfdf66e7ba6832de
SourceStamp 129ad3c335a5
BuildID 20131217004001
Version 26.0

Updated

5 years ago
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #13)
> Enpei - Do you know or can you find out if exporting contacts to SIM is not
> allowed by certain SIMs?

Another question for you - can you hunt down a RIL person in office to take a look at RIL logs to see what's failing here?

Comment 18

5 years ago
(In reply to Jason Smith [:jsmith] from comment #13)
> Enpei - Do you know or can you find out if exporting contacts to SIM is not
> allowed by certain SIMs?

Suppose all SIM should have room for 250 contacts. I don't recall there is any special case. Besides, did you imply that function works with same SIM on v1.3 or v1.4 in comment 7? If not, can reporter help to reproduce this on other OS smartphone to see if it's card related bug?
Flags: needinfo?(echu)
(In reply to Enpei from comment #18)
> (In reply to Jason Smith [:jsmith] from comment #13)
> > Enpei - Do you know or can you find out if exporting contacts to SIM is not
> > allowed by certain SIMs?
> 
> Suppose all SIM should have room for 250 contacts. I don't recall there is
> any special case. Besides, did you imply that function works with same SIM
> on v1.3 or v1.4 in comment 7? If not, can reporter help to reproduce this on
> other OS smartphone to see if it's card related bug?

QA Wanted for the above comment - can someone test this with a different smartphone OS with the affected SIM card to see what happens?

Also more information is needed on the SIM - how many contacts are being exported? What do they contain?
Keywords: qawanted

Comment 20

5 years ago
(In reply to Jason Smith [:jsmith] from comment #19)
> (In reply to Enpei from comment #18)
> > (In reply to Jason Smith [:jsmith] from comment #13)
> > > Enpei - Do you know or can you find out if exporting contacts to SIM is not
> > > allowed by certain SIMs?
> > 
> > Suppose all SIM should have room for 250 contacts. I don't recall there is
> > any special case. Besides, did you imply that function works with same SIM
> > on v1.3 or v1.4 in comment 7? If not, can reporter help to reproduce this on
> > other OS smartphone to see if it's card related bug?
> 
> QA Wanted for the above comment - can someone test this with a different
> smartphone OS with the affected SIM card to see what happens?
> 
> Also more information is needed on the SIM - how many contacts are being
> exported? What do they contain?
And please check if SIM card already full, usually contact app in Android phone can tell how many contacts in SIM card.
Going to hold on the nom based on Enpei's comments - we need more information on the SIM setup here to understand what's failing here.
blocking-b2g: koi? → ---
(In reply to Sarah Parsons from comment #16)
> Created attachment 8348845 [details]
> SP_RIL_Log
> 
> This issue reproduces on the Buri 1.2 Build ID: 20131217004001, See RIL log
> attached. 
> 
> Gaia   4f53ba8b3628ac311253fc28dfdf66e7ba6832de
> SourceStamp 129ad3c335a
> BuildID 20131217004001
> Version 26.0

Hi, Sarah
In this log only some fragment logs are captured, can you attach a more complete log for us?

Thanks

Comment 23

5 years ago
In reply to Enpei in comment 18. I think you may be correct. I was able to reproduce this issue but only with a full SIM.

I checked 3 different SIM cards. The first was an AT&T SIM with 250 contacts on it, the second was an AT&T SIM with no contacts on it, and the third was a T-mobile SIM with 1 contact. Only the one with 250 contacts reproduced this issue.
(Assignee)

Comment 24

5 years ago
Yoshi,

Is Gecko returning any error code when SIM is full and more contacts cannot be added?
Flags: needinfo?(allstars.chh)
Updating title to the problem here - the problem here is that we get stuck on the export contact screen if a user tries to export contacts to a SIM card with no more space available to fit the exported contacts.
Summary: [B2G][Contacts] The user will get stuck on the export screen when exporting contacts to the SIM → [B2G][Contacts] The user will get stuck on the export screen when exporting contacts to the SIM that has no space available for the exported contacts
Now that we understand the bug more clearly - can we test to see if this reproduces on 1.3 & 1.4 with the 250 contact AT&T SIM? Specifically, I'm looking to see if an error is fired on 1.3 or 1.4.
status-b2g-v1.3: unaffected → ---
status-firefox29: unaffected → ---

Comment 27

5 years ago
This issue does not reproduce on either Buri 1.3 or 1.4. When the user attempts to export contacts to a full SIM, a message appears that says 0 Contacts are loaded, then the user is returned to contact settings. 

Gaia   e2f0e09e980b1cb3275a0bb033931cb48f9d521c
SourceStamp 862cb6a1cc88
BuildID 20131218040201
Version 29.0a1


BuildID: 20131218004002
Gaia: a99b23e73fe5630a877004746d0e7fcec1b6d653
SourceStamp: 369bdbff6c38
Version: 28.0a2
Keywords: qawanted
(In reply to Sarah Parsons from comment #27)
> This issue does not reproduce on either Buri 1.3 or 1.4. When the user
> attempts to export contacts to a full SIM, a message appears that says 0
> Contacts are loaded, then the user is returned to contact settings. 
> 
> Gaia   e2f0e09e980b1cb3275a0bb033931cb48f9d521c
> SourceStamp 862cb6a1cc88
> BuildID 20131218040201
> Version 29.0a1
> 
> 
> BuildID: 20131218004002
> Gaia: a99b23e73fe5630a877004746d0e7fcec1b6d653
> SourceStamp: 369bdbff6c38
> Version: 28.0a2

Well that sounds like a different UX workflow, but still represents a bug here. We should be reporting an error if the SIM is full.
(In reply to Jose M. Cantera from comment #24)
> Yoshi,
> 
> Is Gecko returning any error code when SIM is full and more contacts cannot
> be added?

yes, onerror will be called and the errorMsg will be NoFreeRecordFound.
Flags: needinfo?(allstars.chh)
BTW, the maximum contacts can be stored on SIM card is a multiple of 254, i.e. 254, 508, 762, ....

If you say your SIMcard already has 250 contacts, I don't think it's full yet.

Comment 31

5 years ago
(In reply to Jason Smith [:jsmith] from comment #28)
> (In reply to Sarah Parsons from comment #27)
> > This issue does not reproduce on either Buri 1.3 or 1.4. When the user
> > attempts to export contacts to a full SIM, a message appears that says 0
> > Contacts are loaded, then the user is returned to contact settings. 
> > 
> > Gaia   e2f0e09e980b1cb3275a0bb033931cb48f9d521c
> > SourceStamp 862cb6a1cc88
> > BuildID 20131218040201
> > Version 29.0a1
> > 
> > 
> > BuildID: 20131218004002
> > Gaia: a99b23e73fe5630a877004746d0e7fcec1b6d653
> > SourceStamp: 369bdbff6c38
> > Version: 28.0a2
> 
> Well that sounds like a different UX workflow, but still represents a bug
> here. We should be reporting an error if the SIM is full.

I've filed bug 944648 for this.
Removing regression keyword because I don't think this worked out of box when this feature landed.
Keywords: regression
(Assignee)

Comment 33

5 years ago
Created attachment 8356638 [details]
15072.html
Attachment #8356638 - Flags: review?(francisco.jordano)
(Assignee)

Updated

5 years ago
blocking-b2g: --- → 1.3?
how much effort is this fix? or how risky is this?
Flags: needinfo?(jmcf)
(Assignee)

Comment 35

5 years ago
issue is essentially fixed. pending r+ from Francisco. Low risk patch, tests included. Good improvement for the user

thanks
Flags: needinfo?(jmcf)
triage: 1.3+
blocking-b2g: 1.3? → 1.3+
Comment on attachment 8356638 [details]
15072.html

Pretty awesome work, thanks Jose Manuel
Attachment #8356638 - Flags: review?(francisco.jordano) → review+
(Assignee)

Comment 38

5 years ago
https://github.com/mozilla-b2g/gaia/commit/8e48f71f8284f342ef482e8b399c4775725a531d
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Keywords: verifyme
Uplifted 8e48f71f8284f342ef482e8b399c4775725a531d to:
v1.3: 152565532ae094aa8a63120c2c23099e2818d081
status-b2g-v1.3: --- → fixed

Updated

5 years ago
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)

Comment 40

5 years ago
Verified on latest Buri v1.3. The user no longer gets stuck on the export screen when exporting contacts to SIM.

Environmental Variables:
Device: Buri v1.3 mozRIL
BuildID: 20140128004000
Gaia: 3c5119507a985c59cfc264ed23821679b138486d
Gecko: 4936f09590a0
Version: 28.0a2
v1.2-device.cfg
Status: RESOLVED → VERIFIED
status-b2g-v1.3: fixed → verified
Keywords: verifyme

Updated

5 years ago
Duplicate of this bug: 944648
You need to log in before you can comment on or make changes to this bug.