[B2G][Settings] Pressing home whilst in keyboard settings will not return the user to the home screen.

VERIFIED DUPLICATE of bug 947033

Status

Firefox OS
Gaia::Settings
VERIFIED DUPLICATE of bug 947033
5 years ago
5 years ago

People

(Reporter: Harvey, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.2 unaffected, b2g-v1.3 affected)

Details

(Whiteboard: burirun1.3-1)

(Reporter)

Description

5 years ago
[B2G][Settings] Pressing home within the keyboard settings will not return the user to the home screen. 

Description:
If the user goes into keyboard settings and into Built-in Keyboard, then goes back and goes into Selected keyboards and Add more keyboards, if the user then presses the Home button the screen will go home for a second then reappear with the keyboard settings page.

Repro Steps:
1) Updated Buri 1.3 20131211004003
2) Select Settings.
3) Select Built-in Keyboard.
4) Go back.
5) Select Selected Keyboards.
6) Select Add more keyboards.
7) Press the Home button.

Actual:
The screen goes home but then goes back to keyboard settings.

Expected:
The home screen remains in focus.

Environmental Variables:
Device: Buri 1.3
BuildID: 20131211004003
Gaia: 7a2ccae2a546ac4d981d250272dafa630c926422
Gecko: 6bb84d0bc170
Version: 28.0a2
(Reporter)

Comment 1

5 years ago
This issue does not reproduce on Buri 1.2

Environmental Variables:
Device: Buri v1.2 Con RIL
BuildID: 20131212004004
Gaia: 6d02039072a2ae5cf9225a6f4c78ed49decfab5c
Gecko: 8bae10bb0aed
Version: 26.0
status-b2g-v1.2: --- → unaffected
status-b2g-v1.3: --- → affected
Whiteboard: burirun1.3-1
The home button pretty much always has to work.
blocking-b2g: --- → 1.3?
Keywords: regression, regressionwindow-wanted

Updated

5 years ago
QA Contact: nkhristoforov

Comment 3

5 years ago
The regression window for this bug is 12-03 to 12-04.

Last Working Build:
Device: Buri v1.3 MOZ
BuildID: 20131203151100
Gaia: df070d4eed244e782dd3a7c2a7586d0741eac09f
Gecko: 9ac7ed427cd2
Version: 28.0a1
Base Image: V1.2_20131115

First Broken Build:
Device: Buri 1.3 MOZ
BuildID: 20131204040204
Gaia: 45564d6318cdab2fae2de0eb801308e2bcf4e472
Gecko: 9688476c1544
Version: 28.0a1
Base Image: V1.2_20131115
Keywords: regressionwindow-wanted
With bug 947033 in the build I can no longer reproduce this bug. qawanted.

Triage: +'ing since this is pretty annoying.
blocking-b2g: 1.3? → 1.3+

Comment 5

5 years ago
This issue does not reproduce in the latest Buri Mozilla 1.4 build, but does still reproduce in the latest 1.3.

Comment 7 in bug 948700 stated the patch for this issue (see bug 947033) has not yet been uplifted to the 1.3 branch.

As bug 947033 has been referenced in both 949677 and 948700, I'd suggest we dupe both bugs to 948700. All issues seem to stem from the same issue and be fixed by the same patch.

1.3 Environmental Variables (Issue still reproducing):
Device: Buri v1.3 Mozilla RIL
BuildID: 20131219004002
Gaia: a99249a7fdf9f20850d98a9a222385676d472362
Gecko: 809aabadac6d
Version: 28.0a2
Base Image: V1.2_20131115

1.4 Environmental Variables (Issue NOT reproducing):
Device: Buri v1.4 Mozilla RIL
BuildID: 20131219040202
Gaia: e6276c96fcf087a12800419be8a9e25fcbbc924d
Gecko: 5c7fa2bfea8b
Version: 29.0a1
Base Image: V1.2_20131115
Keywords: qawanted

Comment 6

5 years ago
Tim, in your point of view, who would be the best one to check this bug? Thank you.
Flags: needinfo?(timdream)
(In reply to J Zimbrick from comment #5)
> As bug 947033 has been referenced in both 949677 and 948700, I'd suggest we
> dupe both bugs to 948700. All issues seem to stem from the same issue and be
> fixed by the same patch.
>
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(timdream)
Resolution: --- → DUPLICATE
Duplicate of bug: 948700

Comment 9

5 years ago
Verified it.
Thanks!

* Build Information:
 - Gaia      5de94a2be6ab8d33434294d70c1de330f55d8f2d
 - Gecko     http://hg.mozilla.org/mozilla-central/rev/c8d5a871ae32
 - BuildID   20140101040201
 - Version   29.0a1

* Result:
  Cannot reproduce
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.